Visualizzazione errata del desktop di Windows e comparsa del messaggio di errore "Applicazione non correttamente inizializzata (0xc00000005)" dopo aver attivato la funzionalitÓ Norton CleanSweep Smart Sweep in Windows XP Service Pack 2

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Importante In questo articolo vengono fornite informazioni che consentono di ridurre il livello delle impostazioni di protezione o di disattivare le funzionalitÓ di protezione in un computer. ╚ possibile apportare queste modifiche per risolvere un problema specifico. Prima di apportare tali modifiche, si consiglia di valutare i rischi derivanti dall'implementazione di questa soluzione in un ambiente particolare. Se si sceglie di implementare questa soluzione, adottare ogni ulteriore procedura che faciliti la protezione del sistema.
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Sintomi

╚ possibile che si sperimentino entrambi i sintomi seguenti quando si riavvia il computer basato su Microsoft Windows XP Service Pack 2 (SP2) o quando ci si disconnette e poi ci si riconnette al computer. Questi sintomi si manifestano dopo avere attivato la funzionalitÓ Smart Sweep in Norton CleanSweep:
  • Viene visualizzato il messaggio di errore seguente:
    Explorer.exe - Errore di applicazione

    Applicazione non correttamente inizializzata (0xc00000005).
    Fare clic su OK per chiudere l'applicazione.
  • Il desktop di Windows non viene visualizzato correttamente e non Ŕ possibile eseguire Windows.

Cause

Questo problema pu˛ verificarsi in presenza di tutte le seguenti condizioni:
  • Si esegue Windows XP SP2 su un computer basato sul processore AMD Athlon 64.
  • Nel file Boot.ini Ŕ attivata l'opzione /noexecute di Protezione esecuzione programmi.
  • Norton CleanSweep Ŕ configurato per caricare e monitorare automaticamente le installazioni all'avvio di Windows.

Workaround

Per ovviare a questo problema, disattivare Protezione esecuzione programmi in Windows, rimuovere Norton SystemWorks e quindi riattivare Protezione esecuzione programmi. A questo scopo, attenersi alla procedura seguente:

Avviso L'esecuzione di questa procedura potrebbe rendere il computer o la rete pi¨ vulnerabile agli attacchi di utenti malintenzionati o di programmi software dannosi, quali i virus. Non Ŕ consigliabile utilizzare questa soluzione, tuttavia queste informazioni vengono fornite per consentire all'utente di implementarla a propria discrezione. L'utilizzo di questa soluzione avviene pertanto a rischio esclusivo dell'utente.
  1. Avviare Windows in modalitÓ provvisoria. A questo scopo, attenersi alla procedura seguente:
    1. Avviare il computer e premere F8 al termine della procedura di verifica automatica dell'avvio (POST).
    2. Nel menu delle opzioni avanzate di Windows utilizzare i tasti di direzione per selezionare la modalitÓ provvisoria, quindi premere INVIO.
    3. Utilizzare i tasti di direzione per selezionare Windows XP, quindi premere INVIO.
    4. Accedere al computer, quindi scegliere per operare in modalitÓ provvisoria.
  2. Fare clic sul pulsante Start, scegliere Esegui, digitare cmd nella casella Apri, quindi scegliere OK.
  3. Passare alla radice del disco rigido in cui Ŕ installato Windows. In genere Ŕ l'unitÓ C. A questo scopo, digitare c:, premere INVIO, digitare cd\ e premere INVIO.
  4. Digitare attrib -s -h boot.ini, quindi premere INVIO per rimuovere l'attributo Nascosto e l'attributo Sistema dal file Boot.ini.
  5. Fare clic sul pulsante Start, scegliere Esegui, digitare notepad c:\boot.ini, quindi scegliere OK. Il file Boot.ini verrÓ aperto in Blocco note.
  6. Nella sezione [operating systems] copiare e incollare il percorso del sistema operativo Windows dell'installazione in uso.
  7. Rimuovere l'opzione seguente dal percorso del sistema operativo incollato:
    /noexecute=optin
  8. Salvare le modifiche al file Boot.ini e chiudere il Blocco note.
  9. Riavviare il computer.
  10. Nel menu di avvio utilizzare i tasti di direzione per selezionare la seconda voce di sistema operativo, ovvero quella dalla quale Ŕ stata rimossa l'opzione /noexecute=optin dal percorso, quindi premere INVIO.
  11. Accedere a Windows, quindi rimuovere il programma Norton CleanSweep. Per ulteriori informazioni su come rimuovere Norton CleanSweep, rivolgersi al produttore del programma. Per informazioni su come contattare Symantec, fare clic sul numero dell'articolo appropriato della Microsoft Knowledge Base riportato di seguito:
    65416 Elenco dei contatti relativi ai fornitori di terze parti di hardware e software, A-K

    60781 Elenco dei contatti relativi ai fornitori di terze parti di hardware e software, L-P

    60782 Elenco dei contatti relativi ai fornitori di terze parti di hardware e software, Q-Z
  12. Riavviare il computer, quindi utilizzare Blocco note per modificare il file Boot.ini. Rimuovere il secondo percorso di sistema operativo aggiunto al passaggio 6.
  13. Ripristinare gli attributi Nascosto e Sistema del file Boot.ini. A questo scopo, attenersi alla procedura seguente:
    1. Fare clic sul pulsante Start, scegliere Esegui, digitare cmd nella casella Apri, quindi scegliere OK.
    2. Passare alla radice del disco rigido in cui Ŕ installato Windows.
    3. Digitare attrib +s +h boot.ini, quindi premere INVIO.
    4. Digitare exit, quindi premere INVIO.
  14. Riavviare il computer.

Informazioni

Per ulteriori informazioni sull'opzione /noexecute in Windows XP SP2, visitare il seguente sito Web Microsoft (informazioni in lingua inglese):
http://www.microsoft.com/technet/prodtechnol/winxppro/maintain/sp2mempr.mspx
I prodotti di terze parti citati in questo articolo sono forniti da produttori indipendenti. Microsoft non rilascia alcuna garanzia implicita o esplicita relativa alle prestazioni o all'affidabilitÓ di tali prodotti. Microsoft fornisce informazioni su come contattare altri produttori allo scopo di facilitare l'individuazione del supporto tecnico. Queste informazioni sono soggette a modifica senza preavviso. Microsoft non si assume alcuna responsabilitÓ sull'accuratezza delle informazioni relative al contatto con altri produttori.
Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
289022 Modifica del file Boot.ini in Windows XP

ProprietÓ

Identificativo articolo: 873155 - Ultima modifica: lunedý 19 marzo 2007 - Revisione: 2.4
Le informazioni in questo articolo si applicano a
  • Microsoft Windows XP Professional Service Pack 2 (SP2)
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