Article ID: 873188 - Last Review: November 11, 2004 - Revision: 2.2

You cannot scan images with a network scanner when Windows Firewall is turned on in Windows XP Service Pack 2 or in Windows XP Tablet PC Edition 2005

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SYMPTOMS

If you turn on Windows Firewall and then select Allow this computer to use a network scanner in the Scanner and Camera window in Control Panel, you cannot use the Scanner and Camera Wizard to access a network scanner.

CAUSE

This problem occurs because Windows Firewall blocks TCP port 21. This port is required.

WORKAROUND

To work around this problem, you must create a Windows Firewall exception for TCP port 21. To do this, follow these steps:
  1. Click Start, click Run, type firewall.cpl, and then click OK.
  2. In the Windows Firewall dialog box, click the Exceptions tab, and then click Add Port.
  3. In the Add a Port dialog box, type Scanner and Camera Wizard in the Name: text box.
  4. In the Port number: text box, type 21.
  5. Click TCP, and then click OK.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

APPLIES TO
  • Microsoft Windows XP Home Edition Service Pack 2 (SP2)
  • Microsoft Windows XP Media Center Edition Service Pack 2 (SP2)
  • Microsoft Windows XP Professional Service Pack 2 (SP2)
  • Microsoft Windows XP Tablet PC Edition 2005
Keywords: 
kbwinxpsp2rel kbperformance kbconfig kbnofix kbconsumer kbhardware kbdriver kbnetwork kbfirewall kbtshoot kbbug KB873188