An event ID 10010 error message may be logged many times in the event log of your Windows Server 2003-based computer that is running Terminal Services

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Article ID: 873375 - View products that this article applies to.
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SYMPTOMS

Either of the following error messages may be logged many times in the event log of your Microsoft Windows Server 2003-based computer that is running Terminal Services.

The following event ID error message may be logged in the event log if the Citrix MetaFrame program is installed on your terminal server:

Event Type: Error
Event Source: DCOM
Event Category: None
Event ID: 10010
Description: The server 601ac3dc-786a-4eb0-bf40-ee3521e70bfb did not register with DCOM within the required timeout.

The following event ID error message may be logged in the event log if the Network Crawler program is installed on your terminal server:

Event Type: Error
Event Source: DCOM
Event Category: None
Event ID: 10010
Description: The server Network Crawler did not register with DCOM within the required timeout.

CAUSE

This problem occurs because the Windows Explorer operating system shell is not running on the terminal server. When a Component Object Model (COM) object tries to register, it posts a registration message to the Windows Explorer shell. Because the Windows Explorer shell is not running, the registration message times out. Subsequently, the COM component logs the event ID error message on the terminal server.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003 32-bit editions

Date         Time   Version            Size    File name     Platform
---------------------------------------------------------------------
11-Aug-2004  17:03  6.0.3790.198    8,171,008  Shell32.dll   x86 

Windows Server 2003 64-bit edition

Date         Time   Version            Size    File name     Platform
---------------------------------------------------------------------
11-Aug-2004  17:05  6.0.3790.198   12,960,768  Shell32.dll   IA-64
11-Aug-2004  17:03  6.0.3790.198    8,171,008  Wshell32.dll  x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 873375 - Last Review: July 24, 2007 - Revision: 2.10
APPLIES TO
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbbug kbfix kbwinserv2003presp1fix KB873375

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