Slow performance when you apply Access Control Lists remotely on a DFS shared path in Windows Server 2003

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Article ID: 873407 - View products that this article applies to.
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SYMPTOMS

When you modify Access Control Lists (ACLs) in Windows Explorer through a Distributed File System (DFS) shared path, the ACLs may take a long time to apply. When many subfolders and files exist in the DFS shared path, Windows Explorer may appear to stop responding (hang).

CAUSE

The problem occurs because each subfolder and each file is checked to see if the subfolder or the file is a DFS junction.

RESOLUTION

Microsoft Windows Server 2003 hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, 32-bit versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   02-Sep-2004  23:01  5.2.3790.207      117,760  Ntmarta.dll      
Windows Server 2003, Enterprise Edition for Itanium-based Systems
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   02-Sep-2004  22:01  5.2.3790.207      354,816  Ntmarta.dll      IA-64
   02-Sep-2004  22:01  5.2.3790.207      117,760  Wntmarta.dll     x86

Microsoft Windows XP hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows XP Service Pack 1, 32-bit versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   17-Sep-2004  19:17  5.1.2600.1588     114,688  Ntmarta.dll      
Windows XP Service Pack 2, 32-bit versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   17-Sep-2004  18:52  5.1.2600.2515     118,784  Ntmarta.dll  
Windows XP, Itanium-based versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   17-Sep-2004  19:16  5.1.2600.1588     383,488  Ntmarta.dll      IA-64
   17-Sep-2004  19:17  5.1.2600.1588     114,688  Wntmarta.dll     x86

Microsoft Windows 2000 hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To install this hotfix, you must be running Windows 2000 Service Pack 3 or Windows 2000 Service Pack 4.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   28-Sep-2004  08:40  5.0.2195.6980     103,184  Ntmarta.dll     

Hotfix installation instructions

You must install this hotfix on the computer that initiates the ACL changes. For example, if you modify an ACL in a DFS shared path from a Windows XP-based client that connects through DFS to a Windows Server 2003-based file server, you must install the hotfix on the Windows XP-based client.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about DFS in Windows Server 2003, visit the following Microsoft Web site:
http://technet2.microsoft.com/windowsserver/en/library/a9096e88-1634-4da6-b820-537341d349061033.mspx
For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 873407 - Last Review: October 9, 2011 - Revision: 6.0
APPLIES TO
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbwinxppresp3fix kbwin2000presp5fix kbwinserv2003presp1fix kbbug kbfix KB873407

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