ID do artigo: 873415 - Última revisão: quinta-feira, 25 de outubro de 2007 - Revisão: 4.3

Um computador com Exchange Server 2003 que esteja configurado como um servidor de pasta pública pode enfrentar desempenho muito ruim

Download do hotfix está disponívelDownload do Hotfix Disponível
Visualizar e solicitar downloads de hotfix
Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
importante Este artigo contém informações sobre como modificar o registro. Certifique-se de fazer backup do registro antes de modificá-lo. Certifique-se que você sabe como restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup, restaurar e modificar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
256986  (http://support.microsoft.com/kb/256986/ ) Descrição do registro do Microsoft Windows


Para uma versão deste artigo do Microsoft Exchange 2000 Server, consulte 841645  (http://support.microsoft.com/kb/841645/ ) .

Nesta página

Expandir tudo | Recolher tudo

Sintomas

Um computador com Microsoft Exchange Server 2003 que esteja configurado como um servidor de pasta pública pode enfrentar desempenho muito ruim. Quando esse problema ocorre, uma ou mais dos seguintes problemas podem ocorrer:
  • Os usuários são solicitados a inserir novamente suas credenciais do Exchange.
  • Diminui a funcionalidade de email.
  • Os usuários podem perder sua conexão para o computador do Exchange.
  • Downloads do catálogo de endereços do Microsoft Outlook podem demorar mais do que o esperado.

Causa

Esse problema pode ocorrer quando as respostas de controlador de domínio lenta fazer com que um registro posterior de solicitações para recarregar a hierarquia de pasta pública no serviço do Microsoft Exchange Information Store (Store.exe). A hierarquia deve apenas ser recarregada uma vez durante um intervalo de tempo é definido. Esse intervalo normalmente é 15 minutos. Os sintomas descritos neste artigo ocorrem porque o tempo limite expira, e cada segmento do cliente tenta recarregar a hierarquia.

O valor do tempo limite não é redefinido até que o segmento do cliente recebe uma resposta (LIGHTWEIGHT Directory Access Protocol) de um controlador de domínio. A resposta deve conter a lista de servidores de pasta pública. Quando o segmento do cliente recebe a resposta, cada segmento do cliente emite uma solicitação LDAP. Se houver muitos usuários na rede, essas solicitações LDAP podem esgotar as solicitações de (RPC) chamada de procedimento remoto 100 que podem ser abertas ao mesmo tempo.

Resolução

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Esse hotfix requer o Microsoft Exchange Server 2003 Service Pack 1.

Requisitos de reinicialização

Não é necessário reiniciar o computador após instalar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário na ferramenta Data e hora no painel de controle.
Date         Time   Version            Size    File name
--------------------------------------------------------------
23-Nov-2004  00:46  6.5.7232.55     3,261,952  Mdbmsg.dll       
23-Nov-2004  01:19  6.5.7232.55     5,143,552  Store.exe

Como Contornar

Se você aplicar o hotfix descrito neste artigo, não é necessário usar essa solução alternativa. Para contornar esse problema, configure o valor de recarregamento de replicação para um intervalo de 24 horas no registro.

Para configurar o valor de recarregamento de replicação no registro, execute estas etapas.

Aviso Podem ocorrer sérios problemas se você modificar o registro incorretamente usando o Editor do registro ou usando outro método. Esses problemas podem exigir que você reinstale seu sistema operacional. A Microsoft não garante que esses problemas possam ser solucionados. Modificar o registro por sua própria conta e risco.
  1. Clique em Iniciar , clique em Executar , digite regedt32 na caixa Abrir e, em seguida, clique em OK .
  2. Localize e, em seguida, clique na seguinte subchave do Registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MsExchangeIS\ <servername> \Public-(guid)
  3. No menu Editar , clique em Adicionar valor .
  4. Na caixa Nome do valor , digite o seguinte:
    replicação recarregar TLH min
  5. Na lista Tipo de dados , clique em REG_DWORD e, em seguida, clique em OK .
  6. Na caixa dados , digite 86400 e, em seguida, clique em OK .

    Observação O valor é o número de segundos entre recargas. 86.400 segundos é igual a 24 horas.
  7. Feche o Editor do Registro.
O valor de replicação que você especificar é somente leitura quando o armazenamento de pasta pública é iniciado. Para forçar o computador com Exchange Server 2003 para ler o novo valor, desmontar e, em seguida, montar o armazenamento de pasta pública. Faça isso após horas de trabalho quando a carga no sistema é muito leve.

Para desmontar e, em seguida, montar o armazenamento de pasta pública, execute estas etapas:
  1. Inicie o Exchange System Manager.
  2. Expanda Servers , expanda o servidor que você deseja, expanda Storage_Group_Name e clique com o botão direito do mouse em Armazenamento de pasta pública .

    Observação Se grupos administrativos estiverem definidos, execute estas etapas:
    1. Expanda Administrative Groups .
    2. Expanda Administrative_Group_Name.
    3. Expanda Servers .
    4. Expanda o servidor que você deseja.
    5. Expanda Storage_Group_Name.
    6. Clique com o botão direito do mouse Armazenamento de pasta pública .
  3. Clique em Desmontar armazenamento e, em seguida, clique em Sim para continuar.
  4. Clique com o botão direito do mouse Armazenamento de pasta pública , clique em Mount Store e em seguida, clique em OK .

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Para obter mais informações, clique nos números abaixo para ler os artigos na Base de dados de Conhecimento da Microsoft:
824684  (http://support.microsoft.com/kb/824684/ ) Descrição da terminologia padrão que é usada para descrever as atualizações de software
817903  (http://support.microsoft.com/kb/817903/ ) Novo esquema para nomeação para pacotes de atualização de software do Exchange Server

A informação contida neste artigo aplica-se a:
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
Palavras-chave: 
kbmt kbautohotfix kbqfe kbhotfixserver kbfix kbbug kbexchange2003presp1fix KB873415 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 873415  (http://support.microsoft.com/kb/873415/en-us/ )