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The Computer Browser service does not start and event ID 7024 is logged when you restart your Windows XP Service Pack 2-based computer

Article ID:875362
Last Review:July 8, 2005
Revision:1.2

SYMPTOMS

After you install Microsoft Windows XP Service Pack 2 (SP2), the Computer Browser service does not start when you restart your computer. The following event is logged in the system event log:

Type: Error
Source: Service Control Manager
Event ID: 7024
Description:
The Computer Browser service terminated with service-specific error 2550 (0x9F6).

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CAUSE

This problem occurs because Windows XP SP2 installs Windows Firewall. Windows Firewall may block the ports that are used for file and printer sharing. If these ports are blocked, the Computer Browser service cannot start.

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RESOLUTION

To resolve this problem so that the Computer Browser service starts, follow these steps:
1.Click Start, click Run, type firewall.cpl in the Open box, and then click OK.
2. Click the Exceptions tab.
3.Click to select the File and Printer Sharing check box, and then click OK.

The Computer Browser service automatically starts after you unblock the ports that are used for file and printer sharing.

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MORE INFORMATION

Whether the File and Printer Sharing check box is selected may affect the behavior that you experience. By default, the File and Printer Sharing check box is selected if you upgrade from an earlier version of the Windows operating system that has existing shared resources, or if you upgrade your Windows XP Service Pack 1-based computer that has existing shared resources. Therefore, you will not experience the behavior that is mentioned in this article. However, if no shared resources exist before you install Windows XP SP2 or if you integrate Windows XP SP2 with the Windows XP installation, the File and Printer Sharing check box is not selected, and the Computer Browser service does not start.

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REFERENCES

For additional information about the Computer Browser service, click the following article number to view the article in the Microsoft Knowledge Base:
188001 (http://support.microsoft.com/kb/188001/) Description of the Microsoft Computer Browser service
For additional information about a problem that you may experience if the Computer Browser service is not started and your computer is a member of a workgroup in a peer-to-peer network, click the following article number to view the article in the Microsoft Knowledge Base:
318030 (http://support.microsoft.com/kb/318030/) You cannot access shared files and folders or browse computers in the workgroup

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APPLIES TO
Microsoft Windows XP Professional Service Pack 2 (SP2)

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Keywords: 
kbtshoot kbconsumer kbfirewall kbnetwork kbpolicy kbsecurity kbprb kbconfig kbconnectivity kbsettings KB875362

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