文書番号: 875362 - 最終更新日: 2005年7月11日 - リビジョン: 1.2

Windows XP Service Pack 2 ベースのコンピュータの再起動時に、Computer Browser サービスが開始せず、イベント ID 7024 が出力される

お知らせお使いのオペレーティング システムには適用しない情報が含まれている場合があります。
すべて展開する | すべて折りたたむ

現象

Microsoft Windows XP Service Pack 2 (SP2) をインストール後、コンピュータを再起動すると、Computer Browser サービスが開始されません。次のイベントがシステム イベント ログに出力されます。

種類 : エラー
ソース : Service Control Manager
イベント ID : 7024
説明 :
Computer Browser はサービス固有のエラーで終了しました : 2550 (0x9F6)

原因

この問題は、Windows XP SP2 で Windows ファイアウォールがインストールされることが原因で発生します。Windows ファイアウォールにより、ファイルとプリンタの共有で使用されるポートがブロックされる場合があります。これらのポートがブロックされると、Computer Browser サービスを開始できません。

解決方法

問題を解決して Computer Browser サービスを開始できるようにするには、次の手順を実行します。
  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。[名前] ボックスに firewall.cpl と入力し、[OK] をクリックします。
  2. [例外] タブをクリックします。
  3. [ファイルとプリンタの共有] チェック ボックスをオンにし、[OK] をクリックします。

    ファイルとプリンタ共有で使用されるポートのブロックが解除されると、Computer Browser サービスが自動的に開始されます。

詳細

[ファイルとプリンタの共有] チェック ボックスがオンになっているかどうかで、発生する現象が異なります。既存の共有リソースのある Windows オペレーティング システムを以前のバージョンからアップグレードした場合や、既存の共有リソースのある Windows XP SP1 ベースのコンピュータをアップグレードした場合、デフォルトでは [ファイルとプリンタの共有] チェック ボックスはオンになっています。そのため、この資料に記載されている現象は発生しません。しかし、Windows XP SP2 をインストールする前に共有リソースがなかった場合や、Windows XP インストールと Windows XP SP2 を統合した場合は、[ファイルとプリンタの共有] チェック ボックスはオフになっており、Computer Browser サービスは開始されません。

関連情報

Computer Browser サービスの関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
188001? (http://support.microsoft.com/kb/188001/ ) コンピュータ ブラウザ サービスについて
使用しているコンピュータがピア ツー ピア ネットワークのワークグループのメンバである場合に Computer Browser サービスが開始しないと発生することがある問題の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
318030? (http://support.microsoft.com/kb/318030/ ) 共有ファイルやフォルダにアクセスできない、またはワークグループ内のコンピュータを参照できない

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 875362? (http://support.microsoft.com/kb/875362/EN-US/ ) (最終更新日 2004-08-06) を基に作成したものです。

この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Professional Service Pack 2 (SP2)
  • Microsoft Windows XP Home Edition Service Pack 2 (SP2)
キーワード:?
kbfirewall kbtshoot kbprb KB875362
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"