La synchronisation de l'heure peut échouer lorsque vous essayez de synchroniser avec un serveur NTP non-Windows dans Windows Server 2003

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Symptômes

Lorsque vous essayez de synchroniser votre ordinateur Microsoft Windows Server 2003 avec un serveur NTP (Network Time Protocol) qui n'exécute pas Microsoft Windows, la synchronisation peut échouer. Lorsque ce problème se produit, les événements suivants peuvent être enregistrés dans le journal système :

Type d'événement : Evénement Information
Source : W32Time
Catégorie de l'événement : Aucune
ID de l'événement : 38
Date : Date
Heure : Heure
Utilisateur : N/A
Ordinateur : nom_ordinateur
Description : Le fournisseur de temps NtpClient ne peut pas atteindre ou reçoit en ce moment des données de temps non valides de adresse_IP_serveur_NTP. Pour plus d'informations, consultez le centre Aide et support à l'adresse http://support.microsoft.com.

Type d'événement : Avertissement
Source de l'événement : W32Time
Catégorie de l'événement : Aucune
ID de l'événement : 47
Date : Date
Heure : Heure
Utilisateur : N/A
Ordinateur : nom_ordinateur
Description : Fournisseur de temps NtpClient : Aucune réponse valide n'a été reçue de l'homologue manuellement configuré adresse_IP_serveur_NTP après 8 tentatives pour le contacter. Cet utilisateur sera rejeté en tant que source de temps et NtpClient va tenter de découvrir un nouvel utilisateur avec ce nom DNS. Pour plus d'informations, consultez le centre Aide et support à l'adresse http://support.microsoft.com.

Type d'événement : Erreur
Source de l'événement : W32Time
Catégorie de l'événement : Aucune
ID de l'événement : 29
Date : Date
Heure : Heure
Utilisateur : N/A
Ordinateur : nom_ordinateur
Description : Le fournisseur de temps NtpClient est configuré pour obtenir le temps à partir d'une ou plusieurs sources, cependant aucune des sources n'est actuellement disponible. Aucune tentative pour contacter une source ne sera faite pendant 15 minutes. NtpClient n'a aucune source de temps précise. Pour plus d'informations, consultez le centre Aide et support à l'adresse http://support.microsoft.com.

Cause

Ce problème peut se produire lorsque votre ordinateur envoie des requêtes de synchronisation à l'aide du mode actif symétrique. Par défaut, les contrôleurs de domaine Windows Server 2003 sont configurés comme serveurs de temps et utilisent le mode actif symétrique pour envoyer des requêtes de synchronisation. Certains serveurs NTP qui n'exécutent pas Windows répondent uniquement aux requêtes qui utilisent le mode client.

Résolution

Pour résoudre ce problème, configurez le temps Windows pour utiliser le mode client lorsqu'il se synchronise avec le serveur de temps. Pour cela, procédez comme suit :
  1. Cliquez sur Démarrer, sur Exécuter, puis tapez cmd et appuyez sur ENTRÉE.
  2. À l'invite de commandes, tapez les commandes ci-dessous dans l'ordre dans lequel elles sont présentées. Après avoir tapé chaque commande, appuyez sur ENTRÉE.
    • w32tm /config /manualpeerlist:adresse_IP_serveur_NTP,0x8 /syncfromflags:MANUAL
    • net stop w32time
    • net start w32time
    • w32tm /resync

Plus d'informations

Le mode utilisé par le temps Windows pour envoyer des requêtes est défini par la sous-clé de Registre suivante :
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\TimeProviders\NtpServer
Si la valeur de l'entrée Enabled de cette sous-clé est 1, le temps Windows utilise le mode actif symétrique. Sinon, le temps Windows utilise le mode client.

Le paramètre 0x8 référencé dans la commande mentionnée dans la section « Résolution » configure le temps Windows pour utiliser le mode client.

Les paramètres valides pour le mode utilisé avec le commutateur /manualpeerlist comprennent les suivants :
  • 0x01 - utiliser un intervalle d'interrogation spécial SpecialInterval
  • 0x02 - UseAsFallbackOnly
  • 0x04 - envoyer la requête en mode SymmetricActive
  • 0x08 - envoyer la requête en mode Client

Propriétés

Numéro d'article: 875424 - Dernière mise à jour: vendredi 22 septembre 2006 - Version: 3.1
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
Mots-clés : 
kbtshoot kbprb KB875424
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