A sincronização de hora poderá não ter êxito quando tenta sincronizar com um servidor NTP não Windows no Windows Server 2003

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Sintomas

As opções mencionadas neste artigo poderão estar em inglês, consoante a versão do sistema operativo ou dos componentes instalados.

Quando tenta sincronizar o computador baseado no Microsoft Windows Server 2003 com um servidor NTP (Network Time Protocol) que não tem o Microsoft Windows, a sincronização poderá não ter êxito. Quando este problema ocorre, poderão ser registados os seguintes eventos no registo do sistema:

Tipo de evento: Informações de eventos
Origem: W32Time
Categoria do evento: Nenhuma
ID do evento: 38
Data: Data
Hora: Hora
Utilizador: N/D
Computador: Nomedocomputador
Descrição: O dispositivo de hora NtpClient não consegue alcançar ou está actualmente a receber dados horários inválidos de Endereço_IP_servidor_NTP. Para mais informações, consulte o 'Centro de ajuda e suporte' em http://support.microsoft.com.

Tipo de evento: Aviso
Origem do evento: W32Time
Categoria do evento: Nenhuma
ID do evento: 47
Data: Data
Hora: Hora
Utilizador: N/D
Computador: Nomedocomputador
Descrição: Dispositivo de hora NtpClient: após 8 tentativas para o contactar não foi recebida uma resposta válida da unidade configurada manualmente Endereço_IP_servidor_NTP . Este ponto será ignorado como uma origem de hora e o NtpClient irá tentar descobrir um novo ponto com este nome DNS. Para mais informações, consulte o 'Centro de ajuda e suporte' em http://support.microsoft.com.

Tipo de evento: Erro
Origem do evento: W32Time
Categoria do evento: Nenhuma
ID do evento: 29
Data: Data
Hora: Hora
Utilizador: N/D
Computador: Nomedocomputador
Descrição: O dispositivo de hora NtpClient está configurado para obter as horas a partir de uma ou mais origens de horas, no entanto nenhuma delas está actualmente acessível. Não será efectuada nenhuma tentativa para contactar uma origem durante 15 minutos. O NtpClient não tem nenhuma origem de hora exacta. Para mais informações, consulte o 'Centro de ajuda e suporte' em http://support.microsoft.com.

Causa

Este problema poderá ocorrer quando o computador envia pedidos de sincronização utilizando o modo simétrico activo. Por predefinição, os controladores de domínio do Windows Server 2003 estão configurados como servidores de hora e utilizam o modo simétrico activo para enviar pedidos de sincronização. Alguns servidores NTP que não têm o Windows respondem apenas a pedidos que utilizam o modo de cliente.

Resolução

Para resolver este problema, configure a Hora do Windows para utilizar o modo de cliente quando sincronizar com o servidor de hora. Para o fazer, siga estes passos:
  1. Clique em Iniciar, clique em Executar, escreva cmd e prima ENTER.
  2. Na linha de comandos, escreva os seguintes comandos pela ordem apresentada. Depois de escrever cada comando, prima ENTER.
    • w32tm /config /manualpeerlist:Endereço_IP_servidor_NTP,0x8 /syncfromflags:MANUAL
    • net stop w32time
    • net start w32time
    • w32tm /resync

Mais Informação

O modo que a Hora do Windows utiliza para enviar pedidos é definido pela seguinte subchave de registo:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\TimeProviders\NtpServer
Se o valor da entrada Enabled desta subchave for 1, a Hora do Windows utiliza o modo simétrico activo. Caso contrário, a Hora do Windows utiliza o modo de cliente.

A definição 0x8 referida no comando da secção "Resolução" define a Hora do Windows para utilizar o modo de cliente.

As definições válidas para o modo utilizado com o parâmetro /manualpeerlist incluem as seguintes:
  • 0x01 - utiliza o intervalo de consulta especial SpecialInterval
  • 0x02 - UseAsFallbackOnly
  • 0x04 - envia pedido como modo SymmetricActive
  • 0x08 - envia pedido como modo de cliente

Propriedades

Artigo: 875424 - Última revisão: 23 de outubro de 2006 - Revisão: 3.1
A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003 Web Edition
  • Microsoft Windows Server 2003 Standard Edition
  • Microsoft Windows Server 2003 Enterprise Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
Palavras-chave: 
kbtshoot kbprb KB875424

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