Monitoraggio di Exchange per la crescita della coda SMTP misleadingly pu˛ segnalare lo stato di avviso o stato critico in Exchange Server 2003 o in Exchange 2000 Server

Traduzione articoli Traduzione articoli
Identificativo articolo: 875435 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

Sintomi

Dopo aver configurato il monitoraggio nello strumento Gestore di sistema di Microsoft Exchange per monitorare la crescita della coda SMTP in un computer Microsoft Exchange Server 2003 o Microsoft Exchange 2000 Server, potresti ricevere un messaggio di notifica dello stato di avviso o un messaggio di notifica di stato critico. Tuttavia, quando si visualizza la coda SMTP nel computer di Exchange, tale coda non Ŕ eccessivo crescita della coda SMTP.

╚ ad esempio, possibile che venga visualizzato un messaggio di notifica dello stato di avviso o un messaggio di notifica di stato critico se un messaggio di posta non recapitabile rimane nella coda SMTP, mentre tutti gli altri messaggi viene recapitato correttamente. In questo scenario, non Ŕ possibile determinare se il messaggio di notifica che Ŕ visualizzato indica un problema con la coda SMTP che richiede l'azione amministrativa all'indirizzo.

Cause

Questo problema si verifica perchÚ viene utilizzato Windows strumentazione (WMI) proprietÓ IncreasingTime per determinare la crescita della coda SMTP. La proprietÓ IncreasingTime con la descrizione seguente:
Riduci questa tabellaEspandi questa tabella
ProprietÓ Descrizione
ProprietÓ IncreasingTimeValore UInt32 IncreasingTime;
La proprietÓ IncreasingTime specifica la quantitÓ di tempo, in millisecondi, che il numero di messaggi in attesa di essere trasferiti mediante il collegamento Ŕ stato in continua crescita.
A riformulare la descrizione, questa proprietÓ descrive il tempo trascorso poichÚ Ŕ il numero di messaggi nella coda SMTP non diminuito. In questo scenario, se un messaggio SMTP rimane nella coda SMTP Ŕ non ridurre tale coda. Di conseguenza, il numero di millisecondi che passa dopo il numero di messaggi nella coda non ha il diminuito di aumenta.

Un messaggio con lo stato di RETRY rimane nella coda SMTP, finchÚ non verifica il timeout o finchÚ non viene recapitato. Di conseguenza, un messaggio con lo stato di RETRY potrebbe causare un messaggio di notifica dello stato di avviso o di un messaggio di stato critico notifica da generare. Questo stato di RETRY del messaggio potrebbe indicare un problema con la coda SMTP e pertanto comporta correttamente il messaggio di notifica dello stato di avviso o messaggio di notifica stato critico deve essere generato. In genere, tuttavia, questo stato RETRY indica un problema che non Ŕ "critico" e che potrebbero non richiedere azione amministrativa all'indirizzo.

In questo scenario, la Crescita della coda corrente indica il tempo totale del messaggio meno recente con lo stato di RETRY nella coda SMTP.

Risoluzione

Per risolvere il problema, configurare il contatore di prestazioni Lunghezza coda del locale per il Server SMTP di oggetto di prestazioni per misurare il numero di messaggi nella coda SMTP. ╚ inoltre possibile configurare lo strumento prestazioni di Windows per inviare un messaggio di notifica, se il numero di messaggi SMTP raggiunge una determinata soglia.

Per configurare l'oggetto prestazione Server SMTP , attenersi alla seguente procedura:
  1. Fare clic su Start , scegliere Esegui , digitare perfmon e quindi fare clic su OK .
  2. Nel riquadro di destra fare clic sul pulsante Aggiungi . Il pulsante di Aggiungi viene visualizzato come un segno pi¨ (+).
  3. Nell'elenco oggetto prestazione , fare clic su Server SMTP .
  4. Nell'elenco Seleziona i contatori dall'elenco , fare clic su Lunghezza coda locale .
  5. Nella casella Seleziona le istanze dall'elenco , fare clic sull'istanza SMTP che si desidera monitorare. Ad esempio, fare clic su SMTP 1 .
  6. Fare clic su Aggiungi e quindi fare clic su Chiudi .
Per configurare un'impostazione di avviso, attenersi alla seguente procedura:
  1. Nello strumento prestazioni di Windows, espandere avvisi e registri di prestazioni , fare clic con il pulsante destro del mouse sul avvisi e quindi scegliere Nuove impostazioni avvisi .
  2. Nella finestra di dialogo Nuove impostazioni avvisi digitare un nome descrittivo per l'avviso e quindi fare clic su OK . Ad esempio, digitare avviso coda SMTP .
  3. Nella scheda Generale , fare clic su Aggiungi .
  4. Nell'elenco oggetto prestazione , fare clic su Server SMTP .
  5. Nell'elenco Seleziona i contatori dall'elenco , fare clic su Lunghezza coda locale .
  6. Nella casella Seleziona le istanze dall'elenco , fare clic sull'istanza SMTP che si desidera monitorare. Ad esempio, fare clic su SMTP 1 .
  7. Fare clic su Aggiungi e quindi fare clic su Chiudi .
  8. Nell'elenco degli avvisi quando il valore Ŕ , fare clic su e quindi digitare il numero di messaggi di posta elettronica che si desidera configurare come la soglia nella casella limite . Ad esempio, digitare 20 nel limite di casella.

    Nota Questo valore Ŕ specifico dell'organizzazione di Exchange. Per ulteriori informazioni, vedere i documenti di Risoluzione dei problemi di Microsoft Exchange Server 2003 Performance and Troubleshooting Microsoft Exchange 2000 Server Performance descritti in "Ulteriori informazioni" sezione.
  9. Scegliere la scheda operazione , fare clic per selezionare la casella di controllo Invia un messaggio di rete a , digitare il nome dell'account che si desidera che il messaggio da inviare per e quindi fare clic su OK .
Per ulteriori informazioni, fare clic sui numeri degli articoli della Microsoft Knowledge Base riportato di seguito:
324752Come creare e configurare gli avvisi di Performance Monitor in Windows Server 2003
302558Come creare e configurare gli avvisi di Performance Monitor in Windows 2000

Informazioni

Per ulteriori informazioni, fare clic sui numeri degli articoli della Microsoft Knowledge Base riportato di seguito:
310315Risoluzione dei problemi di monitoraggio e stato di Exchange e in Small Business Server
329206Come scoprire quali code SMTP e X.400 sono monitorate in Exchange 2000
Per ulteriori informazioni sulla configurazione di monitoraggio in Exchange 2003, vedere il documento Troubleshooting Microsoft Exchange Server 2003 Performance . Per ottenere questo documento, il seguente sito Microsoft Web:
http://technet.microsoft.com/en-us/library/4b012bda-8711-4617-9239-f3527de884a3.aspx
Per ulteriori informazioni sulla configurazione di monitoraggio in Exchange 2000, vedere il documento Troubleshooting Microsoft Exchange 2000 Server Performance . Per ottenere questo documento, il seguente sito Microsoft Web:
http://www.microsoft.com/downloads/details.aspx?familyid=bd16ee6a-c4ee-4ab0-aaf0-27705465154e&displaylang=en
Per ulteriori informazioni sulla proprietÓ IncreasingTime WMI, visitare i seguenti siti Web Microsoft:
http://msdn2.microsoft.com/en-us/library/aa126772.aspx
Building Management Components for MS Exchange 2000 Server
╚ inoltre possibile utilizzare Microsoft Operations Manager (MOM) per monitorare i computer di Exchange. ╚ possibile utilizzare i componenti di Exchange 2003 Management Pack ed Exchange 2000 Management Pack per MOM per gestire e monitorare i computer Exchange 2003 ed Exchange 2000.

Per ulteriori informazioni su Exchange 2003 Management Pack per MOM ed Exchange 2000 Management Pack per MOM, visitare i seguenti siti Web Microsoft:
http://www.microsoft.com/technet/prodtechnol/exchange/2000/maintain/momtips.mspx
http://www.microsoft.com/technet/prodtechnol/exchange/2000/maintain/mom.mspx

ProprietÓ

Identificativo articolo: 875435 - Ultima modifica: giovedý 25 ottobre 2007 - Revisione: 1.7
Le informazioni in questo articolo si applicano a:
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange 2000 Server Standard Edition
  • Microsoft Exchange 2000 Enterprise Server
Chiavi:á
kbmt kbtshoot kbprb KB875435 KbMtit
Traduzione automatica articoli
Il presente articolo Ŕ stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non Ŕ sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pi¨ o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non Ŕ la sua. Microsoft non Ŕ responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 875435
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com