MS04-020: A vulnerability in POSIX could permit code execution in Interix 2.2

Article translations Article translations
Article ID: 875496 - View products that this article applies to.
This article has been archived. It is offered "as is" and will no longer be updated.
Expand all | Collapse all

On This Page

SUMMARY

Microsoft has released security bulletin MS04-020. The security bulletin contains all the relevant information about the security update, including file manifest information and the deployment options. To view the complete MS04-020 security bulletin, visit the following Microsoft Web site:
http://www.microsoft.com/technet/security/bulletin/ms04-020.mspx

RESOLUTION

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Note This hotfix requires that you must restart your computer after the Portable Operating System Interface (POSIX) subsystem is replaced.

Hotfix replacement information

This hotfix replaces the hotfix that is described in the following Microsoft Knowledge Base article. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
841872 MS04-020: A vulnerability in POSIX could allow code execution

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   23-Jul-2004  18:38  2.2.428.10        656,384  Psxss.exe        

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Hotfix 841872, "MS04-020: A vulnerability in POSIX could allow code execution," removes the vulnerability in Interix 2.2 but leaves Interix 2.2 nonfunctioning. No Interix processes can run after you apply 841872. This hotfix removes the vulnerability and does not affect Interix 2.2.

Services for UNIX 3.0 and Services for UNIX 3.5 contain Interix components, but they do not contain the CAN-2004-0210 vulnerability.

For additional information about terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 875496 - Last Review: October 27, 2013 - Revision: 1.3
APPLIES TO
  • Microsoft Interix 2.2 Standard Edition
  • Microsoft Interix 2.2 Standard Edition
  • Microsoft Interix 2.2 Standard Edition
  • Microsoft Interix 2.2 Standard Edition
  • Microsoft Interix 2.2 Standard Edition
Keywords: 
kbnosurvey kbarchive kbsecvulnerability kbsecbulletin kbsecurity kbfix kbprb kbqfe kbhotfixserver KB875496

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com