Felmeddelandet "Installationsfel: Det gick inte att hitta filen" eller "Fel 0x51F" visas vid försök att uppdatera Office 2003-program via webbplatsen Office Update eller Office Download Center

Artikelöversättning Artikelöversättning
Artikel-id: 875556 - Visa produkter som artikeln gäller.
Visa alla | Dölj alla

På den här sidan

Symptom

När du försöker uppdatera ett Microsoft Office 2003-program från webbplatsen Microsoft Update eller med automatisk uppdatering kan ett felmeddelande av följande typ visas:
Fel 0x51F
När du försöker uppdatera ett Microsoft Office 2003-program från webbplatsen Microsoft Office Download Center eller Microsoft Update kan ett felmeddelande av följande typ visas:
Installationsfel: Det gick inte att hitta filen.
Det gick inte att hitta den nödvändiga installationsfilen filnamn.CAB.

Ursprunglig installationskälla krävs:

Om du har installerat programnamn från en cd-skiva sätter du in cd-skivan. Om du har installerat programnamn från nätverket letar du rätt på installationskällan på nätverket. Klicka på OK när du har hittat installationskällan."
Obs! Filnamnet är oftast i formatet SKUxxx.cab, där xxx är det andra, tredje och fjärde numret i produktkoden.
Om du vill veta mer om produktkodnumrering i Office 2003 klickar du på följande artikelnummer och läser artikeln i Microsoft Knowledge Base:
832672 Beskrivning av numreringsschema för produktkod-GUID:er i Office 2003 (Länken kan leda till en webbplats som är helt eller delvis på engelska)
Obs! Om du vill söka efter uppdateringar för Office 2003 går du till följande Microsoft-webbplats:
http://office.microsoft.com/sv-se/officeupdate/default.aspx

Orsak

Problemet kan uppstå om någon av följande förutsättningar föreligger:
  • Källfiler i mappen C:\MSOCache\All Users\90000409-6000-11D3-8CFE-0150048383C9 saknas.
  • Mappen MSOCache har tagits bort.
  • Det finns ett problem med den lokala installationskällan för programmet.

Workaround

Du kan undvika problemet genom att använda något av metoderna i det här avsnittet.

Obs! Oavsett vilken metod du använder för att undvika det här problemet kan du lösa det om du har CD-skivan med Office 2003-programmen. Om du vill lösa problemet permanent använder du verktyget Local Installation Source för att reparera den lokala installationskällan. Mer information om du hur du använder verktyget Local Installation Source finns avsnittet "Använda verktyget Local Installation Source".

Metod 1: Ange originalkällan som du använde när du installerade programmen för första gången

När felmeddelandet som nämns i avsnittet "Symptom" visas, utför du ett av följande steg för att ange originalkällan som du använde för att installera programmen.
  • Sätt in originalskivan för Office 2003 som du använde för att installera Office 2003 och klicka sedan på OK.
  • Klicka på Bläddra, leta reda på installationsmappen för Office 2003 i nätverket och klicka på OK.
Även om dessa åtgärder löser behovet av installationsfilerna och tillåter att uppdateringen fortsätter, kan problemet uppstå nästa gång du försöker uppdatera ett Office 2003-program på webbplatsen Office Update.

Obs!Om åtgärderna som listas i metod 1 inte fungerar är det möjligt att filerna i mappen MSOCache\All Users\download code inte överensstämmer med filerna på den CD du har använt. Kontrollera att den cd du satt in överensstämmer med den produkt som efterfrågas. Den installerade produkten kan till exempel vara Microsoft Office Professional Edition 2003 och CD:n innehåller filerna för Microsoft Office Professional Enterprise Edition 2003. I så fall måste du ta bort Microsoft Office-produkten och sedan installera den igen från CD:n.

Obs!Toshiba tillhandahåller en komprimerad diskavbildning av OneNote-CD:n på DVD:n "Toshiba Recovery and Applications / Drivers" som finns i följande mapp:
CDROM-enhet\COMPS\MICROSOFT OFFICE ONENOTE 20030\MANUAL
Det finns en enda fil med namnet B21654A.exe i denna mapp. Gör följande när du vill extrahera filen B21654A.exe:
  1. Dubbelklicka på filen B21654A.exe.

    En dialogruta från Winzip Self Extractor visas med följande meddelande:
    Microsoft Office OneNote 2003 W32 English OPK v. 11.5510.5606 Setup will start when the extraction is complete. Please restart your computer after the installation is completed.
  2. Klicka på OK.

    Sedan visas en annan dialogruta med flera installationsalternativ.
  3. Om du vill extrahera filerna utan att installera Microsoft Office OneNote 2003, avmarkerar du kryssrutan When done unzipping open: SETUP.exe. Som standard extraheras filerna till mappen C:\OneNote2003.temp. Om du vill extrahera filerna till någon annan plats ändrar du denna.
  4. Klicka på Unzip.
  5. När extraheringen är klar visas följande Winzip Extractor-dialogruta:
    53 file(s) unzipped successfully
    Click OK.
  6. Stäng dialogrutan WinZip Self-Extractor - B21654A.exe genom att klicka på Stäng.
När uppdateringen Office 2003 SP1 frågar efter platsen för en fil, anger du platsen som innehåller de extraherade filerna.

Obs! Vissa datorer från OEM-tillverkare innehåller en förinstallerad testversion av Microsoft Office OneNote 2003 eller Microsoft Office 2003. Ibland följer kanske inte någon CD med, eller källfilerna finns på en återställnings-CD som det inte går att extrahera filer från. Gör så här för att lösa problemet:
  1. Kontrollera att du kan hitta produktnyckeln för OneNote 2003 eller Microsoft Office som följer med datorn. Produktnyckeln bör finnas på äkthetsbeviset.
  2. Ta bort den befintliga installationen av OneNote 2003.
  3. Hämta testversionen av Microsoft Office OneNote 2003 som finns på följande Microsoft-webbplats:
    http://www.microsoft.com/office/onenote/prodinfo/trial.mspx#XSLTsection126121120120
    Dölj bildenVisa bilden
     Testversion av OneNote 2003 - Microsoft Internet Explorer


    Hämta 60-dagarstestversionen av Microsoft Office Standard Edition 2003 som finns på följande Microsoft-webbplats:
    http://www.microsoft.com/office/editions/prodinfo/standardtrial.mspx#XSLTsection127121120120
    Dölj bildenVisa bilden
     Testversion av Office Standard Edition 2003 - Microsoft Internet Explorer


  4. Installera testversionen av OneNote 2003 eller Office Standard 2003 och ange sedan produktnyckeln från äkthetsbeviset som du hittade i steg 1 i stället för det som anges på webbplatsen i steg 3.
  5. Starta testversionen av OneNote 2003 eller Office Standard 2003 och starta produktlicensen när denna efterfrågas.

    Obs!Testversionen av OneNote 2003 Trial är redan uppdaterad till Microsoft Office OneNote Service Pack 1. För testversionen av Office Standard 2003 måste du installera Microsoft Office 2003 Service Pack 1 från följande Microsoft Office Update-webbplats:
    http://office.microsoft.com/sv-se/downloads/default.aspx
    Observera att den här testversionen av Office Standard 2003 kanske inte innehåller alla program, som testversionen som var förinstallerad på datorn gjorde.

Metod 2: Använd Office Update

Microsoft Update är utformad för att installationen ska utföras utan inblandning av användaren. Om du till exempel använder Microsoft Update behöver du inte ha CD-skivan med program. Om du använder Microsoft Update tillfrågas du dock efter CD-skivan med program endast om det finns ett problem den lokala installationskällan på din dator.

Om du vill att nödvändiga uppdateringar ska identifieras automatiskt besöker du Microsoft-webbplatsen Office Update:
http://office.microsoft.com/sv-se/officeupdate/default.aspx
Klicka på Sök efter viktiga uppdateringar. När identifieringen har slutförts visas en lista över rekommenderade uppdateringar som du kan godkänna. Slutför uppdateringsprocessen genom att klicka på Starta installationen.

Dölj bildenVisa bilden
Hemsida för Microsoft Office-filhämtning - Microsoft Internet Explorer


Obs! Se till att du har CD-skivan med program tillgänglig när du använder Office Update Web för att installera en uppdatering. Sätt i CD-skivan när du tillfrågas.

Metod 3: Använda Microsoft Download Center

Du kan använda Microsoft Download Center för att hämta en fullständig version av uppdateringen om följande villkor är uppfyllda:
  • Du har inte tillgång till program-CD:n.
  • Du fick problem när du installerade uppdateringen eftersom det uppstod ett problem med den lokala installationskällan.
Du använder Microsoft Download Center från följande Microsoft-webbplats:
http://www.microsoft.com/downloads/search.aspx?displaylang=sv
Du söker efter uppdateringen som du vill installera genom att följa följande steg:
  1. Om du vet namnet på den uppdatering som du vill installera, anger du namnet i rutan Nyckelord (valfritt) och klickar sedan på .

    Dölj bildenVisa bilden
    Microsoft Download Center - Microsoft Internet Explorer


    Om du i stället vill hitta alla tillgängliga uppdateringar klickar du produkten i listan över produktfamiljer och sedan på .

    Dölj bildenVisa bilden
    Microsoft Download Center - Microsoft Internet Explorer


  2. Hitta och klicka på sedan på uppdateringen du vill installera.

    Dölj bildenVisa bilden
    Microsoft Download Center - Microsoft Internet Explorer


  3. Läs på webbsidan där hämtar uppdateringen om det finns en fullständig version av uppdateringen. Om det finns en fullständig version av uppdateringen klickar du på den och följer sedan hämtningsinstruktionerna och installerar uppdateringen.

    Dölj bildenVisa bilden
    Microsoft Download Center - Microsoft Internet Explorer

Mer Information

När du installerar ett Office 2003-program kopieras källfilerna från Office 2003-programmet till följande mapp på den lokala hårddisken om det finns plats:
Enhet:\MSOCache\All Users\90000409-6000-11D3-8CFE-0150048383C9

Använda verktyget Local Installation Source

  1. Avsluta alla Office 2003-program.
  2. Gå till följande Microsoft-webbplats:
    http://www.microsoft.com/downloads/details.aspx?familyid=10FA7AA3-695B-42C3-9045-B812BA0FED3E
    Dölj bildenVisa bilden
    Microsoft Internet Explorer


  3. Klicka på Hämta.

    Dölj bildenVisa bilden
    Microsoft Internet Explorer


  4. Klicka på Spara i dialogrutan Filhämtning.

    Dölj bildenVisa bilden
    Dialogrutan Filhämtning


  5. Ange mappen där du vill spara filen LISTool.exe och klicka på Spara.

    Dölj bildenVisa bilden
    Dialogrutan Spara som


  6. Starta Utforskaren.

    Dölj bildenVisa bilden
    Dialogrutan Kör


  7. Öppna mappen som du har hämtat LISTool.exe till och dubbelklicka på LISTool.exe.

    Dölj bildenVisa bilden
    Skrivbordet


  8. Ange sökvägen till mappen och klicka sedan på OK.

    Dölj bildenVisa bilden
    Dialogrutan Microsoft


    Eller klicka på Bläddra för att öppna mappen som du vill extrahera LISTool.exe till.

    Dölj bildenVisa bilden
    Dialogrutan Microsoft


Om det uppstår ett problem med den lokala installationskällan kan du använda verktyget Local Installation Source för att försöka lösa problemet.

Om du vill ta bort och inaktivera den lokala installationskällan för programmet följer du dessa steg:
  1. Öppna mappen som du extraherade verktyget Local Installation Source till och dubbelklicka sedan på LISTool.exe.

    Dölj bildenVisa bilden
    Utforskaren


  2. Klicka på Ta bort och inaktivera LIS och klicka sedan på Nästa.

    Dölj bildenVisa bilden
    Local Installation Source-verktyg för Microsoft Office 2003


  3. Godkänn licensavtalet och klicka på Nästa.

    Dölj bildenVisa bilden
    Local Installation Source-verktyg för Microsoft Office 2003


  4. Markera kryssrutan för programmet som du vill inaktivera den lokala installationskällan för och klicka sedan på Nästa. Markera till exempel kryssrutan Microsoft Office Project Professional Edition 2003.

    Dölj bildenVisa bilden
    Local Installation Source-verktyg för Microsoft Office 2003


  5. Klicka på Ta bort.

    Dölj bildenVisa bilden
    Local Installation Source-verktyg för Microsoft Office 2003


  6. Klicka på OK när följande meddelande visas:
    Den lokala installationskällan för Microsoft Office har tagits bort och inaktiverats.


    Dölj bildenVisa bilden
    Local Installation Source-verktyg för Microsoft Office 2003


Om du vill aktivera den lokala installationskällan för programmet följer du dessa steg:

Obs! Du måste ha CD-skivan med programmet för att utföra dessa steg.
  1. Sök rätt på din kopia av programskivan.
  2. Öppna mappen som du extraherade verktyget Local Installation Source till och dubbelklicka sedan på LISTool.exe.

    Dölj bildenVisa bilden
    Utforskaren


  3. Klicka på Aktivera LIS och sedan på Nästa.

    Dölj bildenVisa bilden
    Local Installation Source-verktyg för Microsoft Office 2003


  4. Godkänn licensavtalet och klicka på Nästa.

    Dölj bildenVisa bilden
    Local Installation Source-verktyg för Microsoft Office 2003


  5. Markera kryssrutan för programmet som du vill inaktivera den lokala installationskällan för och klicka sedan på Nästa. Markera till exempel kryssrutan Microsoft Office Project Professional 2003.

    Dölj bildenVisa bilden
    Local Installation Source-verktyg för Microsoft Office 2003


  6. Klicka på Aktivera.

    Dölj bildenVisa bilden
    Local Installation Source-verktyg för Microsoft Office 2003


  7. Klicka på OK när följande meddelande visas:
    Den lokala installationskällan för Microsoft Office har aktiverats.


    Dölj bildenVisa bilden
    Local Installation Source-verktyg för Microsoft Office 2003


Om du vill veta mer om funktionen för lokal installationskälla klickar du på följande artikelnummer och läser artikeln i Microsoft Knowledge Base:
830168 Vanliga frågor om funktionen för lokal installationskälla i Office 2003 (Länken kan leda till en webbplats som är helt eller delvis på engelska)
De produkter från andra tillverkare som diskuteras i denna artikel tillverkas oberoende av Microsoft. Produkternas funktion eller tillförlitlighet kan därför inte garanteras.

Egenskaper

Artikel-id: 875556 - Senaste granskning: den 22 januari 2007 - Revision: 6.6
Informationen i denna artikel gäller:
  • Microsoft Office Access 2003
  • Microsoft Office Excel 2003
  • Microsoft Office FrontPage 2003
  • Microsoft Office InfoPath 2003
  • Microsoft Office OneNote 2003
  • Microsoft Office Outlook 2003
  • Microsoft Office PowerPoint 2003
  • Microsoft Office Project Professional 2003
  • Microsoft Office Project Standard 2003
  • Microsoft Office Publisher 2003
  • Microsoft Office Visio Professional 2003
  • Microsoft Office Professional Edition 2003
  • Microsoft Office Visio Standard 2003
  • Microsoft Office Word 2003
  • Microsoft Office Standard Edition 2003
  • Microsoft Office Student and Teachers Edition 2003
  • Microsoft Office Small Business Edition 2003
  • Microsoft Office Basic Edition 2003
Nyckelord: 
kbnomt kbgraphxlink kbscreenshot kberrmsg kbprb KB875556

Ge feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com