ダウンロードの処理中に エラー 0x80246008 が発生する

文書番号: 875562 - 対象製品
すべて展開する | すべて折りたたむ

目次

概要

この資料は、Windows Update サイトから更新プログラムをダウンロード中に、0x80246008 エラーが表示される現象について説明しています。

注意: 本技術資料は、新しい Windows Update サイト (Windows Update v6) を使用しているユーザーを対象としています。Windows Update v6 が利用可能なユーザーは、Windows Update を行った際に、自動的に誘導されます。

原因

このエラーは、Background Intelligent Transfer Service (BITS) が有効でない場合に発生します。
注 : 自動更新機能を使用していない場合でも、Windows Update で使用するために、このサービスを有効にする必要があります。

解決方法

SvcHost プロセスに BITS を追加します。

*警告* 以下の手順には、レジストリ エディタの操作が含まれています。レジストリ エディタの使用を誤ると、オペレーティング システムの再インストールが必要になるような、深刻な問題が発生する可能性があります。レジストリ エディタの誤った使用に伴う問題については、一切保証できません。レジストリ エディタは、自己責任でご利用ください。
  1. Windows の [スタート] メニューをクリックします。
  2. [ファイル名を指定して実行] をクリックします。
  3. [名前] ボックスにregeditと入力します。
  4. [OK] をクリックします。
  5. レジストリ エディタが開きます。
  6. 次のレジストリ キーへ移動します。

    HKEY_Local_Machine\Software\Microsoft\WindowsNT\CurrentVersion\SvcHost

  7. netsvcs キーをダブルクリックして開きます。
  8. [値のデータ] の一覧に、BITS が存在しない場合は、BITSと入力して追加します。

    元に戻す画像を拡大する
    875562 WindowsUpdate01
  9. レジストリの編集を終了します。
  10. Windows を再起動します。

問題が回避できない場合


STEP1:  BITS の動作に必要なレジストリ キーが存在するかどうかを確認します。
  1. レジストリ エディタが開きます。
  2. 次のレジストリ キーへ移動します。

    HKEY_Local_Machine\System\CurrentControlSet\Control

  3. BackupRestore キーをダブルクリックして開きます。
  4. 一覧に FilesNotToBackup が存在するかどうかを確認します。存在しない場合は、STEP2 に進んでください。
  5. レジストリの編集を終了します。

STEP2: STEP1 で BITS  に必要なレジストリ キー (FilesNotToBackup) が存在しない場合、以下の手順をおこないます。
  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。
  2. 以下のコマンドをコピーして、[名前] ボックスに貼り付けます。

    Reg.exe ADD HKLM\System\CurrentControlSet\Control\BackupRestore\FilesNotToBackup /v BITS_metadata /t REG_MULTI_SZ /d "%ALLUSERSPROFILE%\Application Data\Microsoft\Network\Downloader\*" /f

  3. [OK] をクリックします

注意 : これは、マイクロソフトのサポート組織内で直接作成された "緊急公開" の資料です。 この資料には、確認中の問題に関する現状ベースの情報が記載されています。 情報提供のスピードを優先するため、資料には誤植が含まれる可能性があり、予告なしに随時改定される場合があります。 その他の考慮事項については、使用条件を参照してください。

プロパティ

文書番号: 875562 - 最終更新日: 2010年9月14日 - リビジョン: 3.0
この資料は以下の製品について記述したものです。
  • Microsoft Windows Update
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Professional x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Server
キーワード:?
kbhowto kbwindowsupdatev5 kberrmsg KB875562
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com