"System Message 5045" error message in various locations in Microsoft Dynamics SL

This article provides a solution to an error that occurs in various locations in Microsoft Dynamics SL.

Applies to:   Microsoft Dynamics SL
Original KB number:   875699

Symptoms

Consider the following scenarios in various locations in Microsoft Dynamics SL.

  • You try to sign in to Microsoft Dynamics SL. See Cause 1, 2, or 3.
  • Or, you do any action that creates a Microsoft Dynamics SL event log. See all causes.
  • Or, you select Start in the Database Physical Integrity Check (95.500.00) screen. See Cause 5.

In these scenarios, you receive the following error message:

System Message 5045 - File error attempting to open process status file

Cause

This problem occurs for one or more of the following reasons.

Cause 1

The Windows user ID has insufficient permissions for the operation. See Resolution 1.

Cause 2

The logical drive mapped to the Microsoft Dynamics SL installation is incorrect. See Resolution 2.

Cause 3

The Solomon.ini file on the workstation computer is corrupted. See Resolution 3.

Cause 4

The event log files are corrupted. See Resolution 4.

Cause 5

The PSTATUS table is corrupted. See Resolution 5.

Resolution

To resolve this problem, use the appropriate resolution.

Resolution 1

Assign appropriate permissions to the Microsoft Dynamics SL users.

  1. Contact the Network Administrator to verify that the Windows user ID has sufficient permissions.
  2. Make sure that all Microsoft Dynamics SL users have full control over the directory where you installed Microsoft Dynamics SL. The default location of the installation is as follows:
    • Microsoft Dynamics SL 7.0 and later versions: DriveLetter:\Program Files\Microsoft Dynamics\SL\Applications
    • Microsoft Dynamics SL 6.5 and earlier versions: DriveLetter:\Program Files\Solomon\

Resolution 2

Share and map the drive to the correctly. The default location of the Microsoft Dynamics SL installation is as follows:

  • Microsoft Dynamics SL 7.0 and later versions: DriveLetter:\Program Files\Microsoft Dynamics\SL\Applications
  • Microsoft Dynamics SL 6.5 and earlier versions: DriveLetter:\Program Files\Solomon

In this case, drives from workstation computers should be mapped either to the root of the volume or to one of the following locations, depending on your version:

  • Microsoft Dynamics SL 7.0 and later versions: DriveLetter:\Program Files\Microsoft Dynamics SL\
  • Microsoft Dynamics SL 6.5 and earlier versions: DriveLetter:\Program Files\

It means that either the root of the volume or one of the locations that were discussed earlier should be shared. From the workstation computers, the icon properties for the main program should be either:

  • Microsoft Dynamics SL 7.0 and later versions: DriveLetter:\SL\Applications\MSDynamicsSL.exe or DriveLetter:\Applications\MSDynamicsSL.exe
  • Microsoft Dynamics SL 6.5 or earlier versions: DriveLetter:\Program Files\Solomon\Parent.exe or DriveLetter:\Solomon\Parent.exe

Note

The icon properties shouldn't be one of the following locations (which indicates a map root):

  • Microsoft Dynamics SL 7.0 and later versions: DriveLetter:\MSDynamicsSL.exe
  • Microsoft Dynamics SL 6.5 and earlier versions: DriveLetter:\Parent.exe

The Icon properties shouldn't be one of the following locations (which indicates a UNC path):

  • Microsoft Dynamics SL 7.0 and later versions: \\Servername\sharename\Applications\MSDynamicsSL.exe
  • Microsoft Dynamics SL 6.5 and earlier versions: \\Servername\sharename\Solomon\Parent.exe

UNC paths aren't supported within Microsoft Dynamics SL or Microsoft Business Solutions - Solomon.

Resolution 3

Rename all Solomon.ini files on the workstation computer to Solomon.old.

Resolution 4

Delete all the event log files in the following locations:

  • Microsoft Dynamics SL 7.0 and later versions: DriveLetter:\Program Files\Microsoft Dynamics\SL\Applications\Eventlog\
  • Microsoft Dynamics SL 6.5 and earlier versions: DriveLetter:\Program Files\Solomon\Eventlog\

Resolution 5

Delete the corrupted records in the PSTATUS table.

Note

Before you follow the instructions in this article, make sure that you have a complete backup copy of the database that you can restore if a problem occurs.

Using SQL Server Management Studio or SQL Query Analyzer, run the following statement against the Microsoft Dynamics SL application database or the Microsoft Business Solutions - Solomon application database:

Delete from PSTATUS