Errore "System Message 5003 - Unable to open the specified server database" (Messaggio di sistema 5003 - Impossibile aprire il database del server specificato) quando si tenta di accedere a Microsoft Dynamics SL

Questo articolo fornisce soluzioni a un errore che si verifica quando si tenta di accedere a Microsoft Business Solutions - Solomon o Microsoft Dynamics SL.

Si applica a: Microsoft Dynamics SL
Numero KB originale: 875704

Sintomi

Quando si tenta di accedere a Microsoft Business Solutions - Solomon o Microsoft Dynamics SL, viene visualizzato il messaggio di errore seguente:

Messaggio di sistema 5003 - Impossibile aprire il database del server specificato

Causa

Questo problema si verifica per uno o più dei motivi seguenti.

Causa 1

Il valore servername nella tabella di dominio nel database di sistema di Microsoft Dynamics SL non corrisponde al nome dell'istanza del SQL Server che contiene i database di Microsoft Dynamics SL. Vedere Risoluzione 1.

Causa 2

Un alias nell'utilità di rete client punta a un server precedente. Assicurarsi che l'alias nell'utilità di rete client sia corretto. Vedere Risoluzione 2.

Causa 3

Il protocollo Named Pipes e il protocollo TCP/IP non sono abilitati nell'utilità di rete client. Vedere Risoluzione 3.

Causa 4

Quando si tenta di accedere a un nuovo database dell'applicazione Microsoft Dynamics SL e il nome del database inizia con un numero, viene visualizzato l'errore. Poiché esiste una limitazione in SQL Server, i nomi di database devono iniziare usando un carattere alfabetico. Vedere Risoluzione 4.

Causa 5

Non è possibile stabilire una connessione Named Pipes al server perché le autorizzazioni di Windows sono insufficienti. Vedere Risoluzione 5.

Causa 6

TCP/IP non è configurato correttamente. Vedere Risoluzione 6.

Causa 7

Il database è impostato sulla modalità Single-User. Vedere Risoluzione 7.

Causa 8

Il file Capicom.dll nel computer in cui viene ricevuto l'errore è danneggiato o la versione non è corretta. Vedere Risoluzione 8.

Causa 9

Windows Firewall nel SQL Server blocca l'accesso ai database SQL Server/SL. Vedere Risoluzione 9.

Causa 10

Si usa il modello di sicurezza dell'autenticazione di Windows in Microsoft Dynamics SL. Tuttavia, l'ID utente in Microsoft Dynamics SL non è stato collegato all'ID utente in Windows. Inoltre, è stato creato manualmente lo stesso ID utente nel database di sistema di Microsoft Dynamics SL in SQL Server. Vedere Risoluzione 10.

Causa 11

L'account utente di Microsoft Dynamics SL è membro del gruppo ADMINISTRATORS in Microsoft Dynamics SL. Tuttavia, l'account utente di dominio Windows correlato non è un membro del ruolo sysadmin in SQL Server. Vedere Risoluzione 11 e Risoluzione 12.

Causa 12

Windows Firewall in Windows Server 2008 R2 blocca l'accesso ai database SQL Server/SL. Vedere Risoluzione 13.

Causa 13

Si verifica nella schermata Trova database (98.000.01) quando si seleziona un database dell'applicazione nella casella Nome database. Vedere Risoluzione 14.

Causa 14

Si verifica nella schermata Trova database (98.000.01) quando si seleziona OK dopo aver selezionato Nome server e Nome database. Vedere Risoluzione 15.

Risoluzione

Per risolvere il problema, usare la risoluzione appropriata.

Risoluzione 1

Verificare il valore del nome server nella tabella di dominio per assicurarsi che il valore corrisponda al nome dell'istanza del SQL Server in cui si trova l'installazione di Microsoft Dynamics SL.

  1. In SQL Server Management Studio eseguire l'istruzione seguente nel database di sistema di Microsoft Dynamics SL.

    Select servername, * from domain
    
  2. Se il valore servername non corrisponde al nome dell'istanza di SQL Server, eseguire l'istruzione seguente per aggiornare il valore del nome server:

    UPDATE Domain SET ServerName = '<Nameofserver>'
    --Replace the <Nameofserver> placeholder with the instance name of SQL Server.
    
  3. Accedere a Manutenzione database.

  4. Nella scheda Aggiorna database selezionare il database di sistema di Microsoft Dynamics SL e tutti i database dell'applicazione associati e quindi selezionare Aggiorna visualizzazioni.

Risoluzione 2

Rimuovere l'alias che fa riferimento al server precedente. Per effettuare questa operazione, seguire questi passaggi:

  1. Selezionare Start, selezionare Esegui, digitare cliconfg e quindi premere INVIO.
  2. Nella scheda Alias verificare che tutti gli alias elencati siano corretti e siano per i server correnti. Se uno degli alias fa riferimento ai server precedenti, usare il puntatore per spostare lo stato attivo su quello che si vuole rimuovere e quindi selezionare Rimuovi.
  3. Seleziona OK.

In un computer a 32 bit:
Vai all'avvio>Tipo di esecuzione>cliconfg

In un computer a 64 bit:

  1. Passare a C:\Windows\SysWOW64
  2. Eseguire cliconfg.exe che si trovano in tale cartella

Risoluzione 3

Verificare che named pipe e TCP/IP siano abilitati nell'utilità di rete client.

  1. Selezionare Start, selezionare Esegui, digitare cliconfg e quindi premere INVIO.

  2. Nella scheda Generale verificare che il protocollo Named Pipes e il protocollo TCP/IP siano visualizzati in Protocolli abilitati in base all'ordine. Se questi protocolli non sono abilitati, usare il puntatore per spostare lo stato attivo su ognuno di essi e quindi selezionare Abilita.

  3. Se il protocollo Named Pipes non è il primo protocollo nell'elenco, selezionare il protocollo Named Pipes e usare i tasti di direzione per spostarlo.

  4. Seleziona OK.

    Nota

    In genere, non esiste alcuna raccomandazione di impostazione su quale protocollo deve essere caricato per primo. A seconda delle configurazioni di rete, un protocollo può funzionare meglio dell'altro.

In un computer a 32 bit:

  1. Vai all'avvio>Tipo di esecuzione>cliconfg
  2. Assicurarsi che named pipe e TCP/IP siano abilitati.

In un computer a 64 bit:

  1. Passare a C:\Windows\SysWOW64.
  2. Eseguire cliconfg.exe che si trovano in tale cartella
  3. Assicurarsi che named pipe e TCP/IP siano abilitati.

Risoluzione 4

Creare un backup dell'applicazione Microsoft Dynamics SL esistente e dei database di sistema, quindi ripristinare i database nello stesso server usando nomi di database alfa.

Nota

Nel passaggio 4 assicurarsi di ripristinare il database allo stesso SQL Server.

Risoluzione 5

Concedere all'utente autorizzazioni sufficienti in Windows.

Nota

SQL Server non è in grado di leggere le impostazioni del Registro di sistema per stabilire una connessione Named Pipe perché l'utente dispone di autorizzazioni insufficienti in Windows. Per assistenza, contattare l'amministratore del sistema di rete.

Risoluzione 6

Verificare che TCP/IP sia configurato correttamente.

  1. Se si usa DHCP per assegnare indirizzi IP, assicurarsi che il computer che genera l'errore stia consentendo al server DHCP di assegnare l'indirizzo anziché assegnare un indirizzo IP statico.

  2. Verificare che la workstation possa effettuare il ping del server. Per effettuare questa operazione, seguire questi passaggi:

    1. Selezionare Start, selezionare Esegui, digitare cmd e quindi premere INVIO.

    2. Al prompt DOS digitare ping <ServerName> o digitare ping <ServerIPAddress>.

      Nota

      Sostituire il <segnaposto ServerName> con il nome del server. Sostituire il <segnaposto ServerIPAddress> con l'indirizzo IP del server.

  3. Se si usa la risoluzione DNS statica, aggiungere il server che esegue SQL Server all'elenco Ordine di ricerca server DNS disponibile in Rete - Proprietà TCP/IP - Configurazione DNS o al file host nel computer della workstation. Per assistenza, contattare l'amministratore del sistema di rete.

Risoluzione 7

Deselezionare l'accesso utente singolo nelle proprietà del database.

  1. Aprire SQL Server Management Studio.
  2. Espandere Database.
  3. Fare clic con il pulsante destro del mouse sul database dell'applicazione Microsoft Dynamics SL e scegliere Proprietà.
  4. Nella pagina Opzioni verificare che l'opzione Utente singolo non sia selezionata come valore Limita accesso .

Risoluzione 8

Verificare la versione del file Capicom.dll e registrare manualmente il file.

  1. Individuare il file Capicom.dll nei percorsi seguenti:

    Sistema operativo a 32 bit: <SystemDrive>:\Windows\System32

    Sistema operativo a 64 bit: <SystemDrive>:\Windows\SysWOW64

    Nota

    <SystemDrive> rappresenta l'unità in cui è installato Microsoft Windows.

  2. Verificare che la versione del file Capicom.dll sia 2.1.0.1. Per effettuare questa operazione, seguire questi passaggi:

    1. Fare clic con il pulsante destro del mouse sul file Capicom.dll e quindi scegliere Proprietà. Verrà visualizzata la finestra di dialogo Proprietàcapicom.dll .
    2. Nella scheda Versione verificare che il valore della versione file sia 2.1.0.1.
    3. Seleziona OK.
  3. Fare clic con il pulsante destro del mouse sul file Capicom.dll e quindi scegliere Apri con.

  4. Nella finestra di dialogo Windows selezionare Seleziona il programma da un elenco e quindi selezionare OK.

  5. Nella finestra di dialogo Apri con selezionare Sfoglia.

  6. Individuare e aprire la cartella seguente:

    Sistema operativo a 32 bit: <SystemDrive>:\Windows\System32 sistema operativo a 64 bit: <SystemDrive>:\Windows\SysWOW64

  7. Fare doppio clic sul file Regsvr32.exe e quindi selezionare OK.

  8. Selezionare OK quando si riceve il messaggio seguente:

    RegSvr32 - DllRegisterServer in SystemDrive :\windows\system32\capicom.dll riuscito.

Risoluzione 9

Aprire la porta 1433 sulla SQL Server. Per effettuare questa operazione, seguire questi passaggi:

  1. In Pannello di controllo selezionare Windows Firewall.
  2. Nella scheda Eccezioni selezionare Aggiungi porta.
  3. Specificare le impostazioni seguenti:
    • Nome: 1433
    • Numero porta: 1433
    • Selezionare TCP.
  4. Selezionare due volte OK.

Risoluzione 10

Eliminare l'ID utente creato in SQL e quindi collegare l'ID utente di Microsoft Dynamics SL all'ID utente di Windows. Per effettuare questa operazione, seguire questi passaggi:

  1. Eliminare l'ID utente creato in SQL:

    1. In SQL Server Management Studio espandere Database, espandere il database di sistema di Microsoft Dynamics SL, espandere Sicurezza e quindi Utenti.
    2. Fare clic con il pulsante destro del mouse sull'ID utente creato e quindi scegliere Elimina.
    3. Nella finestra di dialogo Elimina oggetto selezionare OK.
  2. Collegare l'ID utente di Microsoft Dynamics SL all'ID utente di Windows:

    1. Accedere a Microsoft Dynamics SL usando l'ID utente SYSADMIN.

    2. Nel riquadro di spostamento selezionare Amministrazione.

    3. Nel riquadro Dettagli amministrazione selezionare Manutenzione utente in Sicurezza.

    4. Nella casella ID utente digitare l'ID utente che non può accedere a Microsoft Dynamics SL.

    5. Nella scheda Dettagli digitare NomeDominio NomeUtente><\<> nella casella Nome utente di Windows.

      Nota

      Sostituire il <segnaposto DomainName> con il nome di dominio Windows e sostituire il <segnaposto UserName> con l'ID utente di Windows.

    6. Selezionare Salva e quindi chiudere la schermata Manutenzione utente (95.260.00).

Risoluzione 11

Sincronizzare la proprietà e la sicurezza nei database di Microsoft Dynamics SL. Per effettuare questa operazione, seguire questi passaggi:

  1. Aprire la schermata Manutenzione database (98.290.00).
  2. Nella casella Nome SQL Server destinazione digitare il nome del server.
  3. Nella casella ID di accesso digitare sa.
  4. Nella casella Password digitare la password per l'utente SYSADMIN.
  5. Selezionare Connetti.
  6. Nella scheda Aggiorna database selezionare il database di sistema nella casella Nome database di sistema.
  7. Nella colonna Database selezionare il database dell'applicazione.
  8. Nell'area Scenari di aggiornamento selezionare Sincronizza tutta la proprietà & Sicurezza.
  9. Selezionare Aggiorna database.
  10. Chiudere la schermata Manutenzione database (98.290.00).

Risoluzione 12

Rimuovere e leggere tutti gli utenti nel gruppo ADMINISTRATORS in Microsoft Dynamics SL. Per effettuare questa operazione, seguire questi passaggi:

Nota

Questa risoluzione presuppone che uno o più account utente di Microsoft Dynamics SL con autorizzazioni amministrative possano accedere a Microsoft Dynamics SL.

  1. Accedere al dominio usando un account utente di dominio Windows collegato a un account utente di Microsoft Dynamics SL con autorizzazioni amministrative.
  2. Selezionare Amministrazione.
  3. Nel riquadro System Manager selezionare Manutenzione gruppo in Sicurezza.
  4. Nella casella ID gruppo digitare ADMINISTRATORS e quindi premere TAB.
  5. Nota

    ID utente elencati nell'area Dettagli .

  6. Eliminare tutti gli utenti dall'elenco ad eccezione dell'ID utente attualmente connesso come.
  7. Seleziona Salva.
  8. Aggiungere gli ID utente e quindi selezionare Salva.
  9. Chiudere la schermata Manutenzione gruppo (95.280.00).

Risoluzione 13

Aprire i numeri di porta 1433 e 1434. Per effettuare questa operazione, seguire questi passaggi:

  1. Nel computer che esegue SQL Server selezionare Start, scegliere Strumenti di amministrazione e quindi Selezionare Windows Firewall con sicurezza avanzata.
  2. Fare clic con il pulsante destro del mouse su Regole in ingresso, selezionare Nuova regola e quindi selezionare Avanti.
  3. Selezionare Tutti i programmi e quindi Avanti.
  4. Selezionare Avanti, fare clic per deselezionare la casella di controllo Pubblico e quindi selezionare Avanti.
  5. Digitare SQL SERVER nella casella Nome e quindi selezionare Fine.
  6. Nel riquadro Regole in ingresso fare clic con il pulsante destro del mouse su SQL SERVER e quindi scegliere Proprietà.
  7. Nella scheda Protocolli e porte selezionare TCP nella casella Tipo di protocollo .
  8. Nella casella Porta locale selezionare Porte specifiche e quindi digitare 1433.
  9. Selezionare Applica, quindi selezionare OK.
  10. Fare clic con il pulsante destro del mouse su Regole in ingresso, selezionare Nuova regola e quindi selezionare Avanti
  11. Selezionare Tutti i programmi e quindi Avanti.
  12. Selezionare Avanti, fare clic per deselezionare la casella di controllo Pubblico e quindi selezionare Avanti.
  13. Digitare SQL SERVER BROWSER nella casella Nome e quindi selezionare Fine.
  14. Nel riquadro Regole in ingresso fare clic con il pulsante destro del mouse su SQL SERVER BROWSER e quindi scegliere Proprietà.
  15. Nella scheda Protocolli e porte selezionare UDP nella casella Tipo di protocollo .
  16. Nella casella Porta locale selezionare Porte specifiche e quindi digitare 1434.
  17. Selezionare Applica e quindi ok per chiudere la finestra di dialogo Proprietà SQL SERVER BROWSER .

Risoluzione 14

Selezionare il nome del database di sistema appropriato nella casella Nome database e quindi selezionare OK.

Risoluzione 15

Aggiungere di nuovo un alias al server SQL nell'utilità di rete client SQL Server:

In un computer a 32 bit:

  1. Vai all'avvio>Tipo di esecuzione>cliconfg
  2. Assicurarsi che named pipe e TCP/IP siano abilitati.
  3. Nella scheda Alias selezionare Aggiungi.
  4. In Alias server digitare il nome del server esattamente come si digita nella schermata Trova database .
  5. Lasciare tutto il resto predefinito. (Deve essere predefinito come alias named pipe)
  6. Seleziona OK.
  7. Selezionare Applica.
  8. Seleziona OK.

In un computer a 64 bit:

  1. Accedere a C:\Windows\SysWOW64
  2. Eseguire cliconfg.exe che si trovano in tale cartella
  3. Assicurarsi che named pipe e TCP/IP siano abilitati.
  4. Nella scheda Alias selezionare Aggiungi.
  5. In Alias server digitare il nome del server esattamente come si digita nella schermata Trova database .
  6. Lasciare tutto il resto predefinito. (Deve essere predefinito come alias named pipe)
  7. Seleziona OK.
  8. Selezionare Applica.
  9. Seleziona OK.

Ulteriori informazioni

Per escludere i problemi di rete, creare una connessione ODBC di test nel computer in cui viene visualizzato il messaggio di errore. Per effettuare questa operazione, seguire questi passaggi:

  1. In Pannello di controllo selezionare Strumenti di amministrazione e quindi origini dati (ODBC).
  2. Nella scheda DSN utente selezionare Aggiungi, scorrere fino alla fine dell'elenco, selezionare SQL Server e quindi selezionare Fine.
  3. Specificare le impostazioni seguenti:
    • Nome: TEST
    • Descrizione: TEST
    • Server: digitare il SQL Server a cui connettersi.
  4. Selezionare Avanti.
  5. Selezionare l'autenticazione di Windows o l'autenticazione SQL e digitare il nome utente e la password sa, se necessario.
  6. Selezionare Avanti due volte, selezionare Fine e quindi Selezionare Test origine dati.