Microsoft Dynamics SL'de oturum açmaya çalıştığınızda "Sistem İletisi 5003 - Belirtilen sunucu veritabanı açılamıyor" hatası

Bu makalede, Microsoft Business Solutions - Solomon veya Microsoft Dynamics SL'de oturum açmaya çalıştığınızda oluşan bir hatanın çözümleri sağlanır.

Şunlar için geçerlidir: Microsoft Dynamics SL
Özgün KB numarası: 875704

Belirtiler

Microsoft Business Solutions - Solomon veya Microsoft Dynamics SL'de oturum açmaya çalıştığınızda aşağıdaki hata iletisini alırsınız:

Sistem İletisi 5003 - Belirtilen sunucu veritabanı açılamıyor

Neden

Bu sorun aşağıdaki nedenlerden biri veya daha fazlası nedeniyle oluşur.

Neden 1

Microsoft Dynamics SL sistem veritabanındaki etki alanı tablosundaki sunucu adı değeri, Microsoft Dynamics SL veritabanlarını içeren SQL Server örneğinin adıyla eşleşmiyor. Bkz . Çözüm 1.

Neden 2

İstemci Ağı Yardımcı Programı'ndaki bir diğer ad eski bir sunucuyu gösterir. İstemci Ağ Yardımcı Programı'ndaki diğer adın doğru olduğundan emin olun. Bkz . Çözüm 2.

Neden 3

Adlandırılmış Kanallar protokolü ve TCP/IP protokolü İstemci Ağ Yardımcı Programı'nda etkinleştirilmez. Bkz . Çözünürlük 3.

Neden 4

Yeni bir Microsoft Dynamics SL uygulama veritabanında oturum açmaya çalıştığınızda ve veritabanının adı bir sayı ile başladığında hata görüntülenir. SQL Server sınırlaması olduğundan, veritabanı adlarının alfabetik bir karakter kullanarak başlaması gerekir. Bkz . Çözüm 4.

Neden 5

Windows izinleriniz yetersiz olduğundan sunucuya Adlandırılmış Kanallar bağlantısı kuramazsınız. Bkz . Çözüm 5.

Neden 6

TCP/IP yanlış yapılandırılmış. Bkz . Çözünürlük 6.

Neden 7

Veritabanı Single-User moduna ayarlanır. Bkz . Çözünürlük 7.

Neden 8

Hatanın alındığı bilgisayardaki Capicom.dll dosyası bozuk veya sürüm yanlış. Bkz . Çözünürlük 8.

Neden 9

SQL Server üzerindeki Windows Güvenlik Duvarı, SQL Server/SL veritabanlarına erişimi engelliyor. Bkz . Çözüm 9.

Neden 10

Microsoft Dynamics SL'de Windows Kimlik Doğrulaması güvenlik modelini kullanırsınız. Ancak Microsoft Dynamics SL'deki kullanıcı kimliğini Windows'taki kullanıcı kimliğine bağlamadınız. Ayrıca, SQL Server'daki Microsoft Dynamics SL sistem veritabanında aynı kullanıcı kimliğini el ile oluşturdunuz. Bkz . Çözünürlük 10.

Neden 11

Microsoft Dynamics SL kullanıcı hesabı, Microsoft Dynamics SL'deki ADMINISTRATORS grubunun bir üyesidir. Ancak, ilgili Windows etki alanı kullanıcı hesabı SQL Server'daki sysadmin rolünün üyesi değildir. Bkz . Çözünürlük 11 ve Çözünürlük 12.

Neden 12

Windows Server 2008 R2'deki Windows Güvenlik Duvarı, SQL Server/SL veritabanlarına erişimi engelliyor. Bkz . Çözünürlük 13.

Neden 13

Veritabanı Adı kutusunda bir uygulama veritabanı seçtiğinizde Veritabanı Bul (98.000.01) ekranında gerçekleşir. Bkz . Çözünürlük 14.

Neden 14

Sunucu Adı ve Veritabanı Adı'nı seçtikten sonra Tamam'ı seçtiğinizde Veritabanı Bul (98.000.01) ekranında gerçekleşir. Bkz . Çözünürlük 15.

Çözüm

Bu sorunu çözmek için uygun çözümü kullanın.

Çözüm 1

Değerin Microsoft Dynamics SL yüklemesinin bulunduğu SQL Server örneğinin adıyla eşleştiğinden emin olmak için etki alanı tablosundaki sunucu adı değerini doğrulayın.

  1. SQL Server Management Studio'de, Microsoft Dynamics SL sistem veritabanında aşağıdaki deyimi çalıştırın.

    Select servername, * from domain
    
  2. Sunucu adı değeri SQL Server örnek adıyla eşleşmiyorsa, sunucu adı değerini güncelleştirmek için aşağıdaki deyimi çalıştırın:

    UPDATE Domain SET ServerName = '<Nameofserver>'
    --Replace the <Nameofserver> placeholder with the instance name of SQL Server.
    
  3. Veritabanı Bakımı'nda oturum açın.

  4. Veritabanlarını Güncelleştir sekmesinde, Microsoft Dynamics SL sistem veritabanını ve tüm ilişkili uygulama veritabanlarını ve ardından Görünümleri Güncelleştir'i seçin.

Çözünürlük 2

Eski sunucuya başvuran diğer adı kaldırın. Bunu yapmak için şu adımları uygulayın:

  1. Başlat'ı seçin, Çalıştır'ı seçin, cliconfg yazın ve ENTER tuşuna basın.
  2. Diğer Ad sekmesinde, listelenen tüm diğer adların doğru olduğunu ve geçerli sunucular için olduğunu doğrulayın. Diğer adlardan herhangi biri eski sunuculara başvuruda bulunursa, işaretçiyi kullanarak odağı kaldırmak istediğiniz sunucuya yerleştirin ve kaldır'ı seçin.
  3. Tamam'ı seçin.

32 bit bilgisayarda:
Çalıştırma türü cliconfg'yi>başlatmaya> gidin

64 bit bilgisayarda:

  1. Adresine gidin C:\Windows\SysWOW64
  2. Bu klasörde bulunan cliconfg.exe çalıştırma

Çözüm 3

İstemci Ağ Yardımcı Programı'nda Adlandırılmış Kanallar ve TCP/IP'nin etkinleştirildiğini doğrulayın.

  1. Başlat'ı seçin, Çalıştır'ı seçin, cliconfg yazın ve ENTER tuşuna basın.

  2. Genel sekmesinde, Adlandırılmış Kanallar protokol ve TCP/IP protokollerinin Etkin protokoller'de sırasıyla göründüğünü doğrulayın. Bu protokoller etkin değilse, işaretçiyi kullanarak odağı her birine koyun ve etkinleştir'i seçin.

  3. Adlandırılmış Kanallar protokolü listedeki ilk protokol değilse, Adlandırılmış Kanallar protokolunu seçin ve ok tuşlarını kullanarak taşıyın.

  4. Tamam'ı seçin.

    Not

    Genellikle, önce hangi protokolün yüklenmesi gerektiğine ilişkin belirli bir öneri yoktur. Ağ yapılandırmalarına bağlı olarak, bir protokol diğerinden daha iyi çalışabilir.

32 bit bilgisayarda:

  1. Çalıştırma türü cliconfg'yi>başlatmaya> gidin
  2. Hem Adlandırılmış Kanallar'ın hem de TCP/IP'nin etkinleştirildiğinden emin olun.

64 bit bilgisayarda:

  1. adresine C:\Windows\SysWOW64gidin.
  2. Bu klasörde bulunan cliconfg.exe çalıştırma
  3. Hem Adlandırılmış Kanallar'ın hem de TCP/IP'nin etkinleştirildiğinden emin olun.

Çözünürlük 4

Mevcut Microsoft Dynamics SL uygulamasının ve sistem veritabanlarının yedeğini oluşturun ve ardından alfa veritabanı adlarını kullanarak veritabanlarını aynı sunucuya geri yükleyin.

Not

4. adımda veritabanını aynı SQL Server geri yüklediğinizden emin olun.

Çözünürlük 5

Kullanıcıya Windows'da yeterli izinler verin.

Not

SQL Server, kullanıcının Windows'ta izinleri yetersiz olduğundan Adlandırılmış Kanal bağlantısı kurmak için Kayıt Defteri Ayarları'nı okuyamıyor. Yardım için Ağ Sistemi Yöneticisi'ne başvurun.

Çözünürlük 6

TCP/IP'nin doğru yapılandırıldığını doğrulayın.

  1. IP adresleri atamak için DHCP kullanıyorsanız, hatayı oluşturan bilgisayarın statik IP adresi atamak yerine DHCP sunucusunun adresi atamasına izin verdiğinizden emin olun.

  2. İş istasyonunun sunucuya ping atabildiğini doğrulayın. Bunu yapmak için şu adımları uygulayın:

    1. Başlat'ı seçin, Çalıştır'ı seçin, cmd yazın ve ENTER tuşuna basın.

    2. DOS isteminde ping ServerName> yazın veya ping<<ServerIPAddress> yazın.

      Not

      <ServerName> yer tutucusunun yerine sunucunun adını yazın. <ServerIPAddress> yer tutucusunun yerine sunucunun IP adresini yazın.

  3. Statik DNS çözümlemesi kullanıyorsanız, SQL Server çalıştıran sunucuyu Ağ - TCP/IP Özellikleri - DNS Yapılandırması'nda bulunan DNS Sunucusu Arama Sırası listesine veya iş istasyonu bilgisayarındaki Konak dosyasına ekleyin. Yardım için Ağ Sistemi Yöneticisi'ne başvurun.

Çözüm 7

Veritabanı Özelliklerinde Tek Kullanıcı Erişimini Temizleyin.

  1. SQL Server Management Studio'yu açın.
  2. Veritabanları'nın kapsamını genişletin.
  3. Microsoft Dynamics SL uygulama veritabanına sağ tıklayın ve Özellikler'i seçin.
  4. Seçenekler sayfasında Tek Kullanıcı'nınErişimi Kısıtla değeri olarak seçilmediğini doğrulayın.

Çözünürlük 8

Capicom.dll dosyasının sürümünü doğrulayın ve dosyayı el ile kaydedin.

  1. Aşağıdaki yollarda Capicom.dll dosyasını bulun:

    32 bit İşletim Sistemi: <SystemDrive>:\Windows\System32

    64 bit İşletim Sistemi: <SystemDrive>:\Windows\SysWOW64

    Not

    <SystemDrive> , Microsoft Windows'un yüklü olduğu sürücüyü temsil eder.

  2. Capicom.dll dosyasının sürümünün 2.1.0.1 olduğunu doğrulayın. Bunu yapmak için şu adımları uygulayın:

    1. Capicom.dll dosyasına sağ tıklayın ve özellikler'i seçin. capicom.dll Özellikleri iletişim kutusu görüntülenir.
    2. Sürüm sekmesinde, Dosya sürümü değerinin 2.1.0.1 olduğunu doğrulayın.
    3. Tamam'ı seçin.
  3. Capicom.dll dosyasına sağ tıklayın ve ardından Birlikte Aç'ı seçin.

  4. Windows iletişim kutusunda Listeden programı seçin'i ve ardından Tamam'ı seçin.

  5. Birlikte Aç iletişim kutusunda Gözat'ı seçin.

  6. Aşağıdaki klasörü bulup açın:

    32 bit İşletim Sistemi: <SystemDrive>:\Windows\System32 64 bit İşletim Sistemi: <SystemDrive>:\Windows\SysWOW64

  7. Regsvr32.exe dosyasına çift tıklayın ve tamam'ı seçin.

  8. Aşağıdaki iletiyi aldığınızda Tamam'ı seçin:

    RegSvr32 - SystemDrive'da DllRegisterServer :\windows\system32\capicom.dll başarılı.

Çözüm 9

SQL Server 1433 numaralı bağlantı noktasını açın. Bunu yapmak için şu adımları uygulayın:

  1. Denetim Masası'da Windows Güvenlik Duvarı'nı seçin.
  2. Özel Durumlar sekmesinde Bağlantı Noktası Ekle'yi seçin.
  3. Aşağıdaki ayarları belirtin:
    • Ad: 1433
    • Bağlantı noktası numarası: 1433
    • TCP'yi seçin.
  4. İki kez Tamam'ı seçin.

Çözünürlük 10

SQL'de oluşturduğunuz kullanıcı kimliğini silin ve ardından Microsoft Dynamics SL kullanıcı kimliğini Windows kullanıcı kimliğine bağlayın. Bunu yapmak için şu adımları uygulayın:

  1. SQL'de oluşturduğunuz kullanıcı kimliğini silin:

    1. SQL Server Management Studio'da Veritabanları'nı genişletin, Microsoft Dynamics SL sistem veritabanını genişletin, Güvenlik'i genişletin ve ardından Kullanıcılar'ı genişletin.
    2. Oluşturduğunuz kullanıcı kimliğine sağ tıklayın ve sil'i seçin.
    3. Nesneyi Sil iletişim kutusunda Tamam'ı seçin.
  2. Microsoft Dynamics SL kullanıcı kimliğini Windows kullanıcı kimliğine bağlayın:

    1. SYSADMIN kullanıcı kimliğini kullanarak Microsoft Dynamics SL'de oturum açın.

    2. Gezinti bölmesinde Yönetim'i seçin.

    3. Yönetim ayrıntıları bölmesindeki Güvenlik'in altında Kullanıcı Bakımı'nı seçin.

    4. Kullanıcı Kimliği kutusuna, Microsoft Dynamics SL'de oturum açılmayan kullanıcı kimliğini yazın.

    5. Ayrıntılar sekmesindeki Windows Kullanıcı Adı kutusuna DomainName>UserName<>yazın.<\

      Not

      DomainName yer tutucusunun <yerine Windows etki alanı adını ve UserName> yer tutucusunun <yerine Windows kullanıcı kimliğini yazın.>

    6. Kaydet'i seçin ve ardından Kullanıcı Bakımı (95.260.00) ekranını kapatın.

Çözünürlük 11

Microsoft Dynamics SL veritabanlarındaki sahipliği ve güvenliği eşitleyin. Bunu yapmak için şu adımları uygulayın:

  1. Veritabanı Bakımı (98.290.00) ekranını açın.
  2. Hedef SQL Server Adı kutusuna sunucunun adını yazın.
  3. Oturum Açma Kimliği kutusuna sa yazın.
  4. Parola kutusuna SYSADMIN kullanıcısının parolasını yazın.
  5. Bağlan'ı seçin.
  6. Veritabanını Güncelleştir sekmesindeki Sistem Veritabanı Adı kutusunda sistem veritabanını seçin.
  7. Veritabanları sütununda uygulama veritabanınızı seçin.
  8. Güncelleştirme Senaryoları alanında Tüm Sahipliği Eşitle & Güvenlik'i seçin.
  9. Veritabanını Güncelleştir'i seçin.
  10. Veritabanı Bakımı (98.290.00) ekranını kapatın.

Çözünürlük 12

Tüm kullanıcıları kaldırın ve Microsoft Dynamics SL'deki ADMINISTRATORS grubuna okuyun. Bunu yapmak için şu adımları uygulayın:

Not

Bu çözüm, yönetici izinlerine sahip bir veya birden çok Microsoft Dynamics SL kullanıcı hesabının Microsoft Dynamics SL'de oturum açabileceğini varsayar.

  1. Yönetim izinlerine sahip bir Microsoft Dynamics SL kullanıcı hesabına bağlı bir Windows etki alanı kullanıcı hesabı kullanarak etki alanında oturum açın.
  2. Yönetim'i seçin.
  3. Sistem Yöneticisi bölmesinde Güvenlik'in altında Grup Bakımı'nı seçin.
  4. Grup Kimliği kutusuna ADMINISTRATORS yazın ve SEKME tuşuna basın.
  5. Not

    Ayrıntı alanında listelenen kullanıcı kimlikleri.

  6. Şu anda oturum açtığınız kullanıcı kimliği dışındaki tüm kullanıcıları listeden silin.
  7. Kaydet'i seçin.
  8. Kullanıcı kimliklerini ekleyin ve kaydet'i seçin.
  9. Grup Bakımı (95.280.00) ekranını kapatın.

Çözünürlük 13

1433 ve 1434 numaralı bağlantı noktası numaralarını açın. Bunu yapmak için şu adımları uygulayın:

  1. SQL Server çalıştıran bilgisayarda Başlat'ı seçin, Yönetimsel Araçlar'ın üzerine gelin ve gelişmiş güvenlik özellikli Windows Güvenlik Duvarı'nı seçin.
  2. Gelen Kuralları'ne sağ tıklayın, Yeni Kural'ı ve ardından İleri'yi seçin.
  3. Tüm programlar'ı ve ardından İleri'yi seçin.
  4. İleri'yi seçin, Genel onay kutusunu temizlemek için tıklayın ve ardından İleri'yi seçin.
  5. Ad kutusuna SQL SERVER yazın ve Son'u seçin.
  6. Gelen Kuralları bölmesinde SQL SERVER'a sağ tıklayın ve özellikler'i seçin.
  7. Protokoller ve Bağlantı Noktaları sekmesinde Protokol türü kutusunda TCP'yi seçin.
  8. Yerel Bağlantı Noktası kutusunda Belirli Bağlantı Noktaları'nı seçin ve 1433 yazın.
  9. Uygula'yı ve ardından Tamam'ı seçin.
  10. Gelen Kuralları'ne sağ tıklayın, Yeni Kural'ı ve ardından İleri'yi seçin
  11. Tüm programlar'ı ve ardından İleri'yi seçin.
  12. İleri'yi seçin, Genel onay kutusunu temizlemek için tıklayın ve ardından İleri'yi seçin.
  13. Ad kutusuna SQL SERVER BROWSER yazın ve Son'u seçin.
  14. Gelen Kuralları bölmesinde SQL SERVER BROWSER'a sağ tıklayın ve özellikler'i seçin.
  15. Protokoller ve Bağlantı Noktaları sekmesinde, Protokol türü kutusunda UDP'yi seçin.
  16. Yerel Bağlantı Noktası kutusunda Belirli Bağlantı Noktaları'nı seçin ve 1434 yazın.
  17. Uygula'yı seçin ve ardından TAMAM'ı seçerek SQL SERVER BROWSER Özellikleri iletişim kutusunu kapatın.

Çözünürlük 14

Veritabanı Adı kutusunda uygun sistem veritabanı adını seçin ve ardından Tamam'ı seçin.

Çözünürlük 15

SQL Server İstemci Ağ Yardımcı Programı'nda SQL sunucusuna bir Diğer Ad ekleyin:

32 bit makinede:

  1. Çalıştırma türü cliconfg'yi>başlatmaya> gidin
  2. Hem Adlandırılmış Kanallar'ın hem de TCP/IP'nin etkinleştirildiğinden emin olun.
  3. Diğer Ad sekmesinde Ekle'yi seçin.
  4. Sunucu Diğer Adı için, sunucu adınızı tam olarak Veritabanlarını Bul ekranında yazdığınız gibi yazın.
  5. Diğer her şeyi varsayılan olarak bırakın. (Varsayılan olarak adlandırılmış kanallar diğer adı olmalıdır)
  6. Tamam'ı seçin.
  7. Uygula'yı seçin.
  8. Tamam'ı seçin.

64 bit makinede:

  1. Adresine gidin C:\Windows\SysWOW64
  2. Bu klasörde bulunan cliconfg.exe çalıştırma
  3. Hem Adlandırılmış Kanallar'ın hem de TCP/IP'nin etkinleştirildiğinden emin olun.
  4. Diğer Ad sekmesinde Ekle'yi seçin.
  5. Sunucu Diğer Adı için, sunucu adınızı tam olarak Veritabanlarını Bul ekranında yazdığınız gibi yazın.
  6. Diğer her şeyi varsayılan olarak bırakın. (Varsayılan olarak adlandırılmış kanallar diğer adı olmalıdır)
  7. Tamam'ı seçin.
  8. Uygula'yı seçin.
  9. Tamam'ı seçin.

Ek Bilgi

Ağ sorunlarını dışlamak için, hata iletisini aldığınız bilgisayarda bir test ODBC bağlantısı oluşturun. Bunu yapmak için şu adımları uygulayın:

  1. Denetim Masası'da Yönetim Araçları'nı ve ardından Veri Kaynakları (ODBC) öğesini seçin.
  2. Kullanıcı DSN sekmesinde Ekle'yi seçin, listenin sonuna kaydırın, SQL Server'ı seçin ve ardından Son'u seçin.
  3. Aşağıdaki ayarları belirtin:
    • Ad: TEST
    • Açıklama: TEST
    • Sunucu: Bağlanmak istediğiniz SQL Server yazın.
  4. İleri'yi seçin.
  5. Windows kimlik doğrulaması veya SQL kimlik doğrulaması'nı seçin ve gerekirse sa kullanıcı adını ve parolasını yazın.
  6. İki kez İleri'yi seçin, Son'u ve ardından Veri Kaynağını Test Et'i seçin.