Las imágenes no aparecen como esperaba o recibe un mensaje de error cuando abre un archivo HTML en un equipo con el Service Pack 2 de Windows XP

Seleccione idioma Seleccione idioma
importante Este artículo contiene información que muestra cómo reducir la configuración seguridad o desactivar las características de seguridad en un equipo. Puede realizar estos cambios para evitar un problema concreto. Antes de realizar estos cambios, le recomendamos que evalúe los riesgos asociados a esta solución en su entorno concreto. Si decide implementar esta forma de evitar el problema, tome las medidas adicionales oportunas para ayudar a proteger su sistema.

En este artículo

Show all imageMostrar todoHide all imageOcultar todo

Síntomas

Al abrir un archivo HTML en un programa después de instalar Microsoft Windows XP Service Pack 2 (SP2), puede aparecer uno de los problemas siguientes:
  • Recibe un mensaje de error de secuencia de comandos al ver el archivo HTML en un programa basado en Windows.
  • Recibe un mensaje de error ActiveX al ver el archivo HTML en un programa basado en Windows.
  • Cuando se abre el archivo HTML en Microsoft Internet Explorer, las imágenes no aparecen tal como se espera.

Causa

Estos problemas pueden deberse a una característica de seguridad mejorada que se incluye en Windows XP SP2. Esta característica de seguridad mejorada ayuda a proteger su equipo contra ataques por usuarios malintencionados o por software malintencionado, como los virus informáticos. De forma predeterminada, esta característica está activada en el registro.

Solución

Advertencia Esta solución puede hacer que el equipo o su red sean más vulnerables a ataques de usuarios malintencionados o de software malintencionado como virus. Nos no recomendamos esta solución, pero son proporcionar esta información para que esta solución se puede implementar su propia discreción. Utilice esta solución bajo su responsabilidad.

importante Esta sección, el método o la tarea contiene pasos que indican cómo modificar el registro. Sin embargo, pueden producirse problemas graves si modifica incorrectamente el registro. Por tanto, asegúrese de que siga estos pasos cuidadosamente. Realice una para agregar protección, copia de seguridad del registro antes de modificarlo. A continuación, puede restaurar el registro si se produce un problema. Para obtener más información acerca de cómo realizar una copia de seguridad y restaurar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756Cómo realizar una copia de seguridad y restaurar el registro de Windows


Para evitar estos problemas, cambie el valor de la subclave
FEATURE_LOCALMACHINE_LOCKDOWN
a 0.

Nota De forma predeterminada, el valor de la subclave
FEATURE_LOCALMACHINE_LOCKDOWN
se establece en 1 en Windows XP SP2.

Para ello, siga estos pasos:
  1. Salga de todos los programas basados en Windows.
  2. Haga clic en Inicio , haga clic en Ejecutar , escriba regedit en el cuadro Abrir y, a continuación, haga clic en Aceptar .
  3. Busque y haga clic en la siguiente subclave del Registro:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_LOCALMACHINE_LOCKDOWN
  4. En la subclave
    FEATURE_LOCALMACHINE_LOCKDOWN
    , siga estos pasos:
    1. Haga clic en iexplore.exe .
    2. En el menú Edición , haga clic en Modificar .
    3. En el cuadro datos del valor , escriba 0 y, a continuación, haga clic en Aceptar .
    4. Haga clic en Explore.exe .
    5. En el menú Edición , haga clic en Modificar .
    6. En el cuadro datos del valor , escriba 0 y, a continuación, haga clic en Aceptar .
  5. Para salir del Editor del registro, haga clic en Salir en el menú archivo .
  6. Reinicie Windows.

Para obtener más información

Cuando el valor de la subclave
FEATURE_LOCALMACHINE_LOCKDOWN
se establece en 1, las siguientes restricciones se exigen por Windows XP SP2 para tanto Microsoft Internet Explorer y Microsoft Windows Explorer:
  • No permitir ActiveX.
  • No permitir los comportamientos de binarios.
  • Deshabilitar java.
  • Solicitar secuencia de comandos está ejecutando.
  • Solicitar datos entre dominios.
Los problemas que se describen en la sección "Síntomas" se sabe que produce con los programas siguientes:
  • Broderbund 3D Home Architect 5.0 Deluxe
  • Adobe Photoshop 7.0
  • Macromedia Flash
  • Studio MX de Macromedia Dreamweaver MX 6.0
  • Studio MX de Macromedia Flash MX 6.0
  • Microsoft Excel 2002
  • Microsoft Office Excel 2003
  • Microsoft Office Outlook 2003
  • Microsoft Office PowerPoint 2003
  • Service Pack 2 de Microsoft PowerPoint 2002
  • Microsoft PowerPoint 2002
  • Microsoft Office Publisher 2003
  • Microsoft Office Visio 2003
  • Microsoft Visio 2002 Service Release 1
  • Microsoft Works Suite 2003 (Microsoft Word 2002)
  • ValuSoft imprimir Workshop 2003
Los productos de terceros que se analizan en este artículo están fabricados por compañías independientes de Microsoft. Microsoft no otorga ninguna garantía, implícita o de otro tipo, respecto al rendimiento o confiabilidad de estos productos.

Acerca de este artículo

Id. de artículo: 878461
Última revisión: viernes, 8 de julio de 2005
La información de este artículo se refiere a:: Microsoft Windows XP Professional Service Pack 2 (SP2), Microsoft Windows XP Home Edition Service Pack 2 (SP2)
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 878461
¿Desea realizar algún comentario sobre este artículo?
 

Get more support from smallbusiness.support.microsoft.com

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.