Solución de problemas de documentos en Word para Windows dañados

Seleccione idioma Seleccione idioma
Id. de artículo: 87856 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Resumen

Archivos de documentos dañados pueden hacer que cualquier programa muestre un comportamiento inusual. Dicho comportamiento se produce porque el programa intenta tomar decisiones acerca de qué hacer basan en una información incorrecta en el archivo.

La mejor forma de protegerse contra daños en los documentos es conservar copias de seguridad de los documentos. En caso de que no tiene una copia de seguridad del documento, este artículo proporciona procedimientos de solución de problemas que puede utilizar para identificar y recuperar dañado de Microsoft Word para Windows.

Más información

Identificar un documento dañado

Los documentos dañados a menudo muestran un comportamiento que no forma parte del diseño del programa (por ejemplo, repaginación infinita, el diseño del documento incorrecto y formato, caracteres ilegibles en la pantalla, mensajes de error durante el procesamiento, el sistema se bloquea o produce un error al cargar o ver el archivo, o cualquier otro comportamiento no habitual que no pueda atribuirse al funcionamiento normal del programa). Este comportamiento puede deberse a factores distintos daños en los documentos. Para descartar otros factores, utilice los siguientes pasos:
  • Busque un comportamiento similar en otros documentos.
  • Busque un comportamiento similar en otros programas.
  • Llevar el archivo en cuestión a otro equipo e intente repetir el comportamiento.
  • Utilice un controlador de impresora diferente e intente repetir el comportamiento.
  • Cambiar el nombre de las plantillas adjuntadas al documento e intente repetir el comportamiento.
  • Cambie otros componentes del sistema (como los controladores de vídeo o las fuentes) e intente repetir el comportamiento. Por ejemplo, si está utilizando una versión OEM de un controlador de vídeo, cambie a un controlador de vídeo de Microsoft Windows con el programa de instalación de Windows.
  • Desactivar los programas de otros fabricantes que se estén ejecutando (como terminar-y-programas residentes [TSR], administradores de fuentes, protectores de pantalla y shells del sistema) y, a continuación, intentan repetir el comportamiento.
Si el problema se produce sólo con un único documento, después de realizar estos pasos, probablemente está dañado el documento.

Qué debe intentar si el documento se abre pero exhibe un comportamiento inesperado

Método 1: Convertir el archivo a otro formato y volverlo a convertir a Word.

Éste es el método de recuperación de documentos más completo; Pruébela siempre en primer lugar. Guarde el archivo en formato de archivo RTF. Este formato conserva el formato en el documento Microsoft Word para Windows. Después de guardar el archivo en formato RTF, vuelva a abrir el documento en Word para Windows y convertirlo en RTF.

Si este método se realiza correctamente, el daño del archivo se eliminó durante la conversión.

Si el daño persiste después de guardar el archivo en formato RTF, intente guardar el archivo en los siguientes formatos:
Otros formatos de procesamiento de textos
Sólo texto
Nota: guardar archivos en formato de sólo texto, con frecuencia corrige el problema de corrupción de documento; Sin embargo, se pierde todo el formato de documento. Este método requiere dar más formato; por lo tanto, utilícelo sólo cuando otros formatos de archivo no consigan corregir el problema.Para obtener más información acerca de la pérdida de código VBA en documentos de Word 97 que se convierten en otros formatos de archivo, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
158060 Código de VBA se pierde después de convertir a otro formato de documento

Método 2: Copiar todo excepto la última marca de párrafo en un documento nuevo.

Word para Windows asocia una amplia variedad de formatos con la última marca de párrafo, especialmente de secciones y el formato de estilo. Si copia todo, excepto la última marca de párrafo en un documento nuevo, es posible que el daño se quede en el documento original. En el nuevo documento, vuelva a aplicar el formato de estilo o sección.

Nota: puede seleccionar todo excepto la última marca de párrafo, presione CTRL+FIN y a continuación, CTRL + MAYÚS + inicio.

Método 3: Copie las partes no dañadas del documento a un nuevo documento.

A veces puede determinar la ubicación de los daños en el archivo en el documento. En estos casos, copie todo excepto la parte dañada a un nuevo archivo y, a continuación, siga estos pasos para reconstruir el documento:
  1. Después de copiar las partes no dañadas del documento a un nuevo archivo, guardar una copia del documento dañado en formato de sólo texto.
  2. Abra el archivo de sólo texto. Copie el texto de este archivo y péguelo en el archivo que contiene la parte no dañada del documento.
  3. Cambiar el formato de las secciones que pegó en el paso 2 y, a continuación, guardar el documento recuperado.

Qué debe intentar si el documento no se abre

Existen varias técnicas que puede utilizar para intentar abrir un documento que no se abre. El método que utilice depende de la naturaleza y gravedad del daño en el documento y la naturaleza del comportamiento demostrado. Aunque muchos de estos métodos suelen tener éxito, no todos los documentos dañados pueden recuperarse.

Método 1: Abrir el documento de Word dañado en modo borrador.

A veces, puede abrir un documento en modo borrador cuando no se abrirá en las demás vistas. Después de abrir el archivo, podrá recuperar o reparar el archivo.

Para cambiar a modo de borrador en Word:
  1. En el menú Ver , haga clic en Normal.
  2. En el menú Herramientas , haga clic en Opciones, seleccione la ficha Ver y seleccione la opción Fuente de borrador .

Método 2: Insertar el documento como un archivo en un nuevo documento.

La marca de párrafo final en un documento de Word contiene información acerca del documento. Si el documento está dañado, puede recuperar el texto del documento si puede omitir esta última marca de párrafo.

Para tener acceso a un documento, pero deja la marca de párrafo final, siga estos pasos:
  1. Crear un nuevo documento en blanco.
  2. En el menú Insertar , haga clic en archivo.
  3. En el cuadro de diálogo Insertar archivo , busque y seleccione el documento dañado y haga clic en Aceptar.
Tendrá que volver a aplicar alguna sección formato a la última sección del documento.

Método 3: Abra el archivo de vinculación a él.

Si el "insertar el documento como un archivo en un documento nuevo" (método 2) no funciona, pruebe a este método. Este método le permite tener acceso al documento sin que se muestre en la marca de párrafo final. Además, cuando se crea un vínculo, no se lee parte de la información de encabezado.

Este método permite abrir el archivo si esta parte del encabezado o si la marca de párrafo final en el área dañada del documento.

Para vincular a un archivo "bueno" (un archivo que no se ha dañado) y, a continuación, cambie el vínculo para que señale al archivo dañado, siga estos pasos:
  1. Crear un documento nuevo. En el nuevo documento, escriba Es una prueba. Guarde el documento.
  2. Seleccione el texto y haga clic en Copiar en el menú Edición .
  3. En el menú archivo , haga clic en nuevo . En el nuevo documento, haga clic en Pegado especial del menú Edición .
  4. Seleccione texto sin formato o con formato y haga clic en Pegar vínculo. Haga clic en Aceptar.
  5. En el menú Edición , haga clic en vínculos. Se muestra el cuadro de diálogo vínculos .
  6. Seleccione el nombre de archivo del primer documento vinculado y haga clic en Cambiar origen. El cuadro de diálogo Abrir aparece y le pide el documento que desea cambiar el vínculo a.
  7. Seleccione el documento ya no se puede abrir y haga clic en Abrir.
  8. Haga clic en Aceptar en el cuadro de diálogo vínculos .

    Aparece el texto/datos del documento dañado (siempre y cuando hubiera datos o texto recuperable).
  9. En el menú Edición , haga clic en vínculosy haga clic en Romper los vínculos.
Ahora puede cambiar el formato y guardar el texto recuperado.

Método 4: Abrir el archivo en WordPad o Microsoft Write

Cuando no se puede abrir un documento dañado en Word para Windows (generalmente debido a daños en el encabezado del archivo), puede eliminar el encabezado del archivo y abrir el archivo como sólo texto. Al quitar la información de encabezado, todo el formato se pierde. Este método elimina la información de encabezado del archivo.
  1. Iniciar Microsoft WordPad o escritura. (En Windows, haga clic en Ejecutar en el menú Inicio , escriba WordPady haga clic en Aceptar.
  2. En WordPad, abra el documento dañado. Un cuadro de diálogo en el que se le pide que especifique cómo desea convertir el archivo. Haga clic en el botón Sin conversión .
  3. El documento de Word para Windows está abierto ahora como un archivo de texto. Puede que vea caracteres binarios de (externas) al principio y al final del documento. Eliminar estos caracteres.

    Nota: en Windows, el archivo puede abrirse intacto sin conversión adicional o limpieza necesaria. Si éste es el caso, guarde el archivo con un nombre nuevo y abra el archivo en Word.
  4. En el menú archivo , haga clic en Guardar como. En el cuadro Nombre de archivo , escriba un nuevo nombre con una extensión de nombre de archivo .doc. Antes de hacer clic en el botón Aceptar , tenga en cuenta el directorio donde se va a guardar el archivo para que pueda encontrarla fácilmente al reiniciar Word para Windows.
  5. En el menú archivo , haga clic en Salir.
  6. Reinicie Word para Windows y abra el archivo guardado desde WordPad o escritura (el archivo tendrá el nombre que le asignó en el paso 4). (En el menú archivo , haga clic en Abrir. En el cuadro Nombre de archivo , escriba la ruta de acceso y el nombre del archivo recién creado y haga clic en Aceptar).
  7. En el cuadro de diálogo Convertir archivo , Sólo texto debe seleccionarse. Seleccione el botón Aceptar para abrir el archivo de texto en Word para Windows.
  8. En el menú archivo , haga clic en Guardar comoy guarde el archivo en formato de Word.
  9. En el cuadro Nombre de archivo , escriba un nuevo nombre para el archivo y haga clic en Aceptar.
El archivo está ahora en formato de Word para Windows. Puede volver a abrirlo y reemplazar todos los gráficos, campos y formato.Nota en las tablas: Microsoft WordPad 1.0 puede leer y escribir en Word 6.x y posterior de los formatos de archivo, automáticamente convierte el archivo y mantener dicho formato como WordPad sí admite. Un documento que no se puede abrir con frecuencia se abrirá en WordPad. Las tablas se convierten en texto delimitado pero conservarán la estructura de la tabla básica de la tabla; suele ser la única manera de recuperar una tabla dañada.

Método 5: Elimine la información del encabezado de archivo.

Nota: este método funciona con las versiones 3.0 a 6.2 de MS-DOS sólo.

Utilice este método sólo si fallan todos los demás métodos. Cuando no se puede abrir un documento dañado en Word para Windows (generalmente debido a daños en el encabezado del archivo), puede eliminar el encabezado del archivo y abrir el archivo como sólo texto. Al quitar la información de encabezado, todo el formato se pierde.
  1. En el símbolo del sistema, escriba lo siguiente y presione ENTRAR:
    copiar con + archivo.docnewname.doc
    donde nombreArchivo es el nombre del archivo dañado y newname es el nombre del nuevo archivo. (Esto hace que la palabra "CON" que aparezca y el punto de inserción parpadeando en una línea en blanco).
  2. Presione la barra espaciadora 12 veces.
  3. Presione F6 y, a continuación, presione ENTRAR.
  4. Inicie Word para Windows y abra el nuevo archivo.
  5. Elimine los caracteres impares al principio y al final del archivo. El texto del archivo es normalmente intacto en medio del archivo.
  6. Formato del documento y guardarlo en formato de Word para Windows.
Nota: si el archivo se guardó en Word para Windows con la casilla de verificación Permitir guardar rápidamente activada, el texto puede aparecer en los bloques no contiguos. La característica Guardar rápidamente realiza un seguimiento de los cambios realizados por anexar los cambios al final del documento y recordar dónde estos cambios. A intervalos regulares, al guardar rápidamente, se actualiza el documento con estos cambios (este método es más rápido y consume menos memoria que guardar el documento completo). Si el documento se daña antes de guardar rápidamente tenga la oportunidad de crear una copia completa y actualizada del documento, deberá volver a ordenar el texto (mover el texto anexado a su lugar adecuado en el documento) y, a continuación, vuelva a formatearlo.Para obtener más información acerca de cómo desactivar la característica Guardar rápidamente, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
71999 Cómo deshabilitar la opción de guardar rápidamente en Word para Windows

Método 6: Utilizar el convertidor "Recuperar texto de cualquier archivo".

El convertidor Recuperar texto de cualquier archivo permite extraer el texto de cualquier archivo. El archivo no tiene un archivo de Word. Utilizando el convertidor Recuperar texto de cualquier archivo tiene algunas limitaciones. Formato del documento se pierde junto con todo lo que no es de texto. Se pierden gráficos, campos, objetos de dibujo etc..

Sin embargo, los encabezados, pies de página, notas al pie, notas al final y texto de campo se conservan como texto simple. Además, una vez recuperado el documento utilizando el convertidor Recuperar texto de cualquier archivo, habrá algunos datos binarios que no se pudieron convertir, principalmente en la parte superior e inferior del documento. Estos datos binarios deben eliminarse antes de volver a dar formato y guardar el archivo como un documento de Word.Para obtener más información acerca de cómo utilizar el convertidor "Recuperar texto de cualquier archivo" en Word 97, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
156573 Cómo recuperar texto de cualquier archivo

Propiedades

Id. de artículo: 87856 - Última revisión: jueves, 31 de octubre de 2013 - Versión: 4.0
La información de este artículo se refiere a:
  • Microsoft Word 97 Standard Edition
Palabras clave: 
kbhowto kbtshoot kbualink97 kbmt KB87856 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 87856
Renuncia a responsabilidad de los contenidos de la KB sobre productos a los que ya no se ofrece asistencia alguna
El presente artículo se escribió para productos para los que Microsoft ya no ofrece soporte técnico. Por tanto, el presente artículo se ofrece "tal cual" y no será actualizado.

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com