ID do artigo: 883318 - Última revisão: segunda-feira, 13 de junho de 2005 - Revisão: 1.2

As mensagens de erro "Falha de página inválida no módulo Tps108.dll" ou "Internet Explorer encontrou um problema e precisa ser fechado" são exibidas ao iniciar o Internet Explorer

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Recolher tudo

Sintomas

Ao ser iniciado, o Microsoft Internet Explorer fecha inesperadamente e você recebe uma mensagem de erro similar à seguinte:
Iexplore causou uma falha de página inválida no módulo Tps108.dll
O Internet Explorer encontrou um problema e precisa ser fechado. Desculpe pela inconveniência.
Se você visualizar o conteúdo do relatório de erros contido nesta mensagem de erro, ele contém uma assinatura de erro similar à seguinte:
AppName       AppVer          ModName     ModVer         Offset iexplore.exe  Versão_Programa  tps108.dll  Versão_Módulo Offset
Além disso, ao tentar abrir Meu computador ou o Microsoft Windows Explorer, uma mensagem de erro similar à seguinte é exibida:
O Explorer causou uma falha de página inválida no módulo Tps108.dll

Causa

Esse problema pode ocorrer caso o programa de terceiro Tps108.dll esteja instalado no computador e se o programa Tps108.dll estiver impedindo o Internet Explorer e o Windows Explorer de funcionarem corretamente.

Resolução

Para resolver esse problema, use um dos seguintes métodos:

Método 1: Desativar a opção "Ativar extensões de navegador de terceiros (requer reinicialização)" no Internet Explorer

  1. Inicie o Internet Explorer, caso ele ainda não tenha sido iniciado.
  2. No menu Ferramentas, clique em Opções da Internet e na guia Avançadas.
  3. Na caixa Configurações em Navegação, desmarque a caixa de seleção Ativar extensões de navegador de terceiros (requer reinicialização) e clique em OK.
  4. Feche o reinicie o Internet Explorer.
Para obter informações adicionais sobre a opção "Ativar extensões de navegador de terceiros (requer reinicialização)", clique no número abaixo para ler o artigo na Base de Dados de Conhecimento da Microsoft:
298931  (http://support.microsoft.com/kb/298931/ ) Como desativar faixas de ferramentas de terceiros e objetos auxiliares do navegador

Método 2: Desativar o programa Tps108.dll no computador

Para desativar o programa Tps108.dll, localize o arquivo Tps108.dll no computador e cancele o registro. Para fazer isso, execute estas etapas:
  1. Clique em Iniciar e em Pesquisar.
  2. Clique em Todos os arquivos e pastas.
  3. Na caixa Todo ou parte do nome do arquivo, digite tps108.dll e clique em Pesquisar.
  4. Anote o caminho do arquivo Tps108.dll no disco rígido.
  5. Clique em Iniciar e em Executar, digite cmd na caixa Abrir e pressione ENTER.
  6. No prompt de comando, digite a seguinte linha, em que Caminho é o caminho do arquivo Tps108.dll no disco rígido e pressione ENTER:
    regsvr32 /u Caminho\tps108.dll
    Por exemplo, se o arquivo Tps108.dll estiver na pasta C:\Windows, digite a seguinte linha e pressione ENTER:
    regsvr32 /u c:\windows\tps108.dll
  7. Ao receber a mensagem informando que a operação teve êxito, clique em OK.
  8. Desligue e reinicie o computador.

Método 3: Remover o programa Tps108.dll do computador

Observação Como há diversas versões do Microsoft Windows, as etapas a seguir podem ser diferentes no seu computador. Se esse for o caso, consulte a documentação do produto para concluir as etapas.
  1. Use a ferramenta Adicionar ou remover programas para remover o programa Tps108.dll do computador. Para fazer isso, execute estas etapas:
    1. Clique em Iniciar e em Executar, digite appwiz.cpl na caixa Abrir e clique em OK.
    2. Na lista de programas atualmente instalados, clique em TPS108, caso o programa esteja relacionado, e clique em Remover.

      Observação Se o programa TPS108.dll não estiver relacionado na ferramenta Adicionar ou remover programas, vá para a etapa 2.
  2. Cancele o registro do arquivo Tps108.dll. Para fazer isso, execute as etapas na seção "Método 2: Desativar o programa Tps108.dll no computador".
  3. Finalize o processo Preinsttps108.exe caso ele esteja em execução. Para fazer isso, execute estas etapas:
    1. Clique com o botão direito do mouse em uma área vazia da barra de tarefas do Windows e clique em Gerenciador de tarefas.
    2. Clique na guia Processos.
    3. Na lista de processos, clique em Preinsttps108.exe e em Finalizar processo.
    4. Feche o Gerenciador de tarefas.
  4. Exclua as seguintes subchaves de registro caso elas estejam no registro do Windows:
    • HKEY_CLASSES_ROOT\CLSID\{50a28604-52f2-11d6-8f0f-5254ab11d5c2}
    • HKEY_CLASSES_ROOT\Tps108.tps108obj.1
    • HKEY_LOCAL_MACHINE\Software\Classes\tps108.tps108obj.1
    • HKEY_LOCAL_MACHINE\Software\Software\tps108
    • HKEY_LOCAL_MACHINE\Software\Tps108
    Para excluir essas subchaves de registro, execute estas etapas.
    Aviso O uso incorreto do Editor do Registro pode causar sérios problemas que talvez exijam a reinstalação do sistema operacional. A Microsoft não garante que os problemas resultantes do uso incorreto do Editor do Registro possam ser solucionados. O uso do Editor do Registro é de sua responsabilidade.
    1. Clique em Iniciar e em Executar, digite regedit na caixa Abrir e clique em OK.
    2. Localize e clique na subchave de registro a ser excluída.
    3. No menu Editar, clique em Excluir.
    4. Ao ser solicitado a confirmar a exclusão, clique em Sim.
  5. Localize e exclua as seguintes linhas do disco rígido caso os arquivos já estejam no disco rígido:
    • Preinsttps108.exe
    • Tps108.dll

Mais Informações

Para obter informações adicionais sobre o programa Tps108.dll, visite o seguinte site da TPS108 (em inglês):
http://www.tps108.org/default.htm (http://www.tps108.org/default.htm)
Os outros produtos mencionados neste artigo são produzidos por empresas independentes da Microsoft. A Microsoft não oferece garantia, implícita ou não, em relação ao desempenho ou à confiabilidade desses produtos.
A Microsoft fornece informações para contato com outras empresas para ajudá-lo a encontrar o suporte técnico. Essas informações para contato podem ser alteradas sem notificação prévia. A Microsoft não garante a precisão dessas informações para contato com outras empresas.

A informação contida neste artigo aplica-se a:
  • Microsoft Internet Explorer 6.0 nas seguintes plataformas
    • Microsoft Windows XP Professional
    • Microsoft Windows 2000 Standard Edition
    • Microsoft Windows Millennium Edition
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows 98 Standard Edition
Palavras-chave: 
kberrmsg kbtshoot kbprb KB883318