Formát e-mailových zpráv aplikace Outlook má větší prioritu než formát internetových zpráv nastavený v počítači se serverem Exchange Server 2003 (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)

Překlady článku Překlady článku
ID článku: 883490 - Produkty, které se vztahují k tomuto článku.
Důležité: Tento článek obsahuje informace o úpravě registru. Před úpravami je nutné registr zazálohovat. Seznamte se také s postupem při obnovení registru v případě, že nastane problém. Informace o zálohování, obnovení a úpravě registru naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
256986Popis registru systému Microsoft Windows
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Při odeslání e-mailové zprávy z klienta Microsoft Outlook k Internetu prostřednictvím počítače Microsoft Exchange Server 2003 přepíše původní formát zprávy Outlook Internetový formát zprávy určené počítači Exchange Server.

Poznámka: Zobrazení nastavení formátu zprávy Internetu v počítači Exchange Server spusťte nástroj Exchange System Manager, rozbalte položku Globální nastavení, klepněte na příkaz Internet formáty zpráv a potom poklepejte na výchozí.

Příčina

K tomuto problému dochází, protože Outlook nastaví PR_INETMAIL_OVERRIDE_FORMAT příznak na všechny e-mailové zprávy HTML. Příznak zabraňuje počítači Exchange Server přepsání původní formát zprávy e-mailové zprávy.

Řešení

Informace o aktualizaci Service Pack

Chcete-li tento problém vyřešit, získejte nejnovější aktualizace service pack pro Exchange Server 2003. Další informace naleznete následujícím článku znalostní databáze Microsoft Knowledge Base:
836993Získání nejnovějších aktualizací Service Pack pro Exchange Server 2003

Informace o opravě hotfix

K dispozici je podporovaná oprava hotfix od společnosti Microsoft. Tato oprava hotfix je však určena pouze k opravě problému popsanému v tomto článku. Použijte tuto opravu hotfix pouze u systémů, kde dochází k tomuto konkrétnímu problému. Tato oprava hotfix může být dále testována. Pokud Vás tento problém závažně nepostihuje, doporučujeme počkat na další aktualizaci softwaru, která bude tuto opravu hotfix obsahovat.

Pokud je oprava hotfix k dispozici ke stažení, v horní části tohoto článku je sekce "Hotfix stažení k dispozici". Pokud tento oddíl nevidíte, obraťte se na Technickou podpora společnosti Microsoft pro získání opravy hotfix.

Poznámka: Pokud vyskytnout další problémy nebo jakékoli řešení potíží je vyžadován, pravděpodobně budete muset vytvořit zvláštní požadavek na službu. Výdaje na technickou podporu se týkají dalších otázek a problémů, které nelze vyřešit pomocí této opravy konkrétní opravy hotfix. Navštivte následující web společnosti Microsoft pro získání telefonního čísla na Zákaznické centrum, nebo pokud chcete vytvořit samostatnou žádost o podporu:
http://support.microsoft.com/contactus/?ws=support
Poznámka: Zobrazí formulář "Hotfix stažení k dispozici" jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, oprava hotfix není k dispozici pro daný jazyk.

Požadavky

Chcete-li nainstalovat tuto opravu hotfix, musíte mít nainstalován Exchange Server 2003 Service Pack 1 (SP1).

Požadavek na restartování

Nemáte k instalaci této opravy hotfix restartovat počítač. Následující služby Exchange a Internetová informační služba (IIS) jsou však automaticky restartována při instalaci této opravy hotfix:
  • Služba Publikování na webu
  • Simple Mail Transport Protocol (SMTP)
  • Microsoft Exchange Routing Engine
  • Microsoft Exchange POP3
  • Microsoft Exchange IMAP4
  • služba Správa služby IIS

Informace o nahrazení opravy hotfix

Tato oprava Hotfix nenahrazuje žádné další opravy Hotfix.

INFORMACE O SOUBORECH

Anglická verze této opravy hotfix má následující (nebo pozdější) atributy souborů. Data a časy jednotlivých souborů jsou uvedeny ve formátu UTC (Coordinated Universal Time). Pokud zobrazíte informace o souboru, bude převedena na místní čas. Rozdíl mezi místním ČASEM a najít, použijte kartu časové pásmo v položce Datum a čas v ovládacím.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   05-Oct-2004  21:42  6.5.7232.42       457,216  Phatcat.dll  

Pokyny k instalaci hotfix

Po instalaci této opravy hotfix je nutné nakonfigurovat položka registru povolit opravu hotfix. Postupujte takto.

Upozornění Použijete-li Editor registru nesprávně, můžete způsobit vážné problémy, které mohou vyžadovat přeinstalaci operačního systému. Společnost Microsoft nemůže zaručit, že potíže vzniklé v důsledku nesprávného použití Editoru registru budete moci vyřešit. Editor registru používáte na vlastní nebezpečí.
  1. Klepněte na tlačítko Start, klepněte na příkaz Spustit, zadejte příkaz regedit a klepněte na tlačítko OK.
  2. Vyhledejte následující podklíč registru a klepněte na něj:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeTransport\Parameters
    Poznámka: Pokud podklíč Parameters neexistuje, postupujte takto:
    1. Klepněte pravým tlačítkem myši MSExchangeTransport, přejděte na příkaz Nový a klepněte na příkaz klíč.
    2. Jako název podklíče zadejte Parametry a stiskněte klávesu ENTER.
  3. V nabídce Úpravy přejděte na příkaz Nový a potom klepněte na příkaz Hodnota DWORD.
  4. Jako název položky zadejte DisableInetOverride a stiskněte klávesu ENTER.
  5. DisableInetOverride klepněte pravým tlačítkem myši a potom klepněte na příkaz změnit.
  6. V poli Údaj hodnoty zadejte hodnotu 1 a klepněte na tlačítko OK.
  7. Ukončete program Editor registru.
  8. Restartujte službu SMTP (Simple Mail Transport Protocol). Postupujte takto:
    1. Klepněte na tlačítko Start, klepněte na příkaz Spustit, zadejte příkaz services.msc a pak klepněte na tlačítko OK.
    2. Klepněte pravým tlačítkem myši Simple Mail Transport Protocol (SMTP) a potom klepněte na tlačítko restartovat.
Pokud položka DisableInetOverride je nastavena na 0 nebo neexistuje, nastavení formátu Outlook e-mailové zprávy se používají.

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části Informace v tomto článku jsou určeny pro produkt.

Tento problém byl poprvé opraven v Exchange Server 2003 Service Pack 2.

Další informace

Tento problém nemá vliv na klienty Microsoft Outlook Web Access. E-mailové zprávy, které jsou vytvořeny pomocí aplikace Outlook Web Access jsou formátovány podle očekávání. Tyto e-mailové zprávy použít nastavení formátu zprávy Internetu v počítači Exchange Server.

Další informace o způsobu konfigurace formátů internetových e-mailových zpráv klepněte na následující číslo článku databáze Microsoft Knowledge Base:
821750Jak konfigurovat formáty internetových e-mailových zpráv na úrovních uživatele a domény na serveru Exchange Server 2003 (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)
Další informace o klientská řešení tohoto problému Pokud používáte aplikaci Microsoft Outlook 2002, klepněte na následující číslo článku databáze Microsoft Knowledge Base:
329454Formát zprávy aplikace Outlook 2002 přepíše formát zprávy serveru Exchange
Další informace o aktualizacích softwaru společnosti Microsoft naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
824684Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft
817903Nové schéma přidělování názvů balíčkům aktualizací softwaru pro Exchange Server (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)

Vlastnosti

ID článku: 883490 - Poslední aktualizace: 25. října 2007 - Revize: 3.3
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange Server 2003 Enterprise Edition
Klíčová slova: 
kbmt kbautohotfix kbhotfixserver kbexchange2003presp2fix kbqfe kbfix kbbug KB883490 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:883490

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com