Search Results process may stop responding when you search for a file that contains DBCS characters in Windows 2000

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Article ID: 883509 - View products that this article applies to.
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SYMPTOMS

When you search for a file that contains double-byte character sets (DBCS) characters on a Microsoft Windows 2000-based computer, the Search Results process may stop responding (hang).

Notes
  • To search for a file on a Windows 2000-based computer, click Start, point to Search, and then click For Files or Folders.
  • The DBCS protocol requires more than one byte to represent a character. Some examples of languages that require DBCS include Chinese and Korean.

CAUSE

This problem occurs if one or more of the updates that are described in the following Microsoft Knowledge Base articles are installed on your computer:
839645 MS04-024: A vulnerability in the Windows shell could allow remote code execution
818651 File is not found when you search for a file that contains an accented character

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Windows 2000 Service Pack 3 (SP3) or later versions of Windows 2000.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix replaces the hotfix from Microsoft Knowledge Base article 818651.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time     Version        Size      File name
   ----------------------------------------------------------
   22-Sep-2004  19:39  5.0.3900.6977   2,358,544  Shell32.dll      
   13-Sep-2004  19:27  5.0.2195.6974   5,898,752  Sp3res.dll         

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:
816915 New file naming schema for Microsoft Windows software update packages
For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 883509 - Last Review: October 27, 2013 - Revision: 1.5
APPLIES TO
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
Keywords: 
kbnosurvey kbarchive kbautohotfix kbtshoot kbbug kbfix kbhotfixserver kbqfe KB883509

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