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Symptoms

When a user tries to connect to your network by using a wireless connection, and when that user's connection request is authenticated and authorized by Microsoft Windows Server 2003 Internet Authentication Service (IAS), you may experience all the following symptoms:

  • It takes a long time to complete the user's connection.

  • The following event appears in the System log on the computer that is running IAS:

  • If you view the contents of the IAS log file, you notice information that is similar to the following:

    [516] 08-04 16:36:58:614: NT-SAM EAP handler received request.
    [516] 08-04 16:36:58:614: State attribute is present, but unrecognized

    By default, the IAS log file is named Iaslog.log. This file is located in the following folder:

    %WINDIR%\System32\LogFiles

Cause

This problem occurs if the following conditions are true:

  • The user connects to the network through a wireless access point by using Extensible Authentication Protocol (EAP).

  • When the wireless access point submits the user's credential to IAS, that authentication request contains a Remote Authentication Dial In User Service (RADIUS) state attribute.

In this scenario, if the access point tries to start an EAP session that contains state information, IAS ignores the authentication request. Therefore, the client times out the connection attempt, and the connection takes a long time.

Note The state attribute is a value that permits both systems to keep track of the connection conversation. IAS provides new state information to each connected session. The access point should not send state information during the initial connection request. The access point should only return the state information that it receives from IAS. However, in this scenario, IAS should reject a connection request that contains state information instead of ignoring this request. This would permit the connection to be reestablished more quickly than if the connection attempt has to time out.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required to install this hotfix.

Restart requirement

You must restart your computer to apply the changes after you install this hotfix. However, you do not have to restart the computer immediately after you install this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003, 32-bit editions
   Date         Time   Version       Size     File name
----------------------------------------------------------------
25-Aug-2004 07:46 5.2.3790.206 101,888 Iassam.dll
Windows Server 2003, 64-bit editions
   Date         Time   Version       Size     File name    Platform
----------------------------------------------------------------
25-Aug-2004 07:46 5.2.3790.206 335,360 Iassam.dll IA-64
25-Aug-2004 07:46 5.2.3790.206 101,888 Wiassam.dll x86

Workaround

To work around this problem, configure your wireless access point or device so that it does not send state information during the connection request.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For additional information about the terminology that is used in this article, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

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