How to configure the Exchange Connector for Lotus Notes with Lotus Domino R5 in Exchange 2000 Server

Article translations Article translations
Article ID: 883727 - View products that this article applies to.
Expand all | Collapse all

On This Page

INTRODUCTION

This article describes how to install and configure the Microsoft Exchange 2000 Server Connector for Lotus Notes with Lotus Domino Server R5.

Note While this article assumes that you have already installed and configured a Lotus Domino R5 server, it provides some of the steps to install and configure Lotus Domino R5 to specify example account names and to help increase the clarity of this procedure.

MORE INFORMATION

The installation and configuration of the Exchange 2000 Connector for Lotus Notes is made up of all the following steps:
  • Installing Lotus Domino Server together with the administrative workspace.
  • Starting and configuring the Lotus Notes server.
  • Modifying the Notes.ini file and creating a shortcut to an Exchange connector account.
  • Creating the databases in Lotus Notes and assigning permissions for the Exchange connector account to these databases.
  • Installing and configuring the Connector for Lotus Notes in Exchange 2000.
  • Testing message delivery between Exchange and Lotus Notes and performing a directory synchronization between Exchange and Lotus Notes.

Step 1: Install Lotus Domino Server R5 and the administrative workspace

If you already have Lotus Domino Server installed and configured, you can skip this step. This step is intended to create an example Lotus Domino Server installation together with an example Lotus Notes administrator account information.
  1. On the computer where you want to install Lotus Domino Server, start the Lotus Domino Setup program, and then click Next.
  2. Click Yes to accept the terms of the license agreement, type your name and company information in the Name and Company boxes, and then click Next.

    The name that you specify here is used as the Lotus Notes administrator. For the purposes of this example installation, we refer to this account name as "NotesAdmin."
  3. Confirm the folder locations where Lotus Domino Server will be installed, click Next, click Domino Application Server, and then click Next two times.
  4. In the Lotus Product Registration dialog box that appears, click Exit, and then click Yes.
  5. Click Finish.
  6. Install the Lotus Notes Administrator Program and the Lotus Notes Client program on the computer that is running Exchange 2000. To do this, follow these steps:
    1. On the computer that is running Exchange 2000, start the Lotus Notes Setup program, and then click Next.
    2. Click Yes to accept the terms of the license agreement, type your name and company information in the Name and Company boxes, and then click Next.

      The name that you specify here is used as the Lotus Notes administrator. For the purposes of this example installation, we refer to this account name as "NotesAdmin."
    3. Confirm the folder locations where Lotus Notes will be installed, and then click Next.
    4. Click Domino Administrator, and then click Next two times.
    5. In the Lotus Product Registration dialog box that appears, click Exit, and then click Yes.
    6. Click Finish.

Step 2: Start and configure Lotus Domino Server

If you already have Lotus Domino Server configured, you can skip certain parts of this step. To start and to configure Lotus Domino Server, follow these steps:
  1. On the computer that Lotus Domino Server is installed on, click Start, point to Programs, point to Lotus Applications, and then click Lotus Domino Server.
  2. Click First Domino Server, and then click > to see the next page.
  3. Click Advanced Configuration, and then click > two times to go to page 4 of Domino Server Setup.
  4. Under Organization Identity, change the password that appears in the Certifier Password box.
  5. Under Administrator's Identity, change the password that appears in the Password box.
  6. If you want to modify the existing port options, click Customize, click Edit Ports, disable all the port options except the TCP/IP option and the NetBIOS over IP option, and then click OK.
  7. Click Finish.
  8. When Lotus Domino Server is configured successfully, click Set Access Control List Entry, and then click Add a person.
  9. Note that the name that appears in the Please enter the name you want added to the access control lists box is the "NotesAdmin" account name that you specified during the installation of Lotus Domino Server. Click OK, wait for the access control list entries to be updated, and then click Exit Configuration.
  10. Start the Domino server. To do this, click Start, point to Programs, point to Lotus Applications, and then click Lotus Domino Server.

    The Lotus Domino Server program starts in a Command Prompt window. Note the name of the Lotus Domino Server that appears in the title bar of the Command Prompt window. For example, note that the server name appears similar to ServerName/DomainName.
  11. On the computer that you installed the Lotus Notes Administrator program on, click Start, point to Programs, point to Lotus Applications, and then click Lotus Domino Administrator.
  12. Click Next, click I want to connect to a Domino server, click Next, leave the Set up a connection to a local area network (LAN) option selected, and then click Next.
  13. In the Domino server name box, type the name of the Domino server that you noted in step 10, and then click Next.
  14. Click Use my name as identification, type the user account name that you noted in step 9, and then click Next five times.
  15. Click I do not connect to the Internet through a proxy server, click Next two times, and then click Finish.
  16. In the Enter the password for NotesAdmin/DomainName box, type your password, and then click OK.
  17. On the following message that appears, click OK:
    Notes setup is complete!
  18. On the Lotus administrator startup page that appears, click Close this page.
  19. At the upper left of the Administration - Domino Administrator dialog box, click the DOMAINNAME Domain icon. This icon appears as two tower computers.
  20. In the left pane, click the ServerName/DomainName icon.

    Note This icon is at the top of the list.
  21. In the right pane, click the People menu, and then click Register.
  22. Locate the drive:\Lotus\Domino\Data folder on the computer that Lotus Domino Server is installed on, click cert.id, and then click Open.
  23. In the Enter the certifier password for /DomainName box, type the certifier password that you entered when you installed Lotus Domino Server, and then click OK.
  24. On the following message that appears, click No:
    The current certifier ID contains no recovery information and will not allow ID/password recovery on IDs created with this certifier. The 'EscrowAgent' ID recovery mechanism is no longer supported.

    Display this warning in the future?
  25. In the Register Person -- New Entry dialog box that appears, click to select the Advanced check box.
  26. In the Last name box, type connector.
  27. Click Mail, and then click None in the Mail system list.
  28. Click ID Info, click to clear the In Domino directory check box, click to select the In file check box, click Add person, and then click Register.
  29. On the following message that appears, click OK, and then click Done:
    Person registered successfully! See local Notes log for details.
  30. Press F9 to update the display, make sure that the connector account appears in the Name list, and then click Exit Administrator on the File menu to quit the administration program.

Step 3: Modify the Notes.ini file and create a shortcut to the connector account

  1. On the computer that you installed the Lotus Notes Domino Administrator program and the Notes client program on, open the Notes.ini file by using a text editor such as Notepad. By default, this file is located in the following folder:
    C:\Lotus\Notes
    Note We recommend that you create a backup copy of this file before you modify it.
  2. Remove all the information that appears under InstallType=1. The file now appears similar to the following:
    [Notes]
    
    Directory=C:\Lotus\Notes\Data
    KitType=1
    InstallType=1
  3. On the File menu, click Save As.
  4. In the File name box, type "notesc.ini", and then click Save.

    Note Make sure that you include the quotation marks when you type this file name. Additionally, note that the file name is not "notes.ini," it is "notesc.ini."
  5. Quit Notepad.
  6. Start Windows Explorer, and then locate the following folder:
    drive:\Documents and Settings\All Users\Start Menu\Programs\Lotus Applications
  7. In the right pane, right-click and drag the Lotus Notes icon to a blank area in that same folder. On the shortcut menu that appears when you release the right mouse button, click Copy Here.
  8. Right-click Copy of Lotus Notes, and then click Properties.
  9. On the Shortcut tab, modify the path in the Target box so that it appears similar to the following:
    C:\Lotus\Notes\notes.exe =C:\Lotus\Notes\notesc.ini
    Note If Lotus Notes is installed in a location other than C:\Lotus\Notes, modify your path accordingly. Note that there is a space between "notes.exe" and "=C\Lotus\Notes\notesc.ini."
  10. Click the General tab, change the name of the shortcut to Connector, click OK, and then quit Windows Explorer.
  11. Click Start, point to Programs, point to Lotus Applications, and then click Connector.
  12. Click Next, and then click OK when you receive the following error message:
    Could not open the ID file
  13. Click Next, leave the I want to connect to a Domino server option selected, click Next, leave the Set up a connection to a local area network (LAN) option selected, click Next, type the Domino server name in the Domino server name box, and then click Next.
  14. Click Browse, locate the drive:\Lotus\Notes\Data\ids\people folder, click connecto.id, and then click Open.
  15. Click Next, and then click Yes on the following message that appears:
    Do you want your ID file drive:\Lotus\Notes\Data\ids\people\connecto.id copied to your data directory?
  16. Click Next four times, click I do not connect to the Internet through a proxy server, click Next, leave the Connect over my existing local area network option selected, click Next, and then click Finish.
  17. On the following message that appears, click OK:
    Notes setup is complete!
  18. Quit the Lotus Notes program.

Step 4: Create database files in Lotus Notes and assign permissions to the connector account

Create a new database on the Domino server and assign permissions to the connector account that you created. To do this, follow these steps:

Note When you follow these steps, you can view the changes that are made by restoring the Command Prompt window that the Domino server runs in on the Domino Server computer.
  1. Start the Lotus Domino Administrator program, type your password in the Enter the password for NotesAdmin/DomainName box, and then click OK.

    Note If you are not prompted for your password, make sure that you have quit all copies of the Lotus Notes program that are running on this computer, and then restart the Lotus Domino Administrator program.
  2. If the Lotus administrator startup page appears, click Close this page.
  3. Click the DOMAINNAME Domain icon. This icon appears as two tower computers on the left side of the Administration - Domino Administrator window.
  4. In the left pane, click the ServerName/DomainName icon.
  5. Click the Files tab, and then click names.nsf.
  6. On the Database menu, click Manage ACL.
  7. Click Add, and then click the blue person icon that appears next to the Add a person, server or group name box.
  8. In the list at the upper left of the Names dialog box, click DomainName's Address Book.
  9. Click the connector account, click Add>, and then click OK.
  10. In the User type list, click Person.
  11. In the Access list, click Manager.
  12. Click to select the Delete documents check box, and then click OK.
  13. On the following message that appears, click OK:
    1 database processed - 0 errors
  14. In the Show me list, click Mail Boxes only.
  15. Click mail.box, and then click Manage ACL on the Database menu.
  16. Follow steps 7 through 9 to add the connector account to this database.
  17. In the User type list, click Person.
  18. In the Access list, click Depositor, and then click OK.
  19. On the following message that appears, click OK:
    1 database processed - 0 errors
  20. On the File menu, point to Database, and then click New.
  21. In the Server list, click your Domino Server computer.
  22. In the Title box, type exchange.box.
  23. In the File Name box, change the default name that appears from exchange.nsf to exchange.box.
  24. In the list that appears at the bottom of the New Database dialog box, click Mail Router Mailbox (5.0), and then click OK.
  25. Press the ESC key two times and then press F9 to update the display in the Administration - Domino Administrator window. The Exchange.box database appears on the Files tab in the Title column.
  26. Click exchange.box, and then click Manage ACL on the Database menu.
  27. Follow steps 7 through 9 to add the connector account to this database.
  28. In the User type list, click Person.
  29. In the Access list, click Manager, click to select the Delete documents check box, and then click OK.
  30. On the following message that appears, click OK:
    1 database processed - 0 errors
  31. On the File menu, click Exit Administrator.
  32. Click Start, point to Programs, point to Lotus Applications, and then click Lotus Notes.
  33. Type the password for the "NotesAdmin" account, and then click OK.
  34. In the left pane, click the Databases icon. This is the third folder icon from the bottom.
  35. Double-click Workspace to open the databases in Lotus Notes.
  36. Double-click DomainName's Address Book on ServerName. The Names.nsf database is opened in Lotus Notes.
  37. In the left pane, click Server, and then click Domains.
  38. Click Add Domain, and then click the Basics tab if it is not already selected.
  39. Leave the Foreign Domain option selected in the Domain type list.
  40. In the Foreign domain name box, type exchange, and then click the Mail Information tab.
  41. In the Gateway server name box, type the name of the Lotus Domino server to which Connector for Lotus Notes will connect. This is the Lotus Domino bridgehead server. You must type the full name of the server. This includes the certifier information. For example, type the following:
    DominoServerName/CertifierName
  42. In the Gateway mail file name box, type exchange.box.
  43. Click Save and Close.

Step 5: Install and configure the Exchange 2000 Connector for Lotus Notes

To install the Microsoft Exchange Connector for Lotus Notes, follow these steps:
  1. On the Exchange computer, start the Exchange Server Setup program, and then click Next.
  2. In the Action list next to Microsoft Exchange 2000, click Change.
  3. In the Action list next to Microsoft Exchange Messaging and Collaboration Services, click Change.
  4. In the Action list next to Microsoft Exchange Connector for Lotus Notes, click Install.
  5. Click Next two times.
  6. After the Exchange Connector for Lotus Notes is installed successfully, re-install your latest Exchange service pack, if applicable.
  7. Start the Exchange System Manager program.
  8. Enable the Lotus Notes address space. To do this, follow these steps:
    1. Expand Recipients, and then click Recipient Policies.
    2. In the right pane, right-click Default Policy, and then click Properties.
    3. Click the E-Mail Addresses (Policy) tab, click to select the NOTES check box, and then click Apply.
    4. On the following message that appears, click Yes:
      Address generation for [NOTES] has been enabled for all newly created Recipients. Do you want to automatically add the Address Type to all existing Recipients E-mail addresses?
    5. Click OK.
  9. If you have administrative groups enabled, expand Administrative Groups, and then expand your administrative group.
  10. Expand Connectors, right-click Connector for Lotus Notes (ExchangeServerName), and then click Properties.
  11. On the General tab, type the Domino server name in the Notes Server box. For example, type ServerName/DomainName in the Notes Server box.
  12. Click Modify, and then type the path of the Notesc.ini file that you created in step 4 of the "Step 3: Modify the Notes.ini file and create a shortcut to the connector account" section. For example, type c:\Lotus\Notes\notesc.ini in the Notes INI file location box.
  13. Click OK, and then type exchange.box in the Connector mailbox box if exchange.box does not already appear there.
  14. Click the Address Space tab, and then click Add.
  15. Click NOTES, click OK, type an asterisk (*) in the User Name box, type an asterisk (*) in the Domain box, and then click OK.
  16. Click the Import Container tab, and then click Modify.
  17. Expand your domain, click the organizational unit where you want the Lotus Notes users to be created, and then click OK.
  18. If you receive the following message, click Yes:
    The machine account must be granted permission to create and modify recipients in the selected import container. Continue?
  19. If you want to export users from the Active Directory directory service to Lotus Notes, follow these steps:
    1. Click the Export Containers tab.
    2. If you want to export contacts to Lotus Notes, click to select the Export contacts check box, click Add, expand your domain, click the container that contains the users who you want to export, and then click OK.
    3. If you want to export groups to Lotus Notes, click to select the Export groups check box, click Add, expand your domain, click the container that contains the groups that you want to export, and then click OK.
  20. Click Apply, and then click OK.
  21. Start the Microsoft Exchange Connector for Lotus Notes service. This starts the Microsoft Exchange Connectivity Controller service. To start the Microsoft Exchange Connector for Lotus Notes service, follow these steps:
    1. Click Start, click Run, type services.msc, and then click OK.
    2. Right-click Microsoft Exchange Connector for Lotus Notes, and then click Start.

Step 6: Test the transfer of e-mail between Lotus Notes and Exchange, and perform a directory synchronization

You can test the sending and receiving of e-mail messages between Exchange and Lotus Notes by using the "NotesAdmin" account after this account has replicated to Active Directory. View the Command Prompt window where Domino server is running to see the message traffic in both directions.

To complete the Lotus Notes to Exchange directory synchronization, follow these steps:
  1. In Exchange System Manager, right-click Connector for Lotus Notes (ExchangeServerName), and then click Properties.
  2. Click the Dirsync Options tab, and then click Immediate full reload.
  3. On the following message that appears, click OK:
    A process has been started to synchronize the directories.
  4. Click OK.
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Microsoft continues to update the tools that support interoperability among Lotus Domino R5 and Lotus Domino 6, Microsoft Exchange Server 2003, and Microsoft Windows Server 2003 Active Directory. The updated tools for Lotus Domino replace the following tools that are included with Exchange Server 2003 and with Microsoft Exchange Server 2003 Service Pack 2:
  • Exchange Connector for Lotus Notes
  • Calendar Connector for Lotus Notes
  • Migration Wizard for Lotus Notes
To obtain these tools and to obtain guidance and additional resources, visit the following Microsoft Web site:
http://technet.microsoft.com/en-us/interopmigration/bb403105.aspx
These updated tools provide additional functionality and address several issues that customers reported with earlier versions of the tools.

Properties

Article ID: 883727 - Last Review: November 5, 2007 - Revision: 3.2
APPLIES TO
  • Microsoft Exchange 2000 Server Standard Edition
Keywords: 
kbdeployment kbhowto kbinfo KB883727

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com