Artikel-ID: 883789 - Geändert am: Montag, 30. Oktober 2006 - Version: 1.2

Das Symbol "Drucker und Faxgeräte" in Windows Explorer möglicherweise nicht auf einem Remotecomputer angezeigt, und Sie können möglicherweise nicht möglich, einen Drucker an einen Remotecomputer hinzuzufügen, mithilfe eines Befehlszeilenprogramms in Windows Server 2003

SystemtippDieser Artikel bezieht sich auf ein anderes Betriebssystem als das von Ihnen verwendete. Für Sie möglicherweise nicht relevante Artikelinhalte wurden deaktiviert.

Auf dieser Seite

Alles erweitern | Alles schließen

Problembeschreibung

In Windows Server 2003 Wenn Sie Windows Explorer zum Durchsuchen von eines Remotecomputers verwenden können Sie nicht das Symbol Drucker und Faxgeräte auf dem Remotecomputer angezeigt.

Darüber hinaus Wenn Sie versuchen, einen Drucker zu einem Windows 2003-Remotecomputer hinzufügen, indem mithilfe eines Befehlszeilenprogramms die Druckerinstallation kann nicht abgeschlossen werden und möglicherweise sinngemäß die folgende Fehlermeldung:
Der Vorgang konnte nicht abgeschlossen werden. Entweder der eingegebene Druckername ist ungültig, oder der angegebene Drucker ist nicht mehr mit dem Server verbunden.

Ursache

Dieses Problem, wenn der remote Procedure Call (RPC)-Endpunkt für den Spooler nicht in Windows Server 2003 aktiviert ist.

Wenn dem Computer mit Windows Server 2003 nicht über alle freigegebenen lokalen Drucker verfügt, wird der RPC-Endpunkt für den Spooler nicht erstellt. Wenn der Computer einen lokalen freigegebenen Drucker verfügt, wird der RPC-Endpunkt erstellt, nachdem der lokale Spooler initialisiert wird. Die Zeit, die für den lokalen Spooler initialisiert erforderlich ist hängt die Anzahl der lokalen Drucker.

Hinweis: Das Drucker und Faxgeräte Symbol angezeigt, wenn Sie einen Remotecomputer durchsuchen ist eine grafische Darstellung der RPC-Endpunkt. Der RPC-Endpunkt für den Spooler ermöglicht die Remoteverwaltung von drucken Serverdienste.

Abhilfe

Verwenden Sie um dieses Problem zu umgehen, eine der folgenden Methoden.

Methode 1: Verwenden von Terminaldienste oder ein Skript zum Hinzufügen eines Druckers auf dem Remotecomputer

Von einem Clientcomputer aus mithilfe des Remotedesktops eine Verbindung zur Verfügung auf dem Windows 2003-Computer herstellen. Nachdem Sie die Terminaldienste-Verbindung, verwenden Sie Neuer Drucker in Drucker und Faxgeräte im Startmenü , um einen Drucker auf der Windows Server 2003-basierten Computer hinzuzufügen.

Informationen dazu, wie Sie ein Skript, um einen Drucker mithilfe von Prnadmin.dll hinzufügen finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:
321025  (http://support.microsoft.com/kb/321025/ ) Das programmgesteuerte eines Druckers und Druckeranschluss erstellen mithilfe von PrinterAdmin (Prnadmin.dll) mit einem Visual Basic-Skript in Microsoft Windows 2000
189105  (http://support.microsoft.com/kb/189105/ ) Zum Hinzufügen von Druckern ohne Interaktion des Benutzers in Windows

Methode 2: Verwenden der Terminaldienste so konfigurieren Sie die Druckerwarteschlange erlauben Richtlinieneinstellung Clientverbindungen akzeptieren auf der Windows 2003-Computer

  1. Verwenden Sie die Verbindung zu Ihrem Computer Windows 2003-Terminaldienste.
  2. Klicken Sie auf Start , klicken Sie auf Ausführen , geben Sie Mmc ein und klicken Sie dann auf OK .
  3. Klicken Sie im Datei auf Snap-In hinzufügen/entfernen .
  4. Klicken Sie auf der Registerkarte eigenständig auf Hinzufügen .
  5. Klicken Sie in der Liste Verfügbare eigenständige Snap-Ins auf Gruppenrichtlinienobjekt-Editor , und klicken Sie dann auf Hinzufügen .
  6. Klicken Sie im Dialogfeld Gruppenrichtlinienobjekt auswählen auf Durchsuchen .
  7. Doppelklicken Sie auf den Namen des Computers, auf dem Terminaldienste ausgeführt wird, klicken Sie auf den Namen der Richtlinie, und klicken Sie dann auf Fertig stellen .
  8. Klicken Sie auf Schließen , und klicken Sie dann auf OK .
  9. Doppelklicken Sie auf den Namen der Richtlinie, doppelklicken Sie auf Computerkonfiguration , und doppelklicken Sie dann auf Administrative Vorlagen .
  10. Klicken Sie auf Drucker , und doppelklicken Sie dann im Detailfenster auf Zur Druckerwarteschlange erlauben Clientverbindungen akzeptieren .
  11. Klicken Sie auf der Registerkarte Einstellungen auf aktiviert , und klicken Sie dann auf OK .
Weitere Informationen über das Skript für Gruppenrichtlinien-Aufgaben finden Sie die folgende KB-Artikelnummer:
818735  (http://support.microsoft.com/kb/818735/ ) Whitepaper: Verwalten von Gruppenrichtlinien mithilfe der Gruppenrichtlinien-Verwaltungskonsole

Weitere Informationen

Weitere Informationen dazu, wie einen Drucker hinzufügen Remote mithilfe eines Befehlszeilenprogramms finden Sie die folgende KB-Artikelnummer:
314486  (http://support.microsoft.com/kb/314486/ ) Unter Windows XP Drucker ohne Benutzereingriff hinzufügen

Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Keywords: 
kbmt kbwinservperf kbfileprintservices kbprb KB883789 KbMtde
Maschinell übersetzter ArtikelMaschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 883789  (http://support.microsoft.com/kb/883789/en-us/ )
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.