Article ID: 883824 - Last Review: June 17, 2008 - Revision: 4.2

When you try to install an update, you may receive a "0x8007F0F4" error

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SYMPTOMS

When you try to install an update, you may receive a "0x8007F0F4" error.

CAUSE

The following are common causes of this error:
  • You are installing a service pack such as Windows XP Service Pack 2 (SP2) on a portable computer or on a Tablet PC that is running on battery power.
  • You are missing a prerequisite update. This update is needed before you can install the update that you are currently trying to install.

RESOLUTION

To resolve this problem on a portable computer or on a Tablet PC that is not running on an AC power supply, plug in your computer or your Tablet PC to run it from its AC power supply. Then, try to install the update on your computer.

Advanced troubleshooting

This section is intended for advanced computer users. If you are not comfortable with advanced troubleshooting, you might want to ask someone for help or contact support. For information about how to do this, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/ (http://support.microsoft.com/contactus/)
Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows
This issue has been found to occur when you install previously released time zone updates for Microsoft Windows operating systems. To resolve this issue in this scenario, follow these steps:
  1. Click Start, and then click Run.
  2. Copy and then paste (or type) the following command in the Open box, and then press ENTER:
    regedit
  3. Select My Computer (the root node) in the navigation pane on the left side, click Export under the File menu, and then select All under Export range.
  4. Select Desktop in the Save in box, type backup in the File Name box, and then click Save.

    Note The backup file is located on the Desktop and is named "backup.req." You can restore the registry by double-clicking the backup.req file. After you complete the troubleshooting, and the issue is resolved, you can delete this file.
  5. In Registry Editor, locate the following subkey:
    HKEY LOCAL MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Time Zones
  6. In the details panel on the right side, locate and double-click the following registry entry:
    TZVersion
  7. Type 0 in the Value Data field, and then click OK.
  8. Exit Registry Editor.
  9. Install update KB931836 again.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

APPLIES TO
  • Microsoft Windows Update
  • Microsoft Update
Keywords: 
kbresolve kbwindowsupdatev6 kberrmsg kbwindowsupdate kbtshoot kbprb KB883824
 

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