Não é possível adicionar ou remover componentes do Windows no Windows XP

Traduções deste artigo Traduções deste artigo
ID do artigo: 884018 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Ao tentar adicionar um componente do Windows depois de instalar primeiro o Microsoft Windows XP, não será possível adicionar o componente e uma mensagem de erro semelhante a seguinte poderá ser exibida:
Arquivos necessários
O arquivo 'nome_do_arquivo' no CD-ROM do Windows XP Professional é necessário.
Digite o caminho onde está o arquivo e, em seguida, clique em OK.
Esse problema ocorre mesmo se o arquivo já existir na pasta C:\Windows\I386. Ao fornecer o caminho do arquivo, a mensagem de erro será exibida novamente.

Quando esse erro ocorrer, uma entrada semelhante à seguinte aparece no arquivo C:\Windows\Security\logs\scecomp.log:
Hora_Data Error=1208 Update File
C:\WINDOWS\system32\nome_do_arquivo
Security=D:P(A;;GRGX;;;BU)(A;;GRGX;;;PU)(A;;GA;;;BA)(A;;GA;;;SY)(A;;GRGX;;;WD)
Esse problema também foi localizado para impedir a instalação de hardware e software de terceiros. Especificamente, você pode enfrentar esse sintoma ao instalar o Windows XP Service Pack 2 (SP2) em um computador com um dispositivo de rede Atheros sem-fio interno e ao tentar instalar um dispositivo Bluetooth.

Esse problema ocorre ao tentar instalar um ou mais dos seguintes componentes do Windows:
  • Acessórios e utilitários
  • Serviços de fax
  • Serviço de indexação
  • Internet Explorer
  • IIS (Serviços de Informações da Internet)
  • Ferramentas de gerenciamento e monitoramento
  • Enfileiramento de mensagens
  • MSN Explorer
  • Serviços de rede
  • Outros serviços de arquivos e impressão de rede
  • Outlook Express
  • Atualizar certificados raiz
  • Windows Media Player
  • Windows Messenger

Causa

Esse problema ocorre porque o banco de dados de segurança está corrompido.

Resolução

Observação Não é aconselhável usar o utilitário Esentutl.exe para recuperar da corrupção de banco de dados de segurança. O utilitário Esentutl.exe corrige corrupções ao excluir dados do banco de dados e possivelmente marcar de forma permanente a configurações das Diretivas de Grupo no Registro. Somente use esse tipo de reparo como último recurso.

Para resolver esse problema, recompile o banco de dados de segurança corrompido. Para obter informações adicionanis sobre como recompilar um banco de dados de segurança corrompido, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
278316 Identificações de evento 1000, 1202, 412 e 454 do ESENT, são registradas repetidamente no log de eventos do aplicativo


Para impedir que esse problema ocorra na instalação do Windows XP, contate o Atendimento Microsoft para obter o seguinte hotfix. Para usar a correção atualizada contida nesse hotfix, crie um compartilhamento de arquivo de distribuição do Windows XP e substitua a unidade existente pela unidade atualizada contida nesse hotfix. Isso impedirá que o problema descrito na seção Sintomas ocorra durante a instalação do Windows XP. Para obter informações adicionais, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
828930 Como integrar atualizações de software nos arquivos de origem de instalação do Windows
É necessário seguir as instruções do artigo 828930 da Base de Dados de Conhecimento Microsoft para atualizar o hotfix no compartilhamento de arquivos de distribuição.

Informações sobre o hotfix

Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir somente o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Testes adicionais podem ser realizados nesse hotfix. Portanto, se esse problema não o prejudicar seriamente, é recomendável que você aguarde o próximo service pack que contenha esse hotfix.

Para resolver esse problema, envie uma solicitação para o Atendimento ao Cliente Online Microsoft para obter o hotfix. Para enviar a solicitação online para obter o hotfix, visite o seguinte site da Microsoft:
http://go.microsoft.com/?linkid=6294451
Observação Se outros problemas ocorrerem ou se uma solução de problemas for requisitada, pode ser necessário criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões e problemas de suporte que não se qualifiquem a esse hotfix. Para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:
http://support.microsoft.com/contactus/?ws=support

Informações sobre o arquivo

A versão em inglês desse hotfix tem os atributos de arquivo (ou posterior) listados na tabela a seguir. As datas e horários desses arquivos estão listados em formato UTC (Tempo Universal Coordenado). Ao exibir as informações sobre o arquivo, elas são convertidas para a hora local. Para localizar a diferença entre o UTC e a hora local, use a guia Fuso horário na ferramenta Data e hora do Painel de Controle.
   Data         Hora   Versão        Tamanho       Nome do arquivo   Nível do SP
   ---------------------------------------------------------------
   12-ago-2004  20:44  5.1.2600.1582  302.592  Scesrv.dll   SP1QFE 
   12-ago-2004  20:26  5.1.2600.2505  313.856  Scesrv.dll   SP2QFE

Situação

A Microsoft confirmou que esse é um problema nos produtos Microsoft que estão listados na seção "Aplica-se a".

Mais Informações

Para obter informações adicionais sobre a terminologia usada neste artigo, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
824684 Descrição da terminologia padrão usada para descrever as atualizações de software da Microsoft
Os produtos de terceiros mencionados neste artigo são fabricados por empresas que são independentes da Microsoft. A Microsoft não oferece garantia, implícita ou não, em relação ao desempenho ou à confiabilidade desses produtos.

Propriedades

ID do artigo: 884018 - Última revisão: quinta-feira, 11 de outubro de 2007 - Revisão: 5.1
A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Palavras-chave: 
kberrmsg kbbug kbfix kbqfe kbhotfixserver KB884018

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com