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Programs that connect to IP addresses that are in the loopback address range may not work as you expect in Windows XP Service Pack 2

Article ID:884020
Last Review:June 1, 2006
Revision:4.6
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SYMPTOMS

On a computer that is running Microsoft Windows XP with Service Pack 2 (SP2), programs that connect to IP addresses that are in the loopback address range may not work as you expect. For example, you may receive an error message that says that you cannot establish a connection.

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CAUSE

This problem occurs if the program connects to a loopback address other than 127.0.0.1. Windows XP Service Pack 2 (SP2) prevents connections to all IP addresses that are in the loopback address range except for 127.0.0.1.

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RESOLUTION

Update information

The following file is available for download from the Microsoft Download Center:
DownloadDownload the Update for Windows XP Service Pack 2 (KB884020) package now. (http://www.microsoft.com/downloads/details.aspx?FamilyId=17D997D2-5034-4BBB-B74D-AD8430A1F7C8&displaylang=en) Release Date: September 2004

For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 (http://support.microsoft.com/kb/119591/) How to obtain Microsoft support files from online services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file.

Prerequisites

This update requires Windows XP Service Pack 2 (SP2).

Restart requirement

You have to restart your computer after you apply this update.

Update replacement information

This update does not replace any other updates.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name
   -----------------------------------------------------
   13-Aug-2004  22:50  5.1.2600.2505  359,040  Tcpip.sys

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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MORE INFORMATION

This fix is also included in the fix for Microsoft Knowledge Base article 893066. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
893066 (http://support.microsoft.com/kb/893066/) MS05-019: Vulnerabilities in TCP/IP could allow remote code execution and denial of service


For more information about how to troubleshoot a problem where Remote Desktop Connection does not permit loopback connections to ports that it is not listening on, click the following article number to view the article in the Microsoft Knowledge Base:
817293 (http://support.microsoft.com/kb/817293/) Remote Desktop Connection does not permit loopback connections to ports that it is not listening on
For more information about troubleshooting TCP/IP connectivity issues with Windows XP, click the following article number to view the article in the Microsoft Knowledge Base:
314067 (http://support.microsoft.com/kb/314067/) How to troubleshoot TCP/IP connectivity with Windows XP
For more information about standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 (http://support.microsoft.com/kb/824684/) Description of the standard terminology that is used to describe Microsoft software updates

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APPLIES TO
Microsoft Windows XP Professional Service Pack 2 (SP2)
Microsoft Windows XP Tablet PC Edition 2005

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Keywords: 
kbqfe kbhotfixserver atdownload kb3rdparty kbprint kbnetwork kbfix kbbug KB884020

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