文書番号: 884020 - 最終更新日: 2006年3月24日 - リビジョン: 4.2

Windows XP Service Pack 2 でループバック アドレスの範囲内の IP アドレスに接続するプログラムが正常に動作しないことがある

お知らせお使いのオペレーティング システムには適用しない情報が含まれている場合があります。

目次

すべて展開する | すべて折りたたむ

現象

Service Pack 2 (SP2) をインストール済みの Microsoft Windows XP を実行しているコンピュータで、ループバック アドレスの範囲内の IP アドレスに接続するプログラムが正常に動作しないことがあります。たとえば、接続を確立できないことを通知するエラー メッセージが表示されることがあります。

原因

この問題は、プログラムが 127.0.0.1 以外のループバック アドレスに接続する場合に発生します。Windows XP Service Pack 2 (SP2) では、127.0.0.1 以外のループバック アドレスの IP アドレスへの接続は禁止されます。

解決方法

更新プログラムの情報

下記のファイルは、「Microsoft ダウンロード センター」からダウンロードできます。
元に戻す画像を拡大する
ダウンロード
Windows XP Service Pack 2 用更新プログラム (KB884020) パッケージ (http://www.microsoft.com/downloads/details.aspx?displaylang=ja&FamilyID=17d997d2-5034-4bbb-b74d-ad8430a1f7c8) リリース日 : 2004 年 9 月 17 日

マイクロソフトのサポート ファイルのダウンロード方法を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
119591? (http://support.microsoft.com/kb/119591/ ) オンライン サービスからマイクロソフトのサポート ファイルを入手する方法
マイクロソフトでは、アップロード時点の最新のウイルス検査プログラムを使用して、配布ファイルのウイルス チェックを行っています。配布ファイルはセキュリティで保護されたサーバー上に置かれており、権限のない第三者が無断でファイルを変更できないようになっています。

必要条件

この更新プログラムには Windows XP Service Pack 2 (SP2) が必要です。

再起動の必要性

この更新プログラムの適用後、コンピュータを再起動する必要があります。

更新プログラムの置き換えに関する情報

この更新プログラムを適用しても、他の更新プログラムが置き換えられることはありません。

ファイル情報

修正プログラム (日本語版) のファイル属性は次表のとおりです。ただし、これより新しい修正プログラムがリリースされている可能性もあります。
   日付           時刻    バージョン          サイズ     ファイル名
   ------------------------------------------------------------------
   2004/08/14  07:50  5.1.2600.2505    359,040  tcpip.sys       

状況

マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。

詳細

リモート デスクトップ接続で、リッスンしていないポートへのループバック接続が許可されない問題のトラブルシューティングの関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
817293? (http://support.microsoft.com/kb/817293/ ) リモート デスクトップ接続で、リッスンしていないポートへのループバック接続が許可されない
Windows XP における TCP/IP 接続のトラブルシューティングの関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
314067? (http://support.microsoft.com/kb/314067/ ) Windows XP における TCP/IP 接続のトラブルシューティング
マイクロソフトのソフトウェア更新プログラムの説明に使用される標準的な用語の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
824684? (http://support.microsoft.com/kb/824684/ ) マイクロソフトのソフトウェアの更新で使用される一般的な用語の説明

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 884020? (http://support.microsoft.com/kb/884020/EN-US/ ) (最終更新日 2005-01-26) を基に作成したものです。

この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Professional Service Pack 2 (SP2)
  • Microsoft Windows XP Home Edition Service Pack 2 (SP2)
  • Microsoft Windows XP Media Center Edition Service Pack 2 (SP2)
  • Microsoft Windows XP Tablet PC Edition 2005
キーワード:?
kbbug kbfix kbprint kbqfe kbnetwork kb3rdparty atdownload kbhotfixserver KB884020
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"