文書番号: 884069 - 最終更新日: 2005年8月5日 - リビジョン: 2.0

ネットワーク、ハード ディスク、または記憶装置ドライバの問題によって Windows XP のプログラムが突然クラッシュする

目次

すべて展開する | すべて折りたたむ

現象

ネットワークを利用可能なプログラムを Microsoft Windows XP で起動または実行し、リモート記憶域メディアに対して、有効なデータの読み出しまたは書き込みを行うと、プログラムがクラッシュし、以下のエラー メッセージが表示されます。
問題が発生したため、Program_name を終了します。
ご不便をおかけして申し訳ありません。作業途中であった場合、その情報は失われた可能性があります。
この問題を Microsoft に報告してください。Program_name のエラー報告が作成されました。弊社では、この報告を製品の改善に役立てるとともに、匿名の機密情報として扱います。
エラー報告に含まれるデータの参照 : ここをクリックしてください。

原因

この問題は、Windows XP が以下のいずれかの問題によってファイルにアクセスできないために発生します。
  • ネットワーク接続に問題がある。
  • ファイルが保存されているハード ディスクに問題がある。
  • コンピュータにインストールされている記憶域ドライバに問題がある。
  • ハード ディスクが見つからない。
この問題が発生すると、Windows XP はプログラムを終了します。

回避策

この問題を回避するには、以下の手順を実行します。
  1. 開けないファイルを特定します。ファイルを特定するには、次の手順を実行します。
    1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。eventvwr と入力し、[OK] をクリックします。
    2. イベント ビューアの左側のウィンドウで、[アプリケーション] をクリックします。
    3. 右側のウィンドウで、列見出しの [ソース] をクリックします。これにより、一覧がソース順に並べ替えられ、ソースが Application Error であるすべてのイベントが一覧の先頭に表示されます。
    4. ソースが Application Error、イベント ID が 1005 のイベントを検索します。
    5. 見つけたイベントをダブルクリックします。開けなかったファイルが [説明] ボックスに表示されます。
    6. ファイル名をメモし、[イベントのプロパティ] ダイアログ ボックスを閉じます。
  2. メモしたファイルを見つけ、そのファイルを再度開いてみます。
  3. ファイルがネットワーク上にあり、そのファイルを開けない場合、ネットワーク管理者はネットワークに問題があるかどうかを確認します。
  4. ファイルがフロッピーや CD-ROM などのリムーバブル メディアにあり、そのファイルを開けない場合、リムーバブル メディアがドライブに正常に挿入されているかどうかを確認します。
  5. それでもファイルを開けない場合は、Chkdsk ユーティリティ プログラムを使用して、ハード ディスクのファイル システムの検証と修復を行います。これを行うには、次の手順を実行します。
    1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。[名前] ボックスに cmd と入力し、[OK] をクリックします。
    2. コマンド プロンプトで chkdsk /f と入力し、Enter キーを押します。
  6. それでもファイルを開けない場合は、同じハード ディスク上にある他のファイルを開けるかどうかを確認します。開けない場合は、ハード ディスクが破損している可能性があります。ハード ディスクに問題がある場合は、管理者またはコンピュータ ハードウェアの製造元に連絡してください。
: 問題が発生したファイルをバックアップ コピーから復元することが必要な場合があります。 Windows XP でファイルを復元する方法の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
309340? (http://support.microsoft.com/kb/309340/ ) Windows XP のバックアップ ツールを使用してコンピュータ上のファイルとフォルダを復元する方法

状況

マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。

詳細

プログラムで致命的なイベントが発生したことを示すエラー メッセージが表示されると、[エラー報告] ダイアログ ボックスが表示されます。ダイアログ ボックスには、その致命的なイベントに関する情報をマイクロソフトに送信するためのボタンがあります。マイクロソフトでは、この種のイベントの情報を収集してデータベース化し、原因の特定に役立てます。マイクロソフトのデータ収集ポリシーの詳細については、次のマイクロソフト Web サイトを参照してください。
http://oca.microsoft.com/ja/dcp20.asp (http://oca.microsoft.com/ja/dcp20.asp)

エラー署名

元に戻す全体を表示する
EventTypeName NTStatusCode
InPageError c000020c、c00000be、C00000c4、C0000241 または c00000c3
EventTypeName DriveType
InPageError 00000004

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 884069? (http://support.microsoft.com/kb/884069/EN-US/ ) (最終更新日 2005-04-14) を基に作成したものです。

この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Tablet PC Edition
  • Microsoft Windows XP Media Center Edition
キーワード:?
kberrmsg kbtshoot kbdrwatson kbnetwork KB884069
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"
 

サポート技術情報の翻訳

 

Related Support Centers