ID článku: 884070 - Zobraziť produkty, ktorých sa tento článok týka.
Rozbaliť všetko | Zbaliť všetko

PRIZNAKY

Keď spustíte alebo máte spustený program v systéme Microsoft Windows XP, program môže pri pokuse o čítanie alebo zápis platných údajov na médium na ukladanie údajov zlyhať. Program môže zlyhať napríklad pri pokuse o čítanie platných údajov z pevného disku. Môže sa zobraziť nasledovné chybové hlásenie:
Názov_programu spôsobil chybu a je nutné ho ukončiť.
Ospravedlňujeme sa za spôsobené nepríjemnosti. Ak ste mali v čase zlyhania niečo rozpracované, dané informácie sa mohli stratiť.
Oznámte tento problém spoločnosti Microsoft. Vytvorili sme správu o chybe, ktorú nám môžete odoslať, a pomôcť nám tak zdokonaliť program Názov_programu. Túto správu spracujeme ako dôvernú a anonymnú.
Ak chcete zobraziť údaje, ktoré táto správa o chybe obsahuje, kliknite sem.

PRICINA

K tomuto problému dochádza, keď systém Windows XP nemôže pristupovať k súboru z dôvodu problémov s pevným diskom, na ktorom je súbor uložený, alebo s ovládačmi pre médium na ukladanie údajov. Keď sa tento problém vyskytne, systém Windows XP zatvorí daný program.

RIEŠENIE

Ak chcete tento problém obísť, vykonajte nasledovné kroky:
  1. Identifikujte súbor, ktorý sa nedá otvoriť. Pri identifikácii daného súboru postupujte nasledovne:
    1. Kliknite na tlačidlo Štart, kliknite na príkaz Spustiť, zadajte príkaz EVENTVWR a potom kliknite na tlačidlo OK.
    2. V okne Zobrazovač udalostí kliknite na položku Denník aplikácie.
    3. Kliknite na hlavičku stĺpca Zdroj, čím zoradíte zoznam podľa tohto stĺpca a všetky zdroje chýb aplikácie zobrazíte v hornej časti zoznamu.
    4. Vyhľadajte udalosť, ktorej zdroj nesie označenie Application Error a ktorá je identifikovaná hodnotou 1005.
    5. Dvakrát kliknite na túto udalosť.
    6. Súbor, ktorý sa nedá otvoriť, bude uvedený v poli Popis. Poznačte si názov súboru a zatvorte okno Udalosť - vlastnosti.
  2. Pokúste sa znovu otvoriť daný súbor. Môže ísť o dočasný problém a pri ďalšom spustení programu sa nemusí vyskytnúť.
  3. Ak súbor nemožno otvoriť, použite program Chkdsk.exe a skontrolujte alebo opravte systém súborov na pevnom disku. Postupujte nasledovne:
    1. Kliknite na tlačidlo Štart, kliknite na príkaz Spustiť, zadajte príkaz cmd a potom kliknite na tlačidlo OK.
    2. Zadajte príkaz chkdsk /f a stlačte kláves ENTER.

      Zobrazí sa výzva na naplánovanie spustenia programu Chkdsk po reštartovaní počítača.
    3. Stlačte kláves A.
    4. Reštartujte počítač.
  4. Zistite, či na rovnakom pevnom disku možno otvoriť iné súbory. Ak nie, pevný disk je pravdepodobne poškodený. Ak je príčinou problémov pevný disk, požiadajte o pomoc správcu alebo dodávateľa počítačového hardvéru.
Poznámka: Súbor možno tiež obnoviť zo záložnej kópie.

Ďalšie informácie získate po kliknutí na nasledovné číslo článku databázy Microsoft Knowledge Base:
309340 Obnovenie súborov a priečinkov v počítači pomocou nástroja Zálohovanie v systéme Windows XP (Toto prepojenie môže smerovať na obsah, ktorý je z časti alebo celý v angličtine.)

STAV

Spoločnosť Microsoft potvrdila, že ide o problém, ktorý sa týka produktov spoločnosti Microsoft uvedených v časti „Vzťahuje sa na“.

DALSIE INFORMACIE

Dialógové okno Hlásenie chýb sa zobrazuje v prípade výskytu chyby, ktorá v programe zapríčinila závažnú udalosť. Súčasťou okna Hlásenie chýb je položka, ktorú možno použiť na odoslanie informácie o závažnej udalosti do spoločnosti Microsoft. Spoločnosť Microsoft zhromažďuje informácie o týchto typoch udalostí v databáze za účelom identifikovania príčiny ich vzniku. Ďalšie informácie o politike zhromažďovania údajov spoločnosťou Microsoft nájdete na nasledovnej webovej lokalite spoločnosti Microsoft:
http://oca.microsoft.com/sk/dcp20.asp
Nasledovný podpis chyby sa vzťahuje na chybové hlásenie, ktoré je spomenuté v časti Symptómy.
Zbaliť túto tabuľkuRozbaliť túto tabuľku
EventTypeNameNTStatusCode
InPageError c000009c alebo C0000185 alebo C0000102 alebo C000003F alebo 00000002 alebo 00000003

Vlastnosti

ID článku: 884070 - Posledná kontrola: 13. januára 2006 - Revízia: 2.0
Informácie v tomto článku sa týkajú nasledujúcich produktov:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Media Center Edition
  • Microsoft Windows XP Tablet PC Edition
Kľúčové slová: 
kberrmsg kbtshoot kbdrwatson kbprb KB884070

Odošlite odozvu