FIX: You may receive the "Access reserved error - 7711" error message when you try to run the Make-Table query or the Append query on a linked ODBC Sybase table in Access 2002 or in Access 2003

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 884404 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

อาการ

When you try to run a Make-Table query or an Append query on a linked Open Database Connectivity (ODBC) Sybase table in Microsoft Access 2002 or in Microsoft Office Access 2003, you may receive the following error message:
Access Reserved Error - 7711: This error has no definition.

สาเหตุ

This problem occurs when theเลือกmethod is set to1 - Directin the ODBC Sybase Data Source Name (DSN).

การแก้ไข

สามารถโหลด hotfix ได้แล้วจาก Microsoft แต่มุ่งหวังให้ใช้เพื่อแก้ปัญหาที่อธิบายไว้ในบทความนี้เท่านั้น ใช้ hotfix นี้เฉพาะกับระบบต่างๆ ที่พบปัญหานี้เท่านั้น

การแก้ปัญหานี้ ให้ติดต่อ Microsoft Product Support Services เพื่อรับ hotfix สำหรับรายชื่อทั้งหมดของหมายเลขโทรศัพท์ของ Microsoft Product Support Services และข้อมูลเกี่ยวกับค่าใช้จ่ายในการให้คำปรึกษา แวะไปที่เว็บไซต์ต่อไปนี้ของ Microsoft::
http://support.microsoft.com/contactus/?ws=support
หมายเหตุ:ในกรณีพิเศษ อาจมีการยกเว้นค่าใช้จ่ายสำหรับการสนับสนุนทางโทรศัพท์หากผู้เชี่ยวชาญในการให้การสนับสนุนของ Microsoft ระบุว่าการปรับปรุงเฉพาะจะแก้ปัญหาของคุณได้ ค่าใช้จ่ายปกติจะใช้กับการให้การสนับสนุนสำหรับคำตอบเพิ่มเติมและเรื่องที่ไม่สามารถจัดเป็นคำถามเกี่ยวกับการอัพเดทเฉพาะ

For additional information about this hotfix, click the following article number to view the article in the Microsoft Knowledge Base:
870753Description of the Jet 4.0 Database Engine post-837001 hotfix package: July 21, 2004

การหลีกเลี่ยงปัญหา

เมื่อต้องการแก้ไขปัญหานี้ ตั้งค่านี้เลือกmethod to0 - Cursorin the ODBC Sybase DSN and then re-link the Sybase table. การเปลี่ยนแปลงนั้นเลือกmethod, follow these steps:
  1. คลิกเริ่มการทำงานคลิกเรียกใช้ประเภท:Odbccp32.cplแล้ว คลิกตกลง.
  2. ในการผู้ดูแลของแหล่งข้อมูล odbcdialog box, click your Sybase DSN, and then clickตั้งค่าคอนฟิก.
  3. ในการODBC Sybase Wire Protocol Driver Setupกล่องโต้ตอบ คลิกการประสิทธิภาพการทำงานแท็บ
  4. ในการSelect Methodกล่อง คลิก0 - Cursorแล้ว คลิกตกลง.
To re-link the Sybase tables, follow these steps:
  1. เริ่มการทำงานการเข้าถึง Open the Access database.
  2. ในการเครื่องมือเมนู คลิกอรรถประโยชน์ของฐานข้อมูลแล้ว คลิกตัวจัดการตารางที่เชื่อมโยง.
  3. ในการตัวจัดการตารางที่เชื่อมโยงdialog box, click the linked Sybase tables that you want to update, click to select theAlways prompt for new locationกล่องกาเครื่องหมาย และจากนั้น คลิกตกลง.
  4. ในการSelect Data Sourcedialog box, click your Sybase DSN, and then clickตกลง.
  5. Complete the log on information in theLogon to Sybaseกล่องโต้ตอบ แล้วคลิกตกลง.
  6. ในการตัวจัดการตารางที่เชื่อมโยงกล่องโต้ตอบ คลิกตกลง.
หมายเหตุ:The previous steps may be different in your environment. This depends on the version of the Sybase ODBC driver that you use. The ODBC Sybase DSN can be any one of the following:
  • User DSN
  • System DSN
  • File DSN

สถานะ

Microsoft ยืนยันว่าปัญหานี้เป็นปัญหาที่เกิดขึ้นกับผลิตภัณฑ์ของ Microsoft ซึ่งมีการระบุไว้ในส่วน "การใช้งาน"

ผลิตภัณฑ์ของบุคคลที่สามที่กล่าวถึงในบทความนี้ ผลิตขึ้นโดยบริษัทที่ไม่ขึ้นอยู่กับ Microsoft Microsoft ไม่มีการรับประกันใดๆ ไม่ว่าโดยนัยหรือรูปแบบอื่นใด เกี่ยวกับประสิทธิภาพหรือความเชื่อถือได้ของผลิตภัณฑ์เหล่านี้

คุณสมบัติ

หมายเลขบทความ (Article ID): 884404 - รีวิวครั้งสุดท้าย: 17 กันยายน 2554 - Revision: 5.0
ใช้กับ
  • Microsoft Office Access 2003
  • Microsoft Access 2002 Standard Edition
Keywords: 
kbimport kbexport kbconversion kberrmsg kbtshoot kbprb kbmt KB884404 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:884404

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com