An attachment that has an encoded file name that contains Japanese Industry Standards (JIS) characters may be corrupt in Exchange 2000 or in Exchange 2003

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Article ID: 884477 - View products that this article applies to.
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SYMPTOMS

When you receive an attachment in an e-mail message that has an encoded file name that contains Japanese Industry Standards (JIS) characters, the file name may be corrupt.

CAUSE

This issue occurs when the following conditions are true:
  • You are running Microsoft Exchange 2000 Server.
  • The attachment's file name starts with an ASCII string. However, the file name switches to JIS in the middle of the file name.
  • There is a 0x5c character in the encoded Japanese Industry Standards characters.

RESOLUTION

Exchange Server 2003

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Exchange Server 2003. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
836993 How to obtain the latest service packs for Exchange Server 2003

Exchange 2000 Server

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
      Date         Time   Version            Size    File name
   --------------------------------------------------------------
   24-Sep-2004  08:44  6.0.6617.10       262,144  Exmime.dll       
				
Note Because of file dependencies, this update requires Microsoft Exchange 2000 Server Service Pack 3(SP3). For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
301378 How to obtain the latest Exchange 2000 Server service pack

STATUS

Microsoft has confirmed that this is a problem in Microsoft Exchange 2000 Server.
This problem was first corrected in Microsoft Exchange Server 2003 Service Pack 2.

Properties

Article ID: 884477 - Last Review: October 25, 2007 - Revision: 2.4
APPLIES TO
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange 2000 Server Standard Edition
Keywords: 
kbautohotfix kbexchtransport kbfix kbbug kbhotfixserver kbqfe KB884477

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