在 Windows XP 中打开“磁盘管理”时,收到“The RPC server is unavailable”(RPC 服务器不可用)错误消息

文章翻译 文章翻译
文章编号: 884564 - 查看本文应用于的产品
展开全部 | 关闭全部

症状

首次启动计算机时,如果您在 Microsoft Windows XP Out of Box Experience (OOBE) 过程结束后打开“磁盘管理”,可能收到以下两条错误消息之一:
RPC 服务器不可用。
You do not have access rights to Logical Disk Manager on computer name
另外,在事件查看器的应用程序日志中可能记录以下错误:

事件 ID: 10009
来源:DCOM
类型:错误
描述:DCOM 无法使用任何配置的协议与计算机 computer name 通信。

如果重新启动计算机,然后打开“磁盘管理”,则不会收到该错误消息。

原因

发生此问题的原因是:计算机名称与 RPC 服务需要的名称不匹配。如果使用下列方法之一更改了计算机名称,则可能会出现这种不匹配情况:
  • 启动计算机所用的 Windows XP 映像是使用 Microsoft 系统准备 (Sysprep) 工具创建的。
  • 您在 Windows XP Out of Box Experience 过程中更改了计算机名称。
  • 存在下列一种或多种条件:
    • 您在 Windows XP Out of Box Experience 过程中断开了网络电缆。
    • Windows XP Out of Box Experience 过程完成后,您没有重新启动计算机。
    • 您打开了“磁盘管理”。

替代方法

要解决此问题,请在 Windows XP Out of Box Experience 过程完成后,在打开“磁盘管理”之前,至少重新启动一次计算机。

状态

Microsoft 已经确认这是在“适用于”一节中列出的 Microsoft 产品中存在的问题。Microsoft 正在研究此问题,并且将在获得更多信息之后在本文中添加信息。

属性

文章编号: 884564 - 最后修改: 2006年1月23日 - 修订: 2.0
这篇文章中的信息适用于:
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Home Edition
关键字:?
kbbug kbpending kbwinxpsp3fix KB884564
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。

提供反馈

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com