You receive a "MCI Error - All wave devices that can play files in the current format are in use" error message when you play many AVI files in Windows XP

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Article ID: 884568 - View products that this article applies to.
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SYMPTOMS

When you play many Audio Video Interleaved (AVI) files in a window in Microsoft Windows XP, you may receive the following message:
MCI Error - All wave devices that can play files in the current format are in use. Wait until a wave device is free, then try again.

CAUSE

This problem occurs because the Media Control Interface (MCI) supports only 25 active video windows at the same time.

RESOLUTION

To resolve this problem, install this hotfix, and then make a change in the registry. With this hotfix, the number of active video windows that are supported has been increased to 200.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

There are no prerequisites to install this hotfix.

Restart information

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix is not replaced by any later hotfix.

Registry information

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows


To enable this hotfix, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. On 32-bit editions of Windows XP, locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\VFW

    On 64-bit editions of Windows XP, locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\Software\Wow6432Node\Microsoft\Windows NT\CurrentVersion\VFW
  3. Point to New on the Edit menu, and then click DWORD Value.
  4. Type MaxVFWConverters, and then press ENTER.
  5. Right-click MaxVFWConverters, and then click Modify.
  6. In the Value data box, type 300, and then click OK.

    The value that you enter for MaxVFWConverters is three times the number of video windows that you require. For example, to play 100 video windows, type 300 in Value data.

    Note The maximum value for MaxVFWConverters is 600. This value provides for 200 video windows.
  7. Quit Registry Editor.

Hotfix file information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows XP Service Pack 1 (SP1)
   Date         Time   Version        Size     File name
   -------------------------------------------------------
   06-Oct-2004  16:03  5.1.2600.1596  114,176  Msvfw32.dll 
Windows XP Service Pack 2 (SP2)
   Date         Time   Version        Size     File name
   -------------------------------------------------------
   06-Oct-2004  15:54  5.1.2600.2524  121,344  Msvfw32.dll 
Windows XP 64-Bit Edition (Itanium)
   Date         Time   Version        Size     File name     Platform
   ------------------------------------------------------------------
   06-Oct-2004  07:59  5.1.2600.1596  315,392  Msvfw32.dll   IA-64
   06-Oct-2004  08:03  5.1.2600.1596  114,176  Wmsvfw32.dll  x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 884568 - Last Review: August 29, 2007 - Revision: 3.3
APPLIES TO
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP 64-Bit Edition Version 2003
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbwinxppresp3fix kbfix kbbug KB884568

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