ID článku: 884573 - Poslední aktualizace: 31. března 2006 - Revize: 4.4

Chybová zpráva „0x80070005: Přístup byl odepřen“ při vytvoření naplánované úlohy v systému Windows XP Service Pack 2 nebo Windows XP Tablet PC Edition 2005

Systémový tipTento článek se vztahuje na jiný operační systém, než který používáte. Obsah článku, který pro vás pravděpodobně není relevantní, byl zablokován.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Příznaky

Při vytvoření nové naplánované úlohy pomocí Plánovače úloh v počítači se systémem Microsoft Windows XP se může po klepnutí na tlačítko Dokončit zobrazit následující chybová zpráva:
Nová úloha byla vytvořena, ale možná nebude spuštěna, protože nebyly zadány informace o účtu. Příslušná chyba: 0x80070005: Přístup byl odepřen. Zkuste aplikaci najít pomocí tlačítka Procházet na stránce Úloha.
Navíc se při tomto scénáři naplánovaná úloha nespustí očekávaným způsobem. Místo toho je do souboru protokolu naplánované úlohy (Schedlgu.txt) zaznamenána následující položka:
Pokus o načtení informací o účtu zadané úlohy se nezdařil. Úloha proto nebyla spuštěna. Buď došlo k chybě, nebo tyto informace o účtu úlohy nebyly nalezeny. 0x8004130f: V databázi zabezpečení služby Plánovač úloh nebyly nalezeny žádné informace o účtu zadané úlohy.

Příčina

K těmto potížím dochází v důsledku regrese zavedené v obou následujících aktualizacích:
  • Windows XP Service Pack 2 (SP2) a Windows XP Tablet PC Edition 2005,
  • aktualizace popsaná v následujícím článku znalostní báze Microsoft Knowledge Base:
    841873  (http://support.microsoft.com/kb/841873/ ) MS04-022: Chyba zabezpečení v Plánovači úloh umožňuje spuštění kódu

Řešení

Společnost Microsoft má nyní k dispozici podporovanou opravu hotfix, která je určena pouze k odstranění problému popsaného v tomto článku. Použijte ji pouze v systémech, ve kterých dochází k tomuto konkrétnímu problému. Je možné, že tato oprava hotfix bude dále testována. Pokud vás tedy uvedený problém příliš neobtěžuje, doporučujeme, abyste počkali na další aktualizaci Windows XP Service Pack, která bude tuto opravu hotfix obsahovat.

Potřebujete-li odstranit tento problém okamžitě, obraťte se na služby odborné pomoci společnosti Microsoft, kde můžete tuto opravu hotfix získat. Úplný seznam telefonních čísel služeb odborné pomoci společnosti Microsoft a informace o poplatcích za poskytnutí odborné pomoci naleznete na následujícím webu společnosti Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Poznámka: Ve zvláštních případech nemusí být poplatky za poskytnutí odborné pomoci účtovány, pokud pracovník služeb odborné pomoci společnosti Microsoft potvrdí, že tato zvláštní oprava odstraní vaše potíže. Další dotazy a žádosti o odbornou pomoc, které se netýkají této zvláštní opravy, podléhají běžným sazbám za poskytnutí odborné pomoci. Anglická verze této opravy hotfix má následující nebo vyšší atributy souborů. Data a časy jednotlivých souborů jsou uvedeny ve formátu UTC (Coordinated Universal Time). Při zobrazení informací o souboru jsou data a čas převedeny na místní čas. Rozdíl mezi místním časem a časem UTC naleznete na kartě Časové pásmo na panelu Datum a čas v okně Ovládací panely.
   Datum       Čas    Verze           Velikost  Název souboru
   -----------------------------------------------------------
   27. srpna 2004  22:17  5.1.2600.1580  263 680  Mstask.dll
   29. července 2004  23:35  5.1.2600.1580    10 752  Mstinit.exe
   27. srpna 2004  22:17  5.1.2600.1587  172 544  Schedsvc.dll
   30. července 2004  21:29  5.1.2600.1580    594 432  Xpsp2res.dll
   27. srpna 2004  22:08  5.1.2600.2508  190 976  Schedsvc.dll

Jak potíže obejít

Chcete-li problém obejít, přidejte k uživatelskému účtu, který bude naplánovanou úlohu spouštět, oprávnění Přistupovat k tomuto počítači přes síť. Chcete-li provést toto nastavení v zásadách místního počítače, postupujte takto:
  1. Klepněte na tlačítko Start a na příkaz Spustit, zadejte příkaz Gpedit.msc a pak klepněte na tlačítko OK.
  2. V seznamu Místní počítač – zásady rozbalte následující položky:
    Konfigurace počítače
    Nastavení systému Windows
    Nastavení zabezpečení
    Místní zásady
  3. Klepněte na položku Přiřazení uživatelských práv.
  4. Poklepejte na položku Přistupovat k tomuto počítači přes síť, klepněte na tlačítko Přidat uživatele nebo skupinu a na tlačítko Procházet a potom přidejte požadované uživatelské jméno nebo název skupiny.
  5. Dvakrát klepněte na tlačítko OK.
  6. V nabídce Soubor klepněte na příkaz Konec. Tím ukončíte editor Zásady skupiny.

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části Informace v tomto článku jsou určeny pro produkt.

Další informace

K těmto potížím může dojít také v případě, že vytváříte novou úlohu a nezadáte pro tuto úlohu heslo. V tomto případě je třeba vytvořit heslo pro uživatelský účet (pokud heslo nemá) a použít toto heslo pro všechny nově vytvářené úlohy.
Další informace získáte v následujícím článku znalostní báze Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)

Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows XP Professional SP2
  • Microsoft Windows XP Home Edition SP2
  • Microsoft Windows XP Media Center Edition Service Pack 2 (SP2)
  • Microsoft Windows XP Tablet PC Edition 2005
Klíčová slova: 
kbbug kbfix kbqfe kbwinxpsp2fix kbwinxppresp2fix kbhotfixserver KB884573