Article ID: 884578 - Last Review: June 27, 2007 - Revision: 5.1

WMI may stop responding when it tries to retrieve hard disk information in Windows 2000

Hotfix download is availableHotfix Download Available
View and request hotfix downloads

On This Page

Expand all | Collapse all

SYMPTOMS

In Microsoft Windows 2000, a Windows Management Instrumentation (WMI) query may stop responding. This problem may occur when you use WMI to retrieve hard disk drive information. Additionally, the Framework.log file may contain multiple entries with the following information:
Failed to IOCTL_DISK_GET_DRIVE_LAYOUT device DiskID (170) DateTime Thread: ThreadNumber
Note The Framework.log file is located in the %windir%\System32\Wbem\Logs folder.

CAUSE

This problem is caused by an update to the Cimwin32.dll file. See the "Resolution" section for a list of Microsoft Knowledge Base articles that describe updates that may produce this problem.

RESOLUTION

Hotfix information

A newer version of this hotfix is available. For additional information about the newer hotfix, click the following article number to view the article in the Microsoft Knowledge Base:
889405  (http://support.microsoft.com/kb/889405/ ) The process that runs a WMI statement stops responding on a Windows 2000 Service Pack 3 or later-based computer
A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace another hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   05-Sep-2004  04:32  1.50.1085.6972  1,093,727  Cimwin32.dll     

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

WORKAROUND

To work around this problem, restart the WMIMGMT service.

MORE INFORMATION

The error that the "Symptoms" section describes may also cause lots of SCSI reservation requests. This occurs when a Select * WIN32_DISKDrive WMI query is sent to a cluster node that does not own the disk resource that is being queried. Because the query is issued to a non-owning node, a SCSI reservation request is sent to the logical unit number (LUN) so that the node can mount the volume. However, because the shared disk is reserved by the owning node, the reservation request is rejected. The resulting error condition causes this reservation to be reattempted hundreds of times a second.

The Framework.log file logs the "Failed to IOCTL_DISK_GET_DRIVE_LAYOUT" error every time every time that you use WMI to retrieve hard disk drive information. Therefore, the log grows quickly. After you apply this hotfix, the log file registers the "Failed to IOCTL_DISK_GET_DRIVE_LAYOUT" error only one time for each Select request.

When a "shared nothing" architecture is shared among clusters, we recommend that you do not use WMI to query for drives that the cluster node does not own.

This problem does not occur on versions of Windows that are later than Windows 2000.

For more information about the file naming and about the terms that are used to describe software updates, click the following article numbers to view the articles in the Microsoft Knowledge Base:
816915  (http://support.microsoft.com/kb/816915/ ) New file naming schema for Microsoft Windows software update packages
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
Keywords: 
kbautohotfix kbbug kbfix kbwin2000presp5fix kbhotfixserver kbqfe KB884578
 

Article Translations