O Verificador de arquivos de sistema não aceita um local de rede que contém o CD de instalação ao usar a opção scannow no Windows XP SP2 ou Windows Server 2003

Traduções deste artigo Traduções deste artigo
ID do artigo: 885522 - Exibir os produtos aos quais esse artigo se aplica.
Importante Este artigo contém informações sobre como modificar o Registro. Antes de modificá-lo, faça um backup e certifique-se de que sabe como restaurá-lo caso ocorra algum problema. Para obter informações adicionais sobre como fazer backup, restaurar e editar o Registro, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento da Microsoft.
256986 Descrição do Registro do Microsoft Windows
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Ao executar o Verificador de arquivos de sistema (Sfc.exe) com a opção scannow no Microsoft Windows XP Service Pack 2 (SP2), o CD do Windows XP (SP2) é solicitado, mas Sfc.exe não aceitará um local de rede que contém o CD do Windows XP SP2.

Observação Esse problema também se aplica ao Microsoft Windows Server 2003 Service Pack 1.

Causa

Esse problema ocorre quando o service pack é implantado a partir de um servidor de rede interno com a subchave de registro ServicePackSourcePath modificada para apontar para o local de rede que contém os arquivos extraídos do Windows XP SP2. A subchave de registro ServicePackSourcePath está localizada em
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup
.

Resolução

Aviso O uso incorreto do Editor do Registro pode causar sérios problemas que talvez exijam a reinstalação do sistema operacional. A Microsoft não garante que os problemas resultantes do uso incorreto do Editor do Registro possam ser solucionados. O uso do Editor do Registro é de sua responsabilidade.

Para resolver esse problema, modifique o registro de forma que ele aponte para a pasta %windir%\ServicePackFiles. Para fazer isso, execute estas etapas:

Quando o service pack estiver instalado

  1. Clique em Iniciar e em Executar, digite regedit e clique em OK.
  2. Localize a seguinte subchave:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup
  3. Clique com o botão direito do mouse em ServicePackSourcePath, clique em Modificar, digite %windir%\ServicePackFiles e clique em OK.

Quando o service pack não estiver instalado

  1. Copie a sua pasta de binários (i386) para qualquer local. Por exemplo, copie a pasta i386 para %windir%\Options.
  2. Clique em Iniciar e em Executar, digite regedit e clique em OK.
  3. Localize a seguinte subchave:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup
  4. Clique com o botão direito do mouse em SourcePath, clique em Modificar, digite %windir%\Opções\i386, em que Opções é a pasta que contém a pasta i386 e clique em OK.

Situação

A Microsoft confirmou que esse é um problema nos produtos da empresa que estão listados na seção "Aplica-se a".

Mais Informações

Para obter informações adicionais sobre o recurso de proteção de arquivo do Windows, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento da Microsoft:
222193 Descrição do recurso de proteção de arquivo do Windows
Para obter informações adicionais sobre o recurso WFP, visite o seguinte site da Microsoft na Web (em inglês): http://msdn2.microsoft.com/en-us/library/aa382551.aspx
Para obter informações adicionais sobre o Windows Installer e o WFP, visite o seguinte site da Microsoft na Web (em inglês): http://msdn2.microsoft.com/en-us/library/aa372820.aspx

Propriedades

ID do artigo: 885522 - Última revisão: quarta-feira, 7 de fevereiro de 2007 - Revisão: 1.3
A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Home Edition Service Pack 2 (SP2)
  • Microsoft Windows XP Professional Service Pack 2 (SP2)
  • Microsoft Windows XP Media Center Edition Service Pack 2 (SP2)
  • Microsoft Windows XP Tablet PC Edition 2005
  • Microsoft Windows Server 2003 Service Pack 1
Palavras-chave: 
kbtshoot kbbug kbwinxpsp2rel KB885522

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com