Windows XP Service Pack 2 または Windows XP Tablet PC Edition 2005 のインストールを完了するためにコンピュータを再起動するとコンピュータが応答を停止する

文書翻訳 文書翻訳
文書番号: 885626 - 対象製品
すべて展開する | すべて折りたたむ

目次

概要

この資料では、Microsoft Windows XP Service Pack 2 (SP2) または Windows XP Tablet PC Edition 2005 のインストールを完了するためにコンピュータを再起動すると、コンピュータが応答を停止 (ハング) する問題の解決方法を説明します。この問題は、BIOS (Basic Input/Output System) が Prescott C-0 ステッピング版の Intel Pentium 4 プロセッサおよび Intel Celeron D プロセッサに対応していないごく一部のシステムで発生します。

現象

Microsoft Windows XP Service Pack 2 (SP2) または Windows XP Tablet PC Edition 2005 のインストールを完了するためにコンピュータを再起動すると、コンピュータが応答を停止 (ハング) します。

コンピュータを再起動するときに以下のいずれかのオプションを選択した場合に、この問題が発生します。
  • Windows を通常起動する
  • 前回正常起動時の構成
  • セーフ モード
  • セーフ モードとコマンド プロンプト

原因

この問題は、以下の条件に該当する場合に発生することがあります。
  • Prescott C-0 ステッピング版の Intel Pentium 4 プロセッサまたは Intel Celeron D プロセッサがコンピュータに搭載されています。
  • コンピュータで仕様外のバージョンの BIOS が使用されています。

    : 仕様外のバージョンの BIOS では、コンピュータに搭載されているプロセッサがサポートされません。

解決方法

この問題を解決するには、以下のいずれかの方法を使用します。

方法 1

コンピュータの製造元に問い合わせて、コンピュータに搭載されているプロセッサに対応している BIOS の更新プログラムを入手します。

方法 2

Windows XP SP2 をインストールしていない場合、Windows XP 用の重要な更新プログラム (KB885626) をインストールして、Windows XP SP2 をインストールします。

更新プログラムの情報

下記のファイルは、「Microsoft ダウンロード センター」からダウンロードできます。
元に戻す画像を拡大する
ダウンロード
Windows XP 用の重要な更新プログラム (KB885626) パッケージ マイクロソフトのサポート ファイルのダウンロード方法の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
119591 オンライン サービスからマイクロソフトのサポート ファイルを入手する方法
マイクロソフトでは、アップロード時点の最新のウイルス検査プログラムを使用して、配布ファイルのウイルス チェックを行っています。配布ファイルはセキュリティで保護されたサーバー上に置かれており、権限のない第三者が無断でファイルを変更できないようになっています。

回避策

Windows XP SP2 をインストール済みでコンピュータが起動しない場合に、この問題を回避するには、更新済みの Update.sys をインストールするまでの間、または、更新されたバージョンの BIOS を入手するまでの間、以下の回避策のいずれかを使用できます。

: システムに何らかのソフトウェア更新プログラムを適用する前に、以下の「方法 1」または「方法 2」の手順を最後まで必ず実行してください。

方法 1 : Windows XP 回復コンソールを使用する

Windows XP 回復コンソールを使用してコンピュータを起動するには、以下の手順を実行します。
  1. フロッピー ディスク ドライブに Windows XP 起動ディスクを挿入するか、CD ドライブまたは DVD ドライブに Windows XP CD-ROM を挿入し、コンピュータを再起動します。

    Windows XP セットアップ ディスクの入手方法および使用方法の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
    310994 Windows XP セットアップ ブート ディスクの入手方法
  2. CD ドライブまたは DVD ドライブから起動するためのオプションが表示された場合は、必要なオプションを 1 つまたは複数選択します。
  3. セットアップの画面が表示されたら、R キーを押して回復コンソールを起動します。
  4. コンピュータが応答を停止した Windows XP SP2 のインストールに対応する数字を入力します。インストールが 1 つしか表示されない場合でも、この数字を入力する必要があります。
  5. 管理者のパスワードを入力し、Enter キーを押します。
  6. コマンド プロンプトで次の行を入力し、Enter キーを押します。

    cd system32\drivers

  7. コマンド プロンプトで ren update.sys update.sp2 と入力し、Enter キーを押します。
  8. コマンド プロンプトで exit と入力し、Enter キーを押します。
  9. BIOS の更新プログラムを入手したら、プログラムの提供元が指定する手順に従ってコンピュータの BIOS を更新します。
  10. Windows XP SP2 を起動します。
  11. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。[名前] ボックスに cmd と入力し、[OK] をクリックします。
  12. コマンド プロンプトで次の行を入力し、Enter キーを押します。

    cd %systemroot%\system32\drivers
  13. コマンド プロンプトで move update.sp2 update.sys と入力し、Enter キーを押します。
  14. この資料で前述した Windows XP 用の重要な更新プログラム (KB885626) を適用します。

    警告 : Update.sys ファイルをインストールするまでは、コンピュータを操作しないでください。
  15. コンピュータを再起動します。

方法 2 : Windows の別のインストールを起動する

Microsoft Windows の複数のインストールを起動できるようにコンピュータが構成されている場合は、以下の手順を実行してコンピュータを起動します。
  1. コンピュータを起動し、正常に機能する Windows パーティションを選択します。
  2. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。[名前] ボックスに cmd と入力し、[OK] をクリックします。
  3. コマンド プロンプトで次の行を入力し、Enter キーを押します。

    cd WinXPSP2\system32\drivers

    WinXPSP2 は、Windows XP SP2 がインストールされている Windows フォルダのパスです。
  4. コマンド プロンプトで、move update.sys update.sp2 と入力し、Enter キーを押します。
  5. コマンド プロンプトで exit と入力し、Enter キーを押します。
  6. コンピュータを再起動し、Windows XP SP2 のインストールを起動します。
  7. BIOS の更新プログラムを入手したら、プログラムの提供元が指定する手順に従ってコンピュータの BIOS を更新します。
  8. Windows XP SP2 を起動します。
  9. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。[名前] ボックスに cmd と入力し、[OK] をクリックします。
  10. コマンド プロンプトで次のように入力し、Enter キーを押します。

    cd %systemroot%\system32\drivers
  11. コマンド プロンプトで move update.sp2 update.sys と入力し、Enter キーを押します。
  12. コンピュータを再起動します。
  13. この資料で前述した Windows XP 用の重要な更新プログラム (KB885626) を適用します。

    警告 : Update.sys ファイルをインストールするまでは、コンピュータを操作しないでください。

詳細

Windows XP では、搭載されているプロセッサをサポートするために BIOS とは独立して実行される、プロセッサのステッピングごとに特化した更新プログラムが提供されることがあります。Intel から提供される特定のプロセッサ向けのプロダクション サポート更新プログラムをオペレーティング システムが読み込むことができないと、STOP エラーが発生することや、システムを起動できないことがあります。この資料に記載されている問題では、BIOS により必要なプロダクション サポートが提供されないため、Windows XP に含まれている Intel 提供のプロダクション サポート更新プログラムによってシステムが応答を停止します。

Prescott C-0 ステッピング版の Intel Pentium 4 プロセッサまたは Intel Celeron D プロセッサがコンピュータに搭載されているかどうか、および必要なプロダクション サポートが提供されない BIOS が使用されているかどうかを確認するには、以下の手順を実行します。
  1. 以下の Intel Web サイトから Intel Processor Frequency ID Utility のブート可能版をダウンロードして、起動ディスクを作成します。
    http://downloadfinder.intel.com/scripts-df-external/Detail_Desc.aspx?agr=N&ProductID=25&DwnldID=3088&strOSs=44&OSFullName=Windows* XP&lang=jpn
  2. 手順 1. で作成した起動ディスクを使用してコンピュータを起動します。
  3. "CPUID Data" という部分で、コンピュータの仕様を確認します。各項目の値が以下に該当するコンピュータは、この資料に記載されている問題の影響を受けます。
    • Family : F
    • Model : 3
    • Stepping : 3
    • CPU Revision 値 : 3、 2、1、または 0
この問題の詳細については、以下の Intel Web サイトを参照してください。
http://support.intel.co.jp/jp/support/processors/#Desk
この資料に記載されているサードパーティ製品は、マイクロソフトと関連のない他社の製品です。明示または黙示にかかわらず、これらの製品のパフォーマンスや信頼性についてマイクロソフトはいかなる責任も負わないものとします。 他社テクニカル サポートのお問い合わせ窓口は、ユーザーの便宜のために提供されているものであり、将来予告なしに変更されることがあります。マイクロソフトは、掲載している情報に対して、いかなる責任も負わないものとします。

プロパティ

文書番号: 885626 - 最終更新日: 2007年8月24日 - リビジョン: 3.4
この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Professional Service Pack 2 (SP2)
  • Microsoft Windows XP Media Center Edition Service Pack 2 (SP2)
  • Microsoft Windows XP Home Edition Service Pack 2 (SP2)
  • Microsoft Windows XP Tablet PC Edition 2005
キーワード:?
kbtshoot kbqfe kbprb atdownload kbhotfixserver KB885626
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com