Artikel-ID: 885726 - Geändert am: Donnerstag, 27. September 2007 - Version: 3.4

Der Microsoft Operations Manager 2005-Agent installiert nicht auf Computern, auf denen Windows XP mit Service Pack 2 (SP2) und Windows Server 2003 mit Service Pack 1 (SP1) ausgeführt wird

wichtig Dieser Artikel enthält Informationen, die Ihnen, zeigt wie Sie Sicherheitseinstellungen herabsetzen oder Sicherheitsfunktionen auf einem Computer deaktivieren. Sie können diese Änderungen einem bestimmten Problem zu umgehen vornehmen. Bevor Sie diese Änderungen vornehmen, empfiehlt Microsoft, zunächst die Risiken, die abzuschätzen mit dieser Problemumgehung in Ihrer speziellen Umgebung verbunden sind. Wenn Sie diese Problemumgehung implementieren, sollten Maßnahmen Sie entsprechende treffen, um Ihr System zu schützen.

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Problembeschreibung

Wenn Sie den Assistenten zum Installieren/Deinstallieren von Agents, verwenden um einen Agent auf einem Computer installieren, auf dem Microsoft Windows XP mit Service Pack 2 (SP2) oder Microsoft Windows Server 2003 mit Service Pack 1 (SP1) ausgeführt wird, wird im Dialogfeld Microsoft Operations Manager (MOM) 2005 Taskfortschritt folgende Fehlermeldung:
Computer-Management Aufgabenzusammenfassung:
1 Agentinstallation(en) ist fehlgeschlagen.
Wenn Sie auf Details klicken, erhalten Sie Informationen, die ähnlich der folgenden Meldungen angezeigt, wobei ComputerName der Name des Zielcomputers und ServerName ist der Name des MOM-Servers:
Der MOM-Server konnte nicht angegebene Vorgang auf Computer "ComputerName" ausgeführt werden. Fehlercode:-2147023174-Fehlerbeschreibung: der RPC-Server ist nicht verfügbar.
Der MOM-Server konnte nicht-Agenten auf Remotecomputer ComputerName installiert werden.

Fehlercode:-2147467259
Fehlerbeschreibung: Der Agent konnte keine Verbindung zu den MOM-ServerName herstellen. Der Fehler gemeldet 'ein Verbindungsversuch ist ist fehlgeschlagen, da die Gegenstelle nach einer bestimmten Zeitspanne, oder die hergestellte Verbindung ist fehlgeschlagen, weil verbundene Host reagieren nicht hat nicht ordnungsgemäß geantwortet hat'.. Überprüfen Sie ob der Verwaltungsgruppennamen richtig, der MOM-Server ausgeführt wird, die Sie Port 1270 überwacht und, dass Firewalls zwischen diesen Agent und der MOM-Server konfiguriert sind, TCP- und UDP-Datenverkehr auf Port 1270 übertragen ist.
Microsoft Installer-Fehlerbeschreibung: Keine Beschreibung verfügbar
Eines der folgenden Ereignisse erscheint im Ereignisprotokoll Anwendung auf dem MOM-Server:

Quelle: Microsoft Operations Manager
Typ: Fehler
Ereignis-ID: 21032

Beschreibung:
Der MOM-Server konnte nicht dem Dienststeuerungs-Manager auf Computer "ComputerName" geöffnet werden. Daher kann der MOM-Server Konfiguration der Agent auf dem Computer nicht abschließen.

Fehlercode: 1722
Fehlerbeschreibung: Der RPC-Server ist nicht verfügbar.

Quelle: Microsoft Operations Manager
Typ: Fehler
Ereignis-ID: 21083

Beschreibung:
Der MOM-Server konnte nicht-Agenten auf Remotecomputer ComputerName installiert werden.

Fehlercode:-2147467259
Fehlerbeschreibung: Der Agent konnte keine Verbindung zu den MOM-ServerName herstellen. Der Fehler gemeldet 'ein Verbindungsversuch ist ist fehlgeschlagen, da die Gegenstelle nach einer bestimmten Zeitspanne, oder die hergestellte Verbindung ist fehlgeschlagen, weil verbundene Host reagieren nicht hat nicht ordnungsgemäß geantwortet hat'.. Überprüfen Sie ob der Verwaltungsgruppennamen richtig, der MOM-Server ausgeführt wird, die Sie Port 1270 überwacht und, dass Firewalls zwischen diesen Agent und der MOM-Server konfiguriert sind, TCP- und UDP-Datenverkehr auf Port 1270 übertragen ist.
Microsoft Installer-Fehlerbeschreibung: Keine Beschreibung verfügbar

Darüber hinaus wird das folgende Ereignis im Anwendungsereignisprotokoll auf Computern protokolliert, auf dem der MOM-Agent ausgeführt wird:

Quelle: Microsoft Operations Manager
Typ: Fehler
Ereignis-ID: 26009

Beschreibung:
Der Agent konnte keine Verbindung zu den MOM-ServerName herstellen. Der Fehler gemeldet 'ein Verbindungsversuch ist ist fehlgeschlagen, da die Gegenstelle nach einer bestimmten Zeitspanne, oder die hergestellte Verbindung ist fehlgeschlagen, weil verbundene Host reagieren nicht hat nicht ordnungsgemäß geantwortet hat'.. Überprüfen Sie ob der Verwaltungsgruppennamen richtig, der MOM-Server ausgeführt wird, die Sie Port 1270 überwacht und, dass Firewalls zwischen diesen Agent und der MOM-Server konfiguriert sind, TCP- und UDP-Datenverkehr auf Port 1270 übertragen ist.

Dieses Problem kann auch während einer automatischen Push-Installation des MOM-Agents auftreten.

Ursache

Dieses Problem kann auftreten, wenn Windows-Firewall auf dem Zielcomputer oder auf dem MOM-Server-Computer ausgeführt wird. Wenn Windows-Firewall auf einem MOM-Server ausgeführt wird, können MOM-Agents nicht mit dem MOM-Server kommunizieren. Wenn Windows-Firewall auf einem Zielcomputer oder einen potenziellen MOM-Agent ausgeführt wird, kann der MOM-Server eine Push-Installation von der Agent nicht durchführen.

Windows XP mit SP2 aktiviert standardmäßig Windows-Firewall. Standardmäßig ist Windows-Firewall nicht in Windows Server 2003 mit SP1 aktiviert.

Problembehandlung

Sie können das Dienstprogramm MOM Remote Prerequisite Checker (MOMNetChk.exe) im Microsoft Operations Manager Resource Kit verwenden, um Scannen eines Computers für den Status der Anschlüsse, die die MOM-Dienst und die zugehörigen Dienste verwenden. Um MOM Resource Kit zu erhalten, die folgende Microsoft-Website:
http://technet.microsoft.com/en-us/opsmgr/bb498240.aspx (http://technet.microsoft.com/en-us/opsmgr/bb498240.aspx)
Der MOM Remote Prerequisite Checker führt eine Reihe von Konnektivitätstests durch. Diese Tests gehören ein Pingtest und einen Test für DNS-Verbindung. Das Dienstprogramm bietet auch Informationen zum Status der Dienste, von denen der MOM-Dienst abhängt. Diese Informationen in einem Berichtsfenster angezeigt werden kann oder in der Momscan.log-Datei gespeichert werden.

Der MOM Remote Prerequisite Checker verwenden möchten, starten Sie MOMNetChk.exe, geben Sie die Computername, und klicken Sie dann auf Run Scan . Wenn Sie die Ergebnisse in einer Protokolldatei speichern möchten, klicken Sie auf Protokolldatei speichern , und geben Sie den Speicherort der Datei. Erweitern Sie die Knoten im linken Bereich des Fensters Dienstprogramm, um die Ergebnisse der Tests anzuzeigen, die ausgeführt wurden.

Hinweis: Das MOMNetChk.exe-Dienstprogramm testet den Status der erforderlichen Netzwerk und Dienstkomponenten. Es meldet keine Fehlermeldungen.

Abhilfe

Warnung Diese Problemumgehung kann Ihren Computer oder Ihr Netzwerk möglicherweise anfälliger, Angriffe durch böswillige Benutzer oder gefährlicher Software wie Viren vornehmen. Zwar wir empfehlen diese Problemumgehung nicht jedoch diese Informationen, damit Sie diese Problemumgehung eigenem Ermessen implementieren können. Verwenden Sie diese Problemumgehung auf eigene Gefahr.

Um dieses Problem zu umgehen, manuell installieren Sie Agent oder konfigurieren Sie der Windows-Firewall für den MOM 2005-Server mit dem Agentcomputer kommunizieren.

Installieren Sie den Agent manuell

Gehen Sie folgendermaßen vor um den Agent manuell zu installieren:
  1. Führen Sie auf dem Zielcomputer-Agent das Setupprogramm von der MOM 2005-Installations-CD.
  2. Klicken Sie im Dialogfeld Microsoft Operations Manager 2005-Setupressourcen auf die Registerkarte Manuelle Agentinstallation .
  3. Klicken Sie auf Installieren von Microsoft Operations Manager 2005-Agent , und befolgen Sie dann die Anweisungen, um den Agent manuell installieren.

Konfigurieren der Windows-Firewall

wichtig Diese Schritte möglicherweise Ihr Sicherheitsrisiko erhöht. Diese Schritte möglicherweise auch Ihr Computer oder Ihr Netzwerk möglicherweise anfälliger für Angriffe durch böswillige Benutzer oder gefährlicher Software wie Viren vornehmen. Wir empfehlen den Prozess, den dieser Artikel, beschreibt damit Programme wie entworfen werden, oder um spezielle Programmfunktionen einzusetzen. Bevor Sie diese Änderungen vornehmen, empfiehlt Microsoft, dass Sie die Risiken abzuschätzen, mit der Implementierung dieser Prozess in Ihrer speziellen Umgebung. Wenn Sie diesen Prozess zu implementieren, sollten Maßnahmen Sie entsprechende treffen, um Ihr System zu schützen. Es wird empfohlen, dass dieser Prozess zu, verwenden nur, wenn dieser Vorgang wirklich erforderlich ist.

Die Windows-Firewall den MOM 2005-Server mit dem Agentcomputer kommunizieren zu konfigurieren, müssen Sie Ports öffnen und aktivieren ein Programm.

Auf Computern, die Windows Server 2003 mit SP1 ausgeführt werden, empfiehlt es sich, dass neue Sicherheitskonfigurations-Assistenten zu, verwenden die Windows-Firewall für MOM 2005 konfiguriert.

Offene ports

Gehen Sie folgendermaßen vor um die Ports öffnen, wenn Windows-Firewall auf dem MOM-Server ausgeführt wird,
  1. Klicken Sie auf Start , zeigen Sie auf Systemsteuerung , klicken Sie mit der rechten Maustaste auf Netzwerkverbindungen und klicken Sie dann auf Öffnen .
  2. Klicken Sie mit der rechten Maustaste auf Ihre LAN-Verbindung, und klicken Sie dann auf Eigenschaften .
  3. Klicken Sie auf der Registerkarte Erweitert auf Einstellungen .
  4. Klicken Sie auf der Registerkarte Dienste auf Hinzufügen .
  5. Geben Sie MOM 2005 TCP , im Feld Beschreibung des Dienstes .
  6. Klicken Sie im nächsten angeben der Computername oder die IP-Adresse des MOM-Server.
  7. Geben Sie im Feld Externe Portnummer für diesen Dienst 1270 .
  8. Geben Sie im Feld Interne Portnummer für diesen Dienst 1270 .
  9. Klicken Sie auf TCP , und klicken Sie dann auf OK .
  10. Klicken Sie auf der Registerkarte Dienste auf Hinzufügen .
  11. Geben Sie MOM 2005 UDP , im Feld Beschreibung des Dienstes .
  12. Klicken Sie im nächsten angeben der Computername oder die IP-Adresse des MOM-Server.
  13. Geben Sie im Feld Externe Portnummer für diesen Dienst 1270 .
  14. Geben Sie im Feld Interne Portnummer für diesen Dienst 1270 .
  15. Klicken Sie auf UDP , und klicken Sie dann auf OK .
  16. Klicken Sie zweimal auf OK .

Ports öffnen und ein Programm aktivieren

Die Ports zu öffnen und ein Programm aktivieren, wenn Windows-Firewall auf dem Zielcomputer-Agent ausgeführt wird, gehen Sie folgendermaßen vor:

wichtig In diesem Abschnitt, Methode oder Aufgabe enthält Hinweise zum Ändern der Registrierung. Allerdings können schwerwiegende Probleme auftreten, wenn Sie die Registrierung falsch ändern. Stellen Sie daher sicher, dass Sie diese Schritte sorgfältig ausführen. Für zusätzlichen Schutz sichern Sie der Registrierung, bevor Sie ihn ändern. Anschließend können Sie die Registrierung wiederherstellen, wenn ein Problem auftritt. Weitere Informationen zum Sichern und Wiederherstellen der Registrierung finden Sie im folgenden Artikel der Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) Zum Sichern und Wiederherstellen der Registrierung in Windows
  1. Klicken Sie auf Start , zeigen Sie auf Systemsteuerung , klicken Sie mit der rechten Maustaste auf Netzwerkverbindungen und klicken Sie dann auf Öffnen .
  2. Klicken Sie mit der rechten Maustaste auf Ihre LAN-Verbindung, und klicken Sie dann auf Eigenschaften .
  3. Klicken Sie auf der Registerkarte Erweitert auf Einstellungen .
  4. Klicken Sie auf der Registerkarte Dienste auf Hinzufügen .
  5. Geben Sie RPC , im Feld Beschreibung des Dienstes .
  6. Klicken Sie im nächsten angeben der Computername oder die IP-Adresse des MOM-Server.
  7. Geben Sie im Feld Externe Portnummer für diesen Dienst 135 .
  8. Geben Sie im Textfeld Interne Portnummer für diesen Dienst 135 ein.
  9. Klicken Sie auf TCP , und klicken Sie dann auf OK .
  10. Klicken Sie auf der Registerkarte Dienste auf Hinzufügen .
  11. Geben Sie SMB über TCP , im Feld Beschreibung des Dienstes .
  12. Klicken Sie im nächsten angeben der Computername oder IP-Adresse des Zielcomputers Agent.
  13. Geben Sie im Feld Externe Portnummer für diesen Dienst 445 .
  14. Geben Sie im Feld Interne Portnummer für diesen Dienst 445 .
  15. Klicken Sie auf TCP , und klicken Sie dann auf OK .
  16. Klicken Sie zweimal auf OK .
  17. Klicken Sie auf Start , klicken Sie auf Ausführen , geben Sie regedit ein und klicken Sie dann auf OK .
  18. Erweitern Sie den HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\DomainProfile\AuthorizedApplications\List Sub Schlüssel.
  19. Klicken Sie mit der rechten Maustaste auf Liste , zeigen Sie auf neu und klicken Sie auf Zeichenfolge .
  20. Geben Sie %systemdrive%\A286B00A-C3DE-414F-A96A-2BD238948D88\MsMgmtAuxiliary.exe als Namen für den neuen Zeichenfolgenwert, und drücken Sie anschließend die [EINGABETASTE].
  21. Doppelklicken Sie auf den Wert %systemdrive%\A286B00A-C3DE-414F-A96A-2BD238948D88\MsMgmtAuxiliary.exe Typ %systemdrive%\A286B00A-C3DE-414F-A96A-2BD238948D88\MsMgmtAuxiliary.exe:*:Enabled:MOM 2005 MsMgmtAuxiliary in den Wert im Feld, und klicken Sie dann auf OK .
  22. Schließen Sie den Registrierungseditor.
Auf Computern, die Windows XP mit SP2 ausgeführt werden, müssen Sie die Registrierung, um ein Programm in der Windows-Firewall zu aktivieren, ändern.

Wenn der MOM-Servercomputer und die MOM-Agent-Computer nicht im selben Subnetz sind, müssen Sie die Einstellung der Bereich für jede Ausnahme auf alle Computer konfigurieren. Wenn der MOM-Servercomputer und die MOM-Agentcomputer nicht im selben Subnetz sind und die Einstellung Bereich wird zu Subnetz nur festgelegt, wird Windows-Firewall Kommunikation blockiert. Wenn alle MOM-Komponenten auf demselben Subnetz befinden, beschränken Sie den Netzwerkzugriff noch mehr durch Konfigurieren der Einstellung Bereich Subnetz nur außerdem Netzwerkzugriff einschränken.

Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Operations Manager 2005 Enterprise Edition
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 885726  (http://support.microsoft.com/kb/885726/en-us/ )
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