Información importante que debe saber acerca de las actualizaciones de seguridad MS04-028 si está utilizando Windows XP Service Pack 2

Seleccione idioma Seleccione idioma
Id. de artículo: 885876 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Resumen

El 832332 (Microsoft Office XP), 831932 (Microsoft Visio 2002), o 831931 Este boletín de seguridad de Microsoft de actualizaciones de seguridad de (Microsoft Project 2002) MS04-028 Describe mayo parece que se instalan correctamente en Microsoft Windows XP Service Pack 2 (SP2)-equipo basado en. Sin embargo, las versiones originales de estas actualizaciones se publicaron el 14 de septiembre de 2004 pueden no terminen de instalar correctamente si anteriormente ha instalado alguna de las actualizaciones de software para Office XP, Visio 2002 o Microsoft Project 2002 que se documentan en el artículo de Microsoft Knowledge Base 886992.

Para resolver este problema:
  • Instale la actualización crítica 885884 mediante la característica Actualizaciones automáticas o el sitio Web de Microsoft Windows Update.
  • Instalar las versiones revisadas de las actualizaciones de seguridad 832332, 831932 o 831931 publicadas el 12 de octubre de 2004 de la Actualización de Office Sitio Web.
En este artículo también incluye métodos alternativos que los usuarios avanzados y profesionales de TI pueden utilizar para resolver este problema o para determinar si los equipos cliente se ven afectados por este problema.

Síntomas

Pueden aparecer las siguientes actualizaciones de seguridad instalar correctamente en el Windows XP Service Pack 2 (SP2)-equipo basado en:
Contraer esta tablaAmpliar esta tabla
Artículo KBNombre del paquete de actualización de seguridad de 14 de septiembre de 2004
832332Officexp-kb832332-client-esn, Officexp-kb832332-fullfile-enu
831932Visio2002-KB831932-FullFile-ENU
831931Project2002-kb831931-fullfile-enu
Sin embargo, la instalación de las versiones originales de estas actualizaciones publicadas el 14 de septiembre de 2004, puede actualizar correctamente el archivo Mso.dll en la carpeta %ArchivosPrograma%\Archivos comunes\Microsoft Shared\Office10. Consulte la "Cómo determinar si se ven afectados"sección para determinar si le afecta este problema.

Nota Este problema sólo afecta a las actualizaciones de seguridad original que se publicaron 14 De septiembre de 2004. Los paquetes de actualización de seguridad original que se ven afectados por este problema se llaman Officexp-kbnúmero-tipo de archivo-localización.exe. Por ejemplo, el paquete de actualización de seguridad de cliente en inglés original de seguridad 832332 se denomina Officexp-kb832332-client-enu.exe.

El 12 de octubre de 2004, 832332, 831932 y 831931 actualizaciones de seguridad se han vuelto a publicar para tratar el problema que se describe en este artículo. Las actualizaciones nuevamente publicadas que resuelven este problema se llaman Officexp-kbnúmero-v2-tipo de archivo-localizaciónV2.exe. por ejemplo, el paquete de la nueva actualización de seguridad 832332 se denomina Officexp-kb832332-v2-client-enu.exe.

Causa

Este problema se produce si anteriormente ha instalado uno de los actualizaciones de software para Office XP, Visio 2002 o Microsoft Project 2002 que se documentan en el artículo de Microsoft Knowledge Base 886992 en un equipo basado en Windows XP SP2.

Nota Las siguientes actualizaciones de software publicada de amplia distribución pueden ocasionar esto problema:
833858 Descripción de la actualización de Office XP: 23 de marzo de 2004
831931 Descripción de la actualización de seguridad de Microsoft Project 2002: 12 de octubre de 2004
832668 Actualización de entrada de usuario de Office XP alternativa: 9 de noviembre de 2004
831932 Descripción de la actualización de seguridad de Visio 2002: 12 de octubre de 2004
830241 Descripción de Microsoft Project 2002 Service Pack 1

Solución

Usuarios de equipo único

Si su equipo no se ha actualizado correctamente, tiene las siguientes opciones:
  • Puede instalar la actualización revisada. Para ello, utilice el método que se describe en la sección "Actualizaciones automáticas o Windows Update" o el método que se describe en la sección "Actualización de Office".
  • Puede reparar Office. Para ello, siga las instrucciones que se encuentran en la sección "Reparar Office".

Actualizaciones automáticas o Windows Update

Para resolver este problema, utilice la característica Actualizaciones automáticas o utilizar el sitio Web de Windows Update para instalar la actualización crítica 885884.

Para obtener información adicional acerca de cómo configurar la característica Actualizaciones automáticas en Windows XP, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
306525Cómo configurar y utilizar actualizaciones automáticas en Windows XP


Para instalar esta actualización desde el sitio Web de Windows Update, siga estos pasos:
  1. Visite el siguiente sitio Web de Microsoft:
    http://Update.Microsoft.com/
  2. Haga clic en Instalación rápida (recomendada).
  3. Si el equipo se ve afectado por este problema, la actualización crítica 885884 se selecciona automáticamente para que su instalación. Haga clic en Instalar.
  4. Revisar y aceptar el contrato de licencia de usuario final (CLUF).
Actualización crítica 885884 se descargará a su equipo y el Asistente para instalación le ayudará a instalarlo.Para obtener información adicional acerca de la crítica 885884 actualización, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
885884Descripción de la actualización crítica para Office XP en Windows XP Service Pack 2

Actualización de Office

Para resolver este problema, instale el revisadas 832332, 831932 o 831931 actualizaciones de seguridad desde el sitio Web de Office Update. Para ello, siga estos pasos:
  1. Visite el siguiente sitio Web de Microsoft:
    http://officeupdate.Microsoft.com
  2. Haga clic en Buscar actualizaciones.

    La actualización de Office Sitio Web examina su equipo las actualizaciones instaladas.
  3. Si se ven afectados por este problema, se mostrarán las actualizaciones nuevamente publicadas en la sección "Actualizaciones de Office XP".
  4. Haga clic en Iniciar instalacióny, a continuación, siga las instrucciones que aparecen en pantalla para instalar las actualizaciones de seguridad nuevamente publicadas pertinentes.

Reparar Office

Para resolver este problema, repare la instalación de Office XP. Para ello, siga estos pasos:
  1. Haga clic en Inicio, haga clic en Ejecutar, tipo appwiz.cpl en el Abierto cuadro y, a continuación, presione ENTRAR.
  2. Haga clic en Cambiar o quitar programas.
  3. En la lista de programas actualmente instalados, haga clic en el producto Microsoft Office XP, Microsoft Project 2002 o Microsoft Visio 2002 en la lista de productos instalados.
  4. Haga clic en Haga clic aquí para obtener información de soporte técnico.
  5. Haga clic en Reparación.

    Nota Si instaló el producto Office XP desde un CD-ROM, puede le pedirá el CD-ROM durante el proceso de detectar y reparar. Si ha instalado el producto de Office desde un recurso compartido de red y el recurso compartido de red no está disponible durante el proceso de detectar y reparar, se le puede para la ubicación del recurso de red que contiene la instalación de Microsoft Office archivos de origen.
  6. Si se le pida que reinicie el equipo, haga clic en .

Clientes empresariales

Para resolver este problema, utilice uno de los métodos siguientes.

Nota Le recomendamos que utilice el método que se describe en la sección "Instalar había revisado las actualizaciones de seguridad".

Instalar actualizaciones de seguridad revisadas

Para resolver este problema, instale la versión revisada de las actualizaciones de seguridad afectado que estén asociados con MS04-028, publicado el 12 de octubre de 2004, mediante el uso de la Actualización de Office Sitio Web o descargando e instalando las actualizaciones adecuadas desde el centro de descarga de Microsoft:

Instale la actualización crítica 885884

Para resolver este problema, instale la actualización crítica 885884.

Para obtener información adicional acerca de la actualización crítica 885884, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
885884Descripción de la actualización crítica para Office XP en Windows XP Service Pack 2

Software Update Services (SUS) también se puede utilizar para implementar la actualización crítica 885884. SUS permite que los usuarios instalen un servicio que puede descargar todas las actualizaciones críticas, actualizaciones de seguridad y service packs conforme se publican en el siguiente sitio Web de Microsoft Windows Update:
http://www.Update.Microsoft.com/microsoftupdate/v6/default.aspx
Cuando los administradores aprueban estas actualizaciones, SUS será automáticamente pone a disposición todos los servidores preconfigurados que ejecutan Microsoft Windows Server 2003 y Microsoft Windows 2000 y a los escritorios que ejecutan Microsoft Windows XP Professional y Microsoft Windows 2000 Professional.

Para obtener más información acerca de los servicios de actualización de Software y servicios de Windows Update, la próxima generación de Software Update services, visite el siguiente sitio Web de Microsoft:
http://technet.Microsoft.com/en-US/WSUS/bb466186.aspx

La actualización de MS04-028 herramientas de análisis

Los profesionales de TI pueden utilizar alguna de las actualizaciones de MS04-028 herramientas de análisis para examinar los equipos para las actualizaciones de seguridad MS04-028 y aplicar las actualizaciones que faltan desde un recurso compartido de red de área local. La herramienta se puede ejecutar desde una secuencia de comandos de inicio de sesión o un usuario que tenga derechos de administrador local. Hay dos versiones de esta herramienta:
  • Una versión está destinada para su uso en entornos donde no se utiliza Systems Management Server (SMS) o cualquier otra solución de administración empresarial para la administración de actualizaciones.

    Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
    886988Cómo obtener y utilizar la herramienta de análisis de MS04-028 Enterprise Update en entornos que no utilice Systems Management Server
  • Una versión está destinada a uso en entornos donde se utiliza SMS para la administración de actualizaciones.

    Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
    885920Cómo obtener y utilizar la herramienta de análisis de MS04-028 Enterprise Update en entornos que usan Systems Management Server 2003 y Systems Management Server 2.0

Reparar Office

Para resolver este problema, repare la instalación de Office XP. Para ello, siga estos pasos:
  1. Haga clic en Inicio, haga clic en Ejecutar, tipo appwiz.cpl en el Abierto cuadro y, a continuación, presione ENTRAR.
  2. Haga clic en Cambiar o quitar programas.
  3. En la lista de programas actualmente instalados, haga clic en el producto de Office XP, Microsoft Project 2002 o Microsoft Visio 2002 en la lista de productos instalados.
  4. Haga clic en Haga clic aquí para obtener información de soporte técnico.
  5. Haga clic en Reparación.

    Nota Si instaló el producto Office XP desde un CD-ROM, puede le pedirá el CD-ROM durante el proceso de detectar y reparar. Si ha instalado el producto de Office desde un recurso compartido de red y el recurso compartido de red no está disponible durante el proceso de detectar y reparar, se le puede para la ubicación del recurso de red que contiene los archivos de origen de la instalación de Office.
  6. Si se le pida que reinicie el equipo, haga clic en .
Si es administrador y no desea volver a instalar la versión revisada de las actualizaciones de MS04-028 de forma individual, puede utilizar el VUELVA A INSTALAR =NombreDeFunción> comando. Utilice el método siguiente si es administrador y utilizar el comando Msiexec.exe para instalar las actualizaciones.

Nota No utilice este método si va a actualizar una imagen administrativa, o si va a actualizar un punto de instalación administrativa.

Los siguientes son ejemplos de las líneas de comandos que puede utilizar para reparar productos de Microsoft Office específicos mediante la Msiexec.exe /I {GUID producto} VUELVA A INSTALAR =NombreDeFunción> comando:

Para Microsoft Office 2003 (todos los productos), Microsoft Office Project 2003 y Microsoft Office de Visio 2003, utilizan la siguiente línea de comandos:
Msiexec /i {GUID producto} REINSTALL = ProductNonBootFiles REINSTALLMODE = omu / qb /
Para Office XP (todos los productos), Microsoft Project 2002 y Microsoft Visio 2002, utilice la siguiente línea de comando:
Msiexec /i {GUID producto} REINSTALL = ProductFiles REINSTALLMODE = omu / qb /
Notas
  • El NombreDeFunción o ArchivosProducto distinguen entre mayúsculas y minúsculas. Para instalar todas las características, puede utilizar el REINSTALL = ALL valor, o bien puede instalar sólo la característica que se actualiza.
  • En estos comandos, GUID del producto es el GUID para su producto de Office 2003 u Office XP. Por ejemplo, {90110409-6000-11D3-8CFE-0150048383C9} es el GUID para nosotros Microsoft Office inglés 2003 Professional Enterprise Edition. Como referencia, los artículos siguientes proporcionan información sobre el esquema de numeración para cada producto de Office 2003 y Office XP.

    Para obtener información adicional, haga clic en los números de artículo siguientes para verlos en Microsoft Knowledge Base:
    832672Descripción de la numeración los GUID de código de esquema para el producto en Office 2003
    302663 Descripción del esquema de numeración para los GUID de código de producto para los programas de Office XP
Puede utilizar la línea de comandos para instalar todas las actualizaciones en un archivo por lotes que puede ejecutar en el equipo de destino, o como parte de una secuencia de comandos de inicio de sesión SMS cuando el usuario inicia sesión en el equipo.


Más información

Si no está ejecutando el Service Pack 2 de Windows XP, este problema no le afectará. Si está ejecutando el Service Pack 2 de Windows XP, utilice uno de los métodos de esta sección para determinar si se ven afectados por este problema:

Utilizar Microsoft Baseline Security Analyzer (MBSA)

Utilice MBSA para determinar si las actualizaciones revisadas (832332, 831932 y 831931) están instaladas en los equipos cliente para sólo el análisis del equipo local. Para obtener información detallada acerca de cómo MBSA detecta las actualizaciones de Office, visite el siguiente sitio Web de Microsoft:
http://technet.Microsoft.com/en-us/library/dd277352.aspx
Para obtener información adicional acerca de los programas que MBSA no detecta, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
306460Microsoft Baseline Security Analyzer (MBSA) devuelve mensajes de notas para algunas actualizaciones


Para obtener más información acerca de MBSA y para obtener MBSA, visite el siguiente sitio Web de Microsoft:
http://technet.Microsoft.com/en-US/Security/cc184924.aspx

Compruebe la versión del archivo Mso.dll

Las actualizaciones afectadas no instalan la versión correcta de la Archivo Mso.dll. Por lo tanto, puede determinar se ven afectados por este problema comprobando manualmente la versión del archivo Mso.dll en la carpeta %ArchivosPrograma%\Archivos comunes\Microsoft Shared\Office10. Para ello, siga estos pasos:
  1. Haga clic en Inicio, haga clic en Ejecutar, tipo %ProgramFiles%\Archivos comunes\Microsoft Shared\Office10y, a continuación, haga clic en ACEPTAR.
  2. (Ratón) en el Mso.dll archivo y, a continuación, haga clic enPropiedades.
  3. En el Versión ficha, tenga en cuenta el número de versión del archivo Mso.dll. Si el número de versión no es 10.0.6714.0 o una versión posterior, puede estar afectado por este problema.

Propiedades

Id. de artículo: 885876 - Última revisión: lunes, 28 de mayo de 2012 - Versión: 1.0
La información de este artículo se refiere a:
  • Microsoft Project 2002 Professional
  • Microsoft Visio 2002 Professional Edition
  • Microsoft Visio 2002 Standard Edition
  • Microsoft Office XP Professional Edition
  • Microsoft Office XP Small Business Edition
  • Microsoft Office XP Standard Edition
  • Microsoft Office XP Developer Edition
  • Microsoft Access 2002 Standard Edition
  • Microsoft Excel 2002 Standard Edition
  • Microsoft FrontPage 2002 Standard Edition
  • Microsoft Outlook 2002 Standard
  • Microsoft PowerPoint 2002 Standard Edition
  • Microsoft Word 2002 Standard Edition
Palabras clave: 
kbsecurity kbtshoot kbmt KB885876 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 885876

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com