Windows XP Service Pack 2 を使用している場合に知っておく必要のある、セキュリティ更新プログラム MS04-028 に関する重要な情報

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文書番号: 885876 - 対象製品
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目次

概要

マイクロソフト セキュリティ情報 MS04-028 に記載されている、セキュリティ更新プログラム 832332 (Microsoft Office XP)、831932 (Microsoft Visio 2002)、または 831931 (Microsoft Project 2002) は、Microsoft Windows XP Service Pack 2 (SP2) ベースのコンピュータに正常にインストールされるように見えます。しかし、2004 年 9 月 14 日にリリースされた、これらの更新プログラムのオリジナル版は、「サポート技術情報」 (Microsoft Knowledge Base) の資料 886992 に記載されている、Office XP、Visio 2002、または Microsoft Project 2002 用のいずれかの ソフトウェア更新プログラムを以前にインストールしている場合、インストールが正常に完了しない場合があります。

この問題を解決するには、以下の手順を実行します。
  • 重要な更新プログラム 885884 を、自動更新機能または Microsoft Windows Update Web サイトを使用してインストールします。
  • 2004 年 10 月 12 日にリリースされた、セキュリティ更新プログラム 832332、831932、または 831931 の改訂版を Office ダウンロード Web サイトからインストールします。
この資料では、詳しい知識のあるユーザーや IT 担当者が、この問題を解決する場合や、コンピュータがこの問題の影響を受けているかどうかを確認する場合に使用できる方法についても説明します。

現象

次の表に記載されているセキュリティ更新プログラムは、Windows XP Service Pack 2 (SP2) ベースのコンピュータに正常にインストールされるように見えます。
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文書番号 セキュリティ更新プログラム (2004 年 9 月 14 日) のパッケージ名
832332 officexp-kb832332-v2-client-jpn.exe、officexp-kb832332-v2-fullfile-jpn.exe
831932 Visio2002-KB831932-v2-FullFile-JPN.EXE
831931 project2002-KB831931-v2-FullFile-JPN.EXE
しかし、2004 年 9 月 14 日にリリースされた、これらの更新プログラムのオリジナル版をインストールしても、%Programfiles%\Common Files\Microsoft Shared\Office10 フォルダにある、Mso.dll ファイルが正常に更新されない場合があります。使用しているコンピュータでこの問題が発生しているかどうかを確認するには、この資料の「詳細」を参照してください。

: この問題が発生するのは、2004 年 9 月 14 日にリリースされたオリジナル版のセキュリティ更新プログラムのみです。この問題が発生するオリジナル版のセキュリティ更新プログラムには、Officexp-kbnumber-filetype-localization という形式の名前が付いています。たとえば、セキュリティ更新プログラム 832332 用のオリジナルの日本語版のクライアント用セキュリティ更新プログラムの名前は、Officexp-kb832332-client-jpn.exe です。

この資料に記載されている問題を解決するため、2004 年 10 月 12 日にセキュリティ更新プログラム 832332、831932、および 831931 が再リリースされました。この問題を解決する、再リリース版の更新プログラムの名前は、Officexp-kbnumber-v2-filetype-localizationv2.exe という形式です。たとえば、セキュリティ更新プログラム 832332 の再リリース版の更新プログラム パッケージ (日本語版) の名前は、Officexp-kb832332-v2-client-jpn.exe です。

原因

この問題は、Windows XP SP2 ベースのコンピュータに、「サポート技術情報」 (Microsoft Knowledge Base) の資料 886992 に記載されている、Office XP、Visio 2002、または Microsoft Project 2002 用のいずれかの ソフトウェア更新プログラムを以前にインストールした場合に発生します。

: これまでにリリースされた以下のさまざまなソフトウェア更新プログラムで、この問題が発生する場合があります。
833858 Office XP アップデートについて (2004 年 3 月 23 日)
831931 Microsoft Project 2002 セキュリティ更新プログラム (2004 年 10 月 12 日) の詳細
832668 Office XP 入力システム更新プログラム (2004 年 11 月 10 日)
831932 Visio 2002 セキュリティ更新プログラム (2004 年 10 月 12 日) の詳細
830241 Microsoft Project 2002 Service Pack 1 について

解決方法

コンピュータを単独で使用している場合

コンピュータを正しく更新していない場合には、次の方法のいずれかを使用できます。
  • 改訂版の更新プログラムをインストールする方法。この作業を行うには、「自動更新または Windows Update を使用する」で説明している方法を使用するか、「Office ダウンロード サイトを使用する」で説明している方法を使用します。
  • Office を修復する方法。この作業を行うには、「Office を修復する」で説明している手順を実行します。

自動更新または Windows Update を使用する

この問題を解決するには、自動更新機能または Windows Update Web サイトを使用して、重要な更新プログラム 885884 をインストールします。

Windows XP における自動更新の構成方法の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
306525 Windows XP での自動更新の構成方法および使用方法


Windows Update Web サイトからこの更新プログラムをインストールするには、以下の手順を実行します。
  1. 次のマイクロソフト Web サイトにアクセスします。
    http://update.microsoft.com/
  2. [高速インストール (推奨)] をクリックします。
  3. 使用しているコンピュータがこの問題の影響を受けている場合、重要な更新プログラム 885884 は自動的にインストール対象として選択されます。[インストール] をクリックします。
  4. 使用許諾契約書 (EULA) を確認して、契約に同意します。
重要な更新プログラム 885884 がコンピュータにダウンロードされます。セットアップ ウィザードに従ってインストールを実行します。 重要な更新プログラム 885884 の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
885884 Windows XP Service Pack 2 用 Office XP の重要な更新プログラムについて

Office ダウンロード サイトを使用する

この問題を解決するには、セキュリティ更新プログラム 832332、831932、または 831931 の改訂版を Office ダウンロード Web サイトからインストールします。これを行うには、次の手順を実行します。
  1. 次のマイクロソフト Web サイトにアクセスします。
    http://officeupdate.microsoft.com
  2. [アップデートの確認] をクリックします。

    Office ダウンロード Web サイトにより、コンピュータにインストールされている更新プログラムの確認が行われます。
  3. 使用しているコンピュータでこの問題が発生している場合、再リリース版の更新プログラムが "Office XP 製品用のアップデート" の一覧に表示されます。
  4. [同意してインストールを開始] をクリックし、画面に表示される指示に従って、適切な再リリース版のセキュリティ更新プログラムをインストールします。

Office を修復する

この問題を解決するには、インストールしている Office XP を修復します。これを行うには、次の手順を実行します。
  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。[名前] ボックスに appwiz.cpl と入力し、Enter キーを押します。
  2. [プログラムの変更と削除] をクリックします。
  3. 現在インストールされているプログラムの一覧で、[Microsoft Office XP]、[Microsoft Project 2002]、または [Visio 2002] をクリックします。
  4. [サポート情報を参照するには、ここをクリックしてください] をクリックします。
  5. [修復] をクリックします。

    : Office XP 製品を CD-ROM からインストールしていた場合、アプリケーションの自動修復中に、CD-ROM の挿入を求められることがあります。Office 製品をネットワーク共有からインストールしていて、アプリケーションの自動修復中に、ネットワーク共有が使用できない場合、使用している Microsoft Office のインストール元のファイルが格納されているネットワーク リソースの場所を指定するように求められることがあります。
  6. コンピュータを再起動するかどうかを確認する画面が表示されたら、[はい] をクリックします。

企業内でコンピュータを使用している場合

この問題を解決するには、以下のいずれかの手順を実行します。

: 以下の「改訂版のセキュリティ更新プログラムをインストールする」に記載されている方法を使用することをお勧めします。

改訂版のセキュリティ更新プログラムをインストールする

この問題を解決するには、セキュリティ情報 MS04-028 に記載されているセキュリティ更新プログラムの改訂版 (2004 年 10 月 12 日公開) をインストールします。これを行うには、Office ダウンロード Web サイトを使用するか、Microsoft ダウンロード センターから適切な更新プログラムをダウンロードして、インストールします。

重要な更新プログラム 885884 をインストールする

この問題を解決するには、重要な更新プログラム 885884 をインストールします。

重要な更新プログラム 885884 の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
885884 Windows XP Service Pack 2 用 Office XP の重要な更新プログラムについて

Software Update Services (SUS) を使用して、重要な更新プログラム 885884 を展開することもできます。SUS を使用すると、次の Microsoft Windows Update Web サイトで公開されるすべての重要な更新プログラム、セキュリティ更新プログラム、および Service Pack をダウンロードするサービスをインストールできます。
http://update.microsoft.com/
管理者がこれらの更新プログラムを承認すると、SUS により、事前に構成された Microsoft Windows Server 2003 または Microsoft Windows 2000 を実行しているサーバーおよび Microsoft Windows XP Professional または Microsoft Windows 2000 Professional を実行しているデスクトップでこれらのプログラムが自動的に利用できるようになります。

Software Update Services および Windows Update サービス、次世代の Software Update Services の詳細については、次のマイクロソフト Web サイトを参照してください。
http://www.microsoft.com/japan/windowsserversystem/sus/default.mspx

MS04-028 Update Scanning Tool を使用する

IT 担当者は、MS04-028 Update Scanning Tool を使用してコンピュータをスキャンし、必要な MS04-028 セキュリティ更新プログラムが適用されているかどうかを確認し、未適用の更新プログラムを、ローカル エリア ネットワーク共有から適用します。このツールは、スタートアップまたはログオン スクリプトから実行するか、ローカル管理者の権限を持つユーザーが実行できます。このツールには、2 つのバージョンがあります。
  • 1 つは、更新プログラムの管理に、Systems Management Server (SMS) などのエンタープライズ管理ソリューションを使用していない環境で使用するためのバージョンです。

    関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
    886988 MS04-028 Enterprise Update Scanning Tool の入手方法および Systems Management Server が使用されていない環境での使用方法
  • もう 1 つは、更新プログラムの管理に SMS を使用している環境で使用するためのバージョンです。

    関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
    885920 MS04-028 Enterprise Update Scanning Tool の入手方法および Systems Management Server 2003 と Systems Management Server 2.0 を使用している環境での使用方法

Office を修復する

この問題を解決するには、インストールしている Office XP を修復します。これを行うには、次の手順を実行します。
  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。[名前] ボックスに appwiz.cpl と入力し、Enter キーを押します。
  2. [プログラムの変更と削除] をクリックします。
  3. 現在インストールされているプログラムの一覧で、Office XP、Microsoft Project 2002、または Visio 2002 製品をクリックします。
  4. [サポート情報を参照するには、ここをクリックしてください] をクリックします。
  5. [修復] をクリックします。

    : Office XP 製品を CD-ROM からインストールしていた場合には、アプリケーションの自動修復中に、CD-ROM の挿入を求められることがあります。Office 製品をネットワーク共有からインストールしていて、アプリケーションの自動修復中に、ネットワーク共有が使用できない場合、使用している Office のインストール元のファイルが格納されているネットワーク リソースの場所を指定するように求められることがあります。
  6. コンピュータを再起動するかどうかを確認する画面が表示されたら、[はい] をクリックします。
更新プログラム MS04-028 の改訂版が個別に再インストールされることを回避するには、REINSTALL=<FeatureName> コマンドを使用します。管理者が Msiexec.exe コマンドを使用して更新プログラムをインストールするには、次の方法を使用します。

: 管理者用イメージを更新している場合、または管理者用インストール ポイントを更新する場合には、この方法を使用しないでください。

Msiexec.exe /I {Product GUID} REINSTALL=<FeatureName> コマンドを使用して、特定の Microsoft Office 製品を修復する場合の例を以下に示します。

Microsoft Office 2003 (すべての製品)、Microsoft Office Project 2003、および Microsoft Office Visio 2003 の場合は、次のコマンド ラインを使用します。
Msiexec /i {Product GUID} REINSTALL=ProductNonBootFiles REINSTALLMODE=omu /qb-
Office XP (すべての製品)、Microsoft Project 2002、および Visio 2002 の場合は、次のコマンド ラインを使用します。
Msiexec /i {Product GUID} REINSTALL=ProductFiles REINSTALLMODE=omu /qb-
注意事項
  • FeatureName および ProductFiles では大文字と小文字が区別されます。すべての機能をインストールするには、値に REINSTALL=ALL を指定します。すべての機能をインストールせずに、更新された機能のみをインストールすることもできます。
  • これらのコマンドで、Product GUID には、使用している Office 2003 または Office XP 製品の GUID を指定します。たとえば、{90110409-6000-11D3-8CFE-0150048383C9} は、Microsoft Office 2003 Professional Enterprise Edition 英語版 (米国) の GUID です。この番号については、以下の「サポート技術情報」 (Microsoft Knowledge Base) に記載されている、Office 2003 および Office XP の各製品の番号付けのしくみの説明を参考にしてください。

    関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
    832672 Office 2003 における製品コード GUID の番号付けのしくみ
    302663 [OFFXP] 製品コード GUID の番号付けの仕組み
このコマンド ラインを、対象のコンピュータで実行するバッチ ファイルで使用するか、ユーザーがコンピュータにログオンするときに実行される SMS ログオン スクリプトで使用して、すべての更新プログラムをインストールすることができます。


詳細

Windows XP SP2 を実行していない場合、この問題は発生しません。Windows XP SP2 を実行している場合は、以下の方法を使用して、使用しているコンピュータでこの問題が発生しているかどうかを確認する必要があります。

Microsoft Baseline Security Analyzer (MBSA) を使用する

MBSA を使用して、改訂版の更新プログラム (832332、831932、および 831931) がクライアント コンピュータにインストールされているかどうかを確認します (ローカル コンピュータ スキャンのみ)。MBSA で Office 更新プログラムが検出されるしくみの関連情報については、次のマイクロソフト Web サイトを参照してください。
http://office.microsoft.com/ja-jp/assistance/HA010884161041.aspx
MBSA で検出されないプログラムの関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
306460 Microsoft Baseline Security Analyzer (MBSA) で一部の更新について注意が表示される


MBSA の詳細および MBSA の入手方法については、次のマイクロソフト Web サイトを参照してください。
http://www.microsoft.com/japan/technet/security/tools/mbsahome.mspx

Mso.dll ファイルのバージョンを確認する

この問題が発生する更新プログラムでは、適切なバージョンの Mso.dll ファイルがインストールされません。このため、%Programfiles%\Common Files\Microsoft Shared\Office10 フォルダの Mso.dll ファイルのバージョンを手動で確認することにより、この問題が発生しているかどうかを確認できます。これを行うには、次の手順を実行します。
  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。[名前] ボックスに %Programfiles%\Common Files\Microsoft Shared\Office10 と入力し、[OK] をクリックします。
  2. [Mso.dll] ファイルを右クリックし、[プロパティ] をクリックします。
  3. [バージョン情報] タブで Mso.dll ファイルのバージョン番号を確認します。バージョン番号が 10.0.6714.0 より古い場合は、この資料に記載されている問題が発生している可能性があります。

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 885876 (最終更新日 2004-10-28) を基に作成したものです。

プロパティ

文書番号: 885876 - 最終更新日: 2012年4月5日 - リビジョン: 3.1
この資料は以下の製品について記述したものです。
  • Microsoft Project Professional Version 2002
  • Microsoft Visio Professional Version 2002
  • Microsoft Visio Standard Version 2002
  • Microsoft Office XP Professional
  • Microsoft Office XP Small Business Edition
  • Microsoft Office XP Standard
  • Microsoft Office XP Developer Edition
  • Microsoft Access 2002 Standard Edition
  • Microsoft Excel 2002 Standard Edition
  • Microsoft FrontPage 2002 Standard Edition
  • Microsoft Outlook 2002 Standard Edition
  • Microsoft PowerPoint 2002 Standard Edition
  • Microsoft Word 2002
キーワード:?
kbsecurity kbtshoot KB885876
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

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