An ODBC query through Microsoft Access or MSQuery fails with Host Integration Server ODBC for DB2 driver

Article translations Article translations
Article ID: 885931 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

When you try to perform a query to a linked table view in Microsoft Host Integration Server 2000 ODBC for DB2 driver from Microsoft Access, you may receive the following error message:
ODBC--call failed.
[Microsoft][ODBC DB2 Driver] Invalid string or buffer length. (#0)
When you try to perform a query to a linked table view in Microsoft Host Integration Server ODBC for DB2 driver in MSQuery from Microsoft Excel, you may receive the following error message:
Column not found.
Original SQLSTATE was 42703.

CAUSE

This problem occurs because of invalid table name lengths. The table name length is limited to 18 characters, but Microsoft Access and MSQuery add wildcard characters to the table names. These wildcard characters make the table name longer than 18 characters. To resolve the problem, an exception case has been added so that the table name can be longer than 18 characters if it contains one or more wildcard characters.

RESOLUTION

Host Integration Server 2000

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Host Integration Server 2000. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
328152 How to obtain the latest service pack for Host Integration Server 2000

Hotfix information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
  Date         Time   Version            Size    File name
   --------------------------------------------------------------
   29-Sep-2004  21:44  5.0.0.1003        311,568  Crtpkg.dll
   29-Sep-2004  21:44  5.0.0.1003        700,688  Db2oledb.dll
   29-Sep-2004  21:44  5.0.0.1003         53,552  Ddmstr.dll
   29-Sep-2004  21:44  5.0.0.1003         78,096  Mseidb2c.dll
   29-Sep-2004  21:44  5.0.0.1003        889,104  Mseidb2d.dll
   29-Sep-2004  21:44  5.0.0.1003         24,848  Mseidpm.dll
   29-Sep-2004  21:44  5.0.0.1003        270,608  Mseidrda.dll
   29-Sep-2004  21:44  5.0.0.1003        147,728  Mseidt.dll
   29-Sep-2004  21:44  5.0.0.1003         65,808  Crtpkg.exe
   29-Sep-2004  21:44  5.0.0.1003         82,192  Ddmserv.exe


				

Note Because of file dependencies, the most recent fix that contains these files may also contain additional files.

Host Integration Server 2004

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   29-Sep-2004  22:43  6.0.1906.0        486,400  Db2oledb.dll
   29-Sep-2004  22:42  6.0.1906.0         71,168  Mseidb2c.dll
   29-Sep-2004  22:43  6.0.1906.0        435,200  Mseidb2d.dll
   29-Sep-2004  22:43  6.0.1906.0         20,992  Mseidpm.dll
   29-Sep-2004  22:43  6.0.1906.0        682,496  Mseidrda.dll


				

Note Because of file dependencies, the most recent fix that contains these files may also contain additional files.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

This problem was corrected in Microsoft Host Integration Server 2000 Service Pack 2.

Properties

Article ID: 885931 - Last Review: December 4, 2007 - Revision: 2.5
APPLIES TO
  • Microsoft Host Integration Server 2000 Standard Edition
  • Microsoft Host Integration Server 2000 Service Pack 1
  • Microsoft Host Integration Server 2004 Standard Edition
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbfix kbbug KB885931

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com