Windows XP'DEN bir eşlenen ağ paylaşımına kaydedilen dosyaları bozuk

Makale çevirileri Makale çevirileri
Makale numarası: 885936 - Bu makalenin geçerli olduğu ürünleri görün.
Hepsini aç | Hepsini kapa

Bu Sayfada

Belirtiler

Windows tabanlı bir sunucuda bir ağ paylaşımına Microsoft Windows XP tabanlı bir bilgisayardan bir dosyayı kaydetmeye çalıştığınızda, kaydedilen dosya bozulmuş olabilir. Tipik olarak kaydedilen dosyanın yerine, beklenen veri dosyasının sonuna sıfırları içerir.

Neden

Yazma önbelleği için işaretli bir dosya bellek eşleyen bir program kullandığınızda bu sorun ortaya çıkabilir ve programdan alınan bir kümesi dosya sonu. Bu sorun, dosyayı kaydetmek için kullandığınız istemci bilgisayar için aşağıdaki koşullardan biri doğruysa oluşur:
  • Windows XP Service Pack 2 yüklü.
  • Aşağıdaki Microsoft Bilgi Bankası makalesinde açıklanan düzeltme yüklüdür:
    811169 Ağ Yeniden Yönlendiricisinin Performansını Artırmaya Yönelik Güncelleştirme
Bu senaryoda, önbellek aktarılmadan önce dosyayı görünümünü bağlanılmayan değil.

Pratik Çözüm

Bu soruna geçici bir çözüm bulmak için <a0></a0>, dosyayı kaydettiğiniz sunucuda fırsatçı kilitleri devre dışı bırakın. Bunu yapmak için <a0></a0>, aşağıdaki kayıt defteri alt anahtarında "0" EnableOplocks kayıt defteri değerine ayarlayın:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters
Bunu yapmak için şu adımları izleyin:
  1. Başlat ' ı tıklatın, Çalıştır ' ı tıklatın, regedit yazın ve ENTER tuşuna basın.
  2. Aşağıdaki kayıt defteri alt anahtarını bulup tıklatın:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters
  3. EnableOplocks değeri sağdaki bölmede yoksa, oluşturmalısınız. Bunu yapmak için şu adımları izleyin:
    1. Parametreler, sol bölmede sağ tıklatın, Yeni ' nin üzerine gidin ve DWORD değeri ' ni tıklatın.
    2. EnableOplocks değeri adlandırın ve ENTER tuşuna basın) yazın.
  4. EnableOplocks ' ı sağ tıklatın ve sonra Değiştir ' i tıklatın.
  5. Değer verisi kutusuna, 0 yazın ve ENTER tuşuna basın.
  6. Kayıt Defteri Düzenleyicisi'nden çıkın.

Çözüm

Düzeltme bilgileri

Desteklenen bir düzeltme Microsoft'tan edinilebilir. Ancak bu düzeltmenin, yalnızca bu makalede anlatılan sorunu gidermesi amaçlanmıştır. Bu düzeltmeyi yalnızca bu sorunla karşılaşan sistemlere uygulayın. Bu düzeltme ek sınamaya tabi olabilir. Bu nedenle, bu sorun nedeniyle önemli ölçüde etkilenmediyseniz, bu düzeltmeyi içeren bir sonraki yazılım güncelleştirmesini beklemeniz önerilir.

Düzeltme karşıdan yüklenebilir ise bu Bilgi Bankası makalesinin başında "Düzeltme karşıdan yüklenebilir" bölümü bulunur. Bu bölüm görünmüyorsa, düzeltmeyi edinmek üzere Microsoft Müşteri Hizmetleri ve Destek ekibine başvurun.

Not Ek sorunlar oluşursa veya tüm sorun giderme işlemi gerekmiyorsa, ayrı bir hizmet isteği oluşturmanız gerekebilir. Ek destek sorularına ve bu düzeltme için geçerli olmayan sorunlara normal destek ücretleri uygulanır. Microsoft Müşteri Hizmetleri ve Destek telefon numaralarının tam listesi veya ayrı bir hizmet isteği oluşturmak için, aşağıdaki Microsoft Web sitesini ziyaret edin:
http://support.microsoft.com/contactus/?ws=support
Not "Düzeltme karşıdan yüklenebilir" formunda, düzeltmenin kullanılabilir olduğu diller görüntülenir. Kendi dilinizi görmüyorsanız, bunun nedeni bu düzeltme, seçtiğiniz dil için kullanılamaz.

DOSYA BİLGİLERİ

Bu düzeltmenin İngilizce sürümü, aşağıdaki tabloda listelenen dosya özniteliklerine (veya daha yeni dosya özniteliklerine) sahiptir. Bu dosyaların tarihleri ve saatleri Koordinatlı Evrensel Saat'e (UTC) göre listelenir. Dosya bilgilerini görüntülediğinizde yerel saate dönüştürülür. UTC ve yerel saat arasındaki farkı bulmak için <a0></a0>, Denetim Masası'ndaki Tarih ve Saat aracında saat dilimi sekmesini kullanın.
   Date         Time    Version          Size      File name
   ------------------------------------------------------------
   23-Nov-2004  23:33   5.1.2600.2569    174,592   Rdbss.sys  

Durum

Microsoft, "Geçerli Olduğu Ürünler" bölümünde listelenen Microsoft ürünlerinde bu sorunun olduğunu onaylamıştır.

Daha fazla bilgi

Ek bilgi için, Microsoft Bilgi Bankası'ndaki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
824684Microsoft yazılım güncelleştirmelerini açıklamak için kullanılan standart terminolojinin açıklaması

Özellikler

Makale numarası: 885936 - Last Review: 29 Ağustos 2007 Çarşamba - Gözden geçirme: 4.2
Bu makaledeki bilginin uygulandığı durum:
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Service Pack 2 (SP2)
  • Microsoft Windows XP Home Edition Service Pack 2 (SP2)
  • Microsoft Windows XP Service Pack 1
Anahtar Kelimeler: 
kbmt kbautohotfix kbqfe kbhotfixserver kbwinxpsp2fix kbwinxppresp2fix kbfix kbbug KB885936 KbMttr
Machine-translated Article
ÖNEMLİ: Bu makale, bir kişi tarafından çevrilmek yerine, Microsoft makine-çevirisi yazılımı ile çevrilmiştir. Microsoft size hem kişiler tarafından çevrilmiş, hem de makine-çevrisi ile çevrilmiş makaleler sunar. Böylelikle, bilgi bankamızdaki tüm makalelere, kendi dilinizde ulaşmış olursunuz. Bununla birlikte, makine tarafından çevrilmiş makaleler mükemmel değildir. Bir yabancının sizin dilinizde konuşurken yapabileceği hatalar gibi, makale; kelime dağarcığı, söz dizim kuralları veya dil bilgisi açısından yanlışlar içerebilir. Microsoft, içeriğin yanlış çevrimi veya onun müşteri tarafından kullanımından doğan; kusur, hata veya zarardan sorumlu değildir. Microsoft ayrıca makine çevirisi yazılımını sıkça güncellemektedir.
Makalenin İngilizcesi aşağıdaki gibidir:885936

Geri Bildirim Ver

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com