Oprava: Chybová "Přístup odepřen" zpráva při otevření webové stránky spouštějící skript v sadě rámců v aplikaci Internet Explorer 6

Překlady článku Překlady článku
ID článku: 886184 - Produkty, které se vztahují k tomuto článku.
Důležité: Tento článek obsahuje informace o úpravě registru. Před úpravami je nutné registr zazálohovat. Seznamte se také s postupem při obnovení registru v případě, že nastane problém. Informace o zálohování, obnovení a úpravě registru naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
256986Popis registru systému Microsoft Windows
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

V aplikaci Microsoft Internet Explorer 6 otevřete webovou stránku, která obsahuje sadu rámců. Pokud je skript spuštěn v levém rámci sady rámců, zobrazí se následující chybová zpráva:
Na zobrazované webové stránce nastaly potíže, a je proto možné, že nebude zobrazena správně nebo nebude fungovat. Tuto zprávu můžete v budoucnu zobrazit poklepáním na ikonu upozornění na stavovém řádku.

Řádek: 6
Char: 2
Chyba: Přístup byl odepřen.
Kód: 0
URL: http:// URLPath /frameset.html

Příčina

K těmto potížím může dojít, jsou-li splněny následující podmínky:
  • Vlastnost Document.Domain explicitně definována ve skriptu mezi rámci. Například microsoft.com.
  • Je splněna jedna z následujících podmínek:
    • Máte Microsoft Windows XP Service Pack 2 (SP2) nainstalován.
    • Máte Internet Explorer 6 Service Pack 1 (SP1) nainstalována a nainstalujte kumulativní aktualizace zabezpečení pro aplikaci Internet Explorer (MS04-025).

      Další informace o kumulativní aktualizace zabezpečení pro aplikaci Internet Explorer (MS04-025) klepněte na následující číslo článku databáze Microsoft Knowledge Base:
      867801MS04-025: Kumulativní aktualizace zabezpečení pro aplikaci Internet Explorer

Řešení

Informace o opravě hotfix

K dispozici je podporovaná oprava hotfix od společnosti Microsoft. Tato oprava hotfix je však určena pouze k opravě problému popsanému v tomto článku. Použijte tuto opravu hotfix pouze u systémů, kde dochází k tomuto konkrétnímu problému. Tato oprava hotfix může být dále testována. Pokud Vás tento problém závažně nepostihuje, doporučujeme počkat na další aktualizaci softwaru, která bude tuto opravu hotfix obsahovat.

Pokud je oprava hotfix k dispozici ke stažení, v horní části tohoto článku je sekce "Hotfix stažení k dispozici". Pokud tento oddíl nevidíte, obraťte se na Technickou podpora společnosti Microsoft pro získání opravy hotfix.

Poznámka: Pokud vyskytnout další problémy nebo jakékoli řešení potíží je vyžadován, pravděpodobně budete muset vytvořit zvláštní požadavek na službu. Výdaje na technickou podporu se týkají dalších otázek a problémů, které nelze vyřešit pomocí této opravy konkrétní opravy hotfix. Navštivte následující web společnosti Microsoft pro získání telefonního čísla na Zákaznické centrum, nebo pokud chcete vytvořit samostatnou žádost o podporu:
http://support.microsoft.com/contactus/?ws=support
Poznámka: Zobrazí formulář "Hotfix stažení k dispozici" jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, oprava hotfix není k dispozici pro daný jazyk.

Požadavky

Musíte mít Microsoft Internet Explorer 6 SP1 nainstalovali tuto opravu hotfix.Další informace získáte v následujícím článku znalostní báze Microsoft Knowledge Base:
328548Jak získat nejnovější aktualizaci service pack pro aplikaci Internet Explorer 6

Informace o restartování

Po instalaci této opravy hotfix je třeba restartovat počítač.

Informace o nahrazení opravy hotfix

Tato oprava hotfix není nahrazena žádnou pozdější opravou hotfix.

Informace o registru

Upozornění Použijete-li Editor registru nesprávně, můžete způsobit vážné problémy, které mohou vyžadovat přeinstalaci operačního systému. Společnost Microsoft nemůže zaručit, že potíže vzniklé v důsledku nesprávného použití Editoru registru budete moci vyřešit. Editor registru používáte na vlastní nebezpečí.

Chcete-li povolit tuto opravu hotfix, postupujte takto:
  1. Ukončete aplikaci Internet Explorer 6.
  2. Klepněte na tlačítko Start, klepněte na příkaz Spustit, zadejte příkaz regedit a klepněte na tlačítko OK.
  3. Vyhledejte následující podklíč registru a klepněte na něj:
    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main
  4. V nabídce Úpravy přejděte na příkaz Nový a klepněte na příkaz klíč.
  5. Zadejte FeatureControl a stiskněte klávesu ENTER.
  6. Podklíč FeatureControl vybrána v nabídce Úpravy přejděte na podnabídku Nový a klepněte na příkaz klíč.
  7. Zadejte FEATURE_DOC_WRITE_DOMAIN_KB886184 a stiskněte klávesu ENTER.
  8. Podklíč FEATURE_DOC_WRITE_DOMAIN_KB886184 vybrána v nabídce Úpravy přejděte na podnabídku Nový a potom klepněte na příkaz Hodnota DWORD.
  9. Zadejte iexplore.exe a stiskněte klávesu ENTER.
  10. Klepněte pravým tlačítkem myši iexplore.exe a potom klepněte na příkaz změnit.
  11. V poli Údaj hodnoty zadejte 1 a potom klepněte na tlačítko OK.
  12. V nabídce soubor klepněte na příkaz Konec a ukončete Editor registru.

Informace o souboru opravy hotfix

Anglická verze této opravy hotfix má následující (nebo pozdější) atributy souborů. Data a časy jednotlivých souborů jsou uvedeny ve formátu UTC (Coordinated Universal Time). Pokud zobrazíte informace o souboru, bude převedena na místní čas. Rozdíl mezi místním ČASEM a najít, použijte kartu časové pásmo v ovládacím panelu Datum a čas.
   Date         Time   Version         Size       File name
   ---------------------------------------------------------
   09-Feb-2005  01:36  6.00.2800.1493  2,699,776  Mshtml.dll 				

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v aplikaci Microsoft Internet Explorer 6 Service Pack 1.

Další informace

Další informace o vlastnosti Document.Domain naleznete na následujícím webu:
http://msdn2.microsoft.com/en-us/library/ms533740.aspx

Vlastnosti

ID článku: 886184 - Poslední aktualizace: 15. listopadu 2007 - Revize: 1.7
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Internet Explorer 6.0 SP1
Klíčová slova: 
kbmt kbautohotfix kbie600presp2fix kbfix kbbug kbqfe kbhotfixserver KB886184 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:886184

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com