Artigo: 886209 - Última revisão: segunda-feira, 3 de Dezembro de 2007 - Revisão: 4.3

Os utilizadores não consegue ligar a computadores remotos utilizando o Windows Small Business Server 2003 Remote Web Workplace

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
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Sintomas

Quando os utilizadores tentarem ligar a um ambiente de trabalho remoto de uma rede baseada no Microsoft Windows Small Business Server 2003 utilizando uma ligação de local de trabalho remoto na Web, podem receber a seguinte mensagem de erro:
Não foi possível estabelecer ligação ao computador remoto. Assegurar que o computador remoto está em e ligado à rede Windows Small Business Server.
Este problema ocorre quando os utilizadores em ligar a ambientes de trabalho do servidor ou ligar a ambientes de trabalho do cliente no site ' local de trabalho remoto na Web ' e, em seguida, tente ligar a um dos ambientes de trabalho do servidor ou cliente ambientes de trabalho na lista.

Causa

Este problema poderá ocorrer se um processo em execução num computador baseado no Windows Small Business Server existe a escutar na porta TCP (Transmission Control Protocol) 4125. Num computador com o Windows Small Business Server, o ' local de trabalho Web remoto ' utiliza a porta TCP 4125 para a funcionalidade Ambiente de trabalho remota. Por vezes, outro processo pode utilizar a porta TCP 4125 antes de ' local de trabalho remoto na Web ' pode reclamar porta 4125. Se outro processo está a escutar esta porta, o Windows Small Business Server não é possível responder ao pedido de ligação do computador remoto.

O processo mais comuns que afirma porta TCP 4125 é Mad.exe. Mad.exe é o serviço System Attendant do Microsoft Exchange.

Resolução

Para resolver este problema, determinar que processo está a escutar na porta 4125 e, em seguida, parar desse processo de escutar nessa porta. Para o fazer, siga estes passos:
  1. No computador Windows Small Business Server, clique em Iniciar , clique em Executar , escreva cmd e, em seguida, clique em OK .
  2. Escreva o seguinte comando e, em seguida, prima ENTER:
    netstat - aon | localizar ": 4125"
    Receberá resultados semelhantes à seguinte:
    TCP IP_Address: Port IP_Address: Port LISTENING Process_Identifier
    Nota O Process_Identifier (ID) que aparece nestes resultados é o ID do processo que está a escutar na porta 4125.
  3. Clique com o botão direito do rato na barra de tarefas e, em seguida, clique em Gestor de tarefas .
  4. Clique no separador processos e, em seguida, clique em Seleccionar colunas no menu Ver .
  5. Clique para seleccionar a caixa de verificação PID (Process Identifier) e, em seguida, clique em OK .
  6. No separador processos , localize o serviço que corresponde ao ID de processo que foi devolvido pelo comando netstat .
  7. Reinicie o serviço que corresponde a este processo. Por exemplo, se o processo de Mad.exe, reinicie o serviço System Attendant do Microsoft Exchange. Para o fazer, siga estes passos:
    1. Clique em Iniciar , clique em Executar , escreva services.msc e, em seguida, clique em OK .
    2. Faça duplo clique no serviço que pretende reiniciar, certifique-se de que o nome do processo aparece na caixa caminho para o executável no separador Geral e, em seguida, clique em ' Cancelar ' .
    3. Clique com o botão direito do rato no serviço e, em seguida, clique em reiniciar .
    4. Se for pedido para reiniciar também um ou mais serviços dependentes, clique em Sim .
    Nota Se este serviço parou de responder, poderá ter de terminar o processo utilizando o Gestor de tarefas do Windows. Para tal, faça clique sobre o processo em questão, clique em Terminar o processo e, em seguida, clique em Sim .
Se detectar este problema com o processo de Mad.exe, pode modificar o intervalo de portas que é utilizado pelo protocolo de chamada (RPC, Remote Procedure Call) de procedimento remoto para excluir porta 4125. Para o fazer, siga estes passos.

importante Esta secção, método ou tarefa contém passos que indicam como modificar o registo. No entanto, poderão ocorrer problemas graves se modificar o registo de forma incorrecta. Por conseguinte, certifique-se de que segue estes passos cuidadosamente. Criar uma para protecção adicional, cópia de segurança do registo antes de o modificar. Em seguida, pode restaurar o registo se ocorrer um problema. Para obter mais informações sobre como efectuar uma cópia de segurança e restaurar o registo, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) Como efectuar uma cópia de segurança e restaurar o registo no Windows
  1. Clique em Iniciar , clique em Executar , escreva regedit e, em seguida, clique em OK .
  2. Localize a seguinte subchave do registo:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Rpc
  3. Clique com o botão direito do rato em RPC , aponte para Novo e, em seguida, clique em chave .
  4. Na caixa nova chave # 1 , escreva Internet e, em seguida, prima ENTER.
  5. Crie as seguintes entradas de três registo:
    Nome da entrada: portas
    Tipo: REG_MULTI_SZ
    Dados do valor: 4125

    Nome da entrada: PortsInternetAvailable
    Tipo: REG_SZ
    Dados do valor: N

    Nome da entrada: UseInternetPorts
    Tipo de valor: REG_SZ
    Dados do valor: S
    Para o fazer, siga estes passos:
    1. Clique com o botão direito do rato na Internet , aponte para Novo e, em seguida, clique em Valor de múltiplas cadeias .
    2. Na caixa novo valor # 1 , escreva portas e, em seguida, prima ENTER.
    3. Clique com o botão direito do rato em portas e, em seguida, clique em Modificar .
    4. Na caixa dados do valor , escreva 4125 e, em seguida, clique em OK .
    5. Clique com o botão direito do rato na Internet , aponte para Novo e, em seguida, clique em Valor da cadeia .
    6. Na caixa novo valor # 1 , escreva PortsInternetAvailable e, em seguida, prima ENTER.
    7. Clique com o botão direito do rato PortsInternetAvailable e, em seguida, clique em Modificar .
    8. Na caixa dados do valor , escreva N e, em seguida, clique em OK .
    9. Clique com o botão direito do rato na Internet , aponte para Novo e, em seguida, clique em Valor da cadeia .
    10. Na caixa novo valor # 1 , escreva UseInternetPorts e, em seguida, prima ENTER.
    11. Clique com o botão direito do rato UseInternetPorts e, em seguida, clique em Modificar .
    12. Na caixa dados do valor , escreva Y e, em seguida, clique em OK .
  6. Saia do Editor de registo e, em seguida, reinicie o computador Windows Small Business Server.

Mais Informação

Este problema também poderá ocorrer se tiver um router ou um firewall que está configurado entre o computador Windows Small Business Server e um computador cliente. Neste cenário, verifique se o router ou o firewall está configurado para permitir tráfego na porta TCP 4125 para o computador do Windows Small Business Server. Para obter informações adicionais sobre como configurar ou resolver problemas de conectividade de rede, clique números de artigo que se seguem para visualizar os artigos na base de dados de conhecimento da Microsoft:
306802  (http://support.microsoft.com/kb/306802/ ) Como configurar o Small Business Server para acesso à Internet com duas placas de rede a tempo inteiro
309633  (http://support.microsoft.com/kb/309633/ ) Como configurar um SBS para acesso à Internet a tempo inteiro com uma única placa de rede
329155  (http://support.microsoft.com/kb/329155/ ) Receber uma mensagem de erro "O servidor pode estar demasiado ocupado" quando tenta ligar aos serviços de terminal num computador com o Small Business Server 2000
154596  (http://support.microsoft.com/kb/154596/ ) Como configurar a atribuição dinâmica de portas RPC para trabalhar com firewalls

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Small Business Server 2003 Premium Edition
  • Microsoft Windows Small Business Server 2003 Standard Edition
Palavras-chave: 
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