ID do artigo: 886209 - Última revisão: segunda-feira, 3 de dezembro de 2007 - Revisão: 4.3

Os usuários não é possível se conectar a áreas de trabalho remotas usando o Windows Small Business Server 2003 Remote Web Workplace

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
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Sintomas

Quando os usuários tentam se conectar a uma área de trabalho remota em uma rede baseada no Microsoft Windows Small Business Server 2003 usando uma conexão Remote Web Workplace, eles recebem a seguinte mensagem de erro:
Não foi possível estabelecer conectividade com o computador remoto. Verifique que o computador remoto está ligado e conectado à rede Windows Small Business Server.
Esse problema ocorre quando os usuários clicar em conectar-se para áreas de trabalho do servidor ou conectar-se a áreas de trabalho do cliente no site do Remote Web Workplace e, em seguida, tentar se conectar a uma das áreas de trabalho do servidor ou áreas de trabalho cliente na lista.

Causa

Esse problema pode ocorrer se um processo que está em execução no computador com Windows Small Business Server está escutando na porta TCP (Transmission Control Protocol) 4125. Em um computador baseado no Windows Small Business Server, o Remote Web Workplace usa a porta TCP 4125 para seu recurso de área de trabalho remoto. Às vezes, outro processo pode usar a porta TCP 4125 antes Remote Web Workplace pode solicitar porta 4125. Se outro processo está escutando nessa porta, o Windows Small Business Server não pode responder à solicitação de conexão do computador remoto.

O processo mais comuns que afirma a porta TCP 4125 é MAD.exe. MAD.exe é o serviço Microsoft Exchange System Attendant.

Resolução

Para resolver esse problema, determinar qual processo está escutando na porta 4125 e parar de que o processo de escutando nessa porta. Para fazer isso, execute as seguintes etapas:
  1. No computador Windows Small Business Server, clique em Iniciar , clique em Executar , digite cmd e, em seguida, clique em OK .
  2. Digite o seguinte comando e pressione ENTER:
    netstat - aon | localizar ": 4125"
    Você receber resultados semelhantes à seguinte:
    TCP IP_Address: Port IP_Address: Port LISTENING Process_Identifier
    Observação O Process_Identifier (ID) que aparece nesses resultados é a identificação do processo que está escutando na porta 4125.
  3. Clique com o botão direito da barra de tarefas e clique em Gerenciador de tarefas .
  4. Clique na guia processos e clique em Selecionar colunas no menu Exibir .
  5. Clique para selecionar a caixa de seleção de processo (PID) e, em seguida, clique em OK .
  6. Na guia processos , localize o serviço que corresponde à identificação de processo foi retornada pelo comando netstat .
  7. Reinicie o serviço que corresponde a esse processo. Por exemplo, se o processo for MAD.exe, reinicie o serviço Microsoft Exchange System Attendant. Para fazer isso, execute as seguintes etapas:
    1. Clique em Iniciar , clique em Executar , digite services.msc e, em seguida, clique em OK .
    2. Clique duas vezes o serviço que você deseja reiniciar, certifique-se que o nome do processo aparece na caixa caminho do executável na guia Geral e, em seguida, clique em Cancelar .
    3. Clique o serviço com o botão direito do mouse e clique em Reiniciar .
    4. Se você for solicitado para reiniciar um ou mais serviços dependentes também, clique em Sim .
    Observação Se este serviço parou de responder, talvez você precise finalizar o processo usando o Windows Task Manager. Para fazer isso, clique no processo em questão, clique em Finalizar processo e, em seguida, clique em Sim .
Se você enfrentar esse problema com o processo MAD.exe, você pode modificar o intervalo de porta que é usado pelo protocolo de (RPC) chamada de procedimento remoto para excluir porta 4125. Para fazer isso, siga estas etapas.

importante Esta seção, método ou tarefa contém etapas que informam sobre como modificar o registro. No entanto, sérios problemas poderão ocorrer se você modificar o registro incorretamente. Por isso, certifique-se que você execute essas etapas cuidadosamente. Para proteção adicional, fazer backup do registro antes de modificá-lo. Em seguida, você pode restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup e restaurar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
322756  (http://support.microsoft.com/kb/322756/ ) Como fazer backup e restaurar o registro no Windows
  1. Clique em Iniciar , clique em Executar , digite regedit e, em seguida, clique em OK .
  2. Localize a seguinte subchave do Registro:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Rpc
  3. Clique com o botão direito do mouse em RPC , aponte para novo e, em seguida, clique em chave .
  4. Na caixa New Key # 1 , digite Internet e, em seguida, pressione ENTER.
  5. Crie as seguintes entradas do três registro:
    Nome da entrada: portas
    Tipo: REG_MULTI_SZ
    Dados do valor: 4125

    Nome da entrada: PortsInternetAvailable
    Tipo: REG_SZ
    Dados do valor: N

    Nome da entrada: UseInternetPorts
    Tipo de valor: REG_SZ
    Dados do valor: S
    Para fazer isso, execute as seguintes etapas:
    1. Clique com o botão direito do mouse em Internet , aponte para novo e, em seguida, clique em Valor de seqüência múltipla .
    2. Na caixa novo valor # 1 , digite portas e, em seguida, pressione ENTER.
    3. Clique com o botão direito do mouse em portas e, em seguida, clique em Modificar .
    4. Na caixa dados do valor , digite 4125 e, em seguida, clique em OK .
    5. Clique com o botão direito do mouse em Internet , aponte para novo e em Valor da seqüência .
    6. Na caixa novo valor # 1 , digite PortsInternetAvailable e, em seguida, pressione ENTER.
    7. Clique com o botão direito do mouse PortsInternetAvailable e, em seguida, clique em Modificar .
    8. Na caixa dados do valor , digite N e, em seguida, clique em OK .
    9. Clique com o botão direito do mouse em Internet , aponte para novo e em Valor da seqüência .
    10. Na caixa novo valor # 1 , digite UseInternetPorts e, em seguida, pressione ENTER.
    11. Clique com o botão direito do mouse UseInternetPorts e, em seguida, clique em Modificar .
    12. Na caixa dados do valor , digite s e, em seguida, clique em OK .
  6. Feche o Editor do Registro e em seguida, reinicie o computador Windows Small Business Server.

Mais Informações

Esse problema também pode ocorrer se você tiver um roteador ou um firewall é configurado entre o computador Windows Small Business Server e um computador cliente. Nesse cenário, verifique se o roteador ou o firewall está configurado para permitir o tráfego na porta TCP 4125 para o computador do Windows Small Business Server. Para obter informações adicionais sobre como configurar ou solucionar problemas de conectividade de rede, clique nos números abaixo para ler os artigos na Base de dados de Conhecimento da Microsoft:
306802  (http://support.microsoft.com/kb/306802/ ) Como configurar o Small Business Server para o tempo total acesso à Internet com dois adaptadores de rede
309633  (http://support.microsoft.com/kb/309633/ ) Como configurar um SBS para o tempo total acesso à Internet com um único adaptador de rede
329155  (http://support.microsoft.com/kb/329155/ ) Você receber uma mensagem de erro "O servidor pode estar muito ocupado" ao tentar se conectar aos serviços de terminal em um computador Small Business Server 2000
154596  (http://support.microsoft.com/kb/154596/ ) Como configurar a alocação de porta dinâmica da RPC para funcionar com os firewalls

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Small Business Server 2003 Premium Edition
  • Microsoft Windows Small Business Server 2003 Standard Edition
Palavras-chave: 
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Clique aqui para ver a versão em Inglês deste artigo: 886209  (http://support.microsoft.com/kb/886209/en-us/ )