Alcune regole sono disabilitate e viene visualizzato un messaggio di errore quando si tenta di creare o abilitare le regole in Outlook

Numero KB originale: 886616

Sintomi

Dopo l'aggiornamento a Office Outlook 2003 (o versione successiva), è possibile notare che alcune regole sono disabilitate e non possono essere abilitate. Altre regole funzionano correttamente. Se si tenta di abilitare le regole disabilitate, viene visualizzato il messaggio di errore seguente:

Una o più regole non possono essere caricate nel server Exchange e sono state disattivate. Ciò potrebbe essere dovuto al fatto che alcuni parametri non sono supportati o che non è disponibile spazio sufficiente per archiviare tutte le regole.

Causa

  • Cassette postali in Microsoft Exchange Server 2007, Exchange Server 2010 o Exchange Server 2013

    Questo comportamento si verifica se le regole presenti nella cassetta postale superano la quota di regole stabilita per la cassetta postale. Il limite di dimensioni delle regole per le cassette postali in Exchange Server 2007 (e versioni successive) ha dimensioni predefinite di 64 KB per cassetta postale. Anche il limite totale delle dimensioni delle regole è personalizzabile fino a 256 KB per cassetta postale.

  • Cassette postali in Exchange Server 2003

    Questo comportamento si verifica se le regole presenti nella cassetta postale superano le dimensioni di 32 kilobyte (KB). Il limite totale delle dimensioni delle regole per le cassette postali in Exchange Server 2003 è di 32 KB. Il limite di regole per Exchange 2003 non può essere modificato.

In Outlook 2003 e versioni successive, le dimensioni delle regole sono aumentate principalmente per fornire supporto per il formato Unicode.

Soluzione alternativa

Se la cassetta postale è in Exchange Server 2007 o versioni successive, è possibile chiedere all'amministratore di Exchange di aumentare la quota delle regole per la cassetta postale.

Il comando di esempio seguente imposta la quota delle regole sul valore massimo di 256 KB.

Set-Mailbox john@contoso.com -RulesQuota:256kb

Il comando di esempio seguente consente di visualizzare la quota delle regole correnti per una cassetta postale.

Get-Mailbox john@contoso.com |FL displayname, rulesquota

Se l'amministratore di Exchange non può aumentare la quota delle regole per la cassetta postale, provare una delle soluzioni alternative seguenti applicabili a tutte le versioni di Exchange.

Per risolvere questo comportamento in modo che le regole vengano ripristinate, usare uno o più dei metodi seguenti per ridurre le dimensioni delle regole esistenti.

Metodo 1

Rinominare le regole con un nome più breve. Per rinominare una regola in Outlook, seguire questa procedura.

Per Outlook 2010 e versioni successive:

  1. Nella scheda File fare clic su Info.
  2. Fare clic su Gestisci regole e avvisi.
  3. Nella scheda Regole di posta elettronica fare clic sulla regola da rinominare.
  4. Fare clic su Modifica regole e quindi su Rinomina regola.
  5. Digitare un nuovo nome più breve per la regola e quindi fare clic su OK.
  6. Fare clic su OK per chiudere la finestra di dialogo Regole e avvisi .

Per Outlook 2007 e Outlook 2003:

  1. Scegliere Regole e avvisi dal menu Strumenti.
  2. Nella scheda Regole di posta elettronica fare clic sulla regola da rinominare.
  3. Nell'elenco Modifica regola fare clic su Rinomina regola.
  4. Digitare un nuovo nome più breve per la regola e quindi fare clic su OK.
  5. Fare clic su OK per chiudere la finestra di dialogo Regole e avvisi .

Metodo 2

Eliminare le regole precedenti. Per eliminare una regola in Outlook, seguire questa procedura:

Per Outlook 2010 e versioni successive:

  1. Nella scheda File fare clic su Info.
  2. Fare clic su Gestisci regole e avvisi.
  3. Nella scheda Regole di posta elettronica fare clic sulla regola da rinominare.
  4. Fare clic sul pulsante Elimina e quindi su per confermare l'eliminazione.
  5. Fare clic su OK per chiudere la finestra di dialogo Regole e avvisi .

Per Outlook 2007 e Outlook 2003:

  1. Scegliere Regole e avvisi dal menu Strumenti.
  2. Nella scheda Regole di posta elettronica fare clic sulla regola da eliminare.
  3. Fare clic su Elimina e quindi su per confermare l'eliminazione.
  4. Fare clic su OK per chiudere la finestra di dialogo Regole e avvisi .

Metodo 3

Combinare regole simili per ridurre le dimensioni complessive delle regole. Se possibile, combinare regole simili per ridurre le dimensioni complessive delle regole. Dopo aver combinato regole simili, eliminare le regole che non sono più necessarie. Per modificare una regola esistente in Outlook, seguire questa procedura.

Per Outlook 2010 e versioni successive:

  1. Nella scheda File fare clic su Info.
  2. Fare clic su Gestisci regole e avvisi.
  3. Nella scheda Regole di posta elettronica fare clic sulla regola da rinominare.
  4. Fare clic su Modifica regola e quindi su Modifica impostazioni regola.
  5. Modificare la regola in base alle esigenze.
  6. Fare clic su OK per chiudere la finestra di dialogo Regole e avvisi .

Per Outlook 2007 e Outlook 2003:

  1. Scegliere Regole e avvisi dal menu Strumenti.

  2. Nella scheda Regole di posta elettronica fare clic sulla regola da modificare.

  3. Nell'elenco Modifica regola fare clic su Modifica impostazioni regola.

    Modificare la regola in base alle esigenze.

  4. Al termine, fare clic su Fine e quindi su OK per chiudere la finestra di dialogo Regole e avvisi .

Nota

Se la regola è solo client, è necessario fare clic su OK due volte per chiudere la finestra di dialogo Regole e avvisi .

Metodo 4

Spostare il file delle cartelle personali (pst) in un percorso con il nome del percorso più breve. Se sono presenti regole che spostano i messaggi di posta elettronica in un file pst, spostare il file pst in un percorso con il nome di percorso più breve possibile. Ad esempio, spostare il file pst in un percorso come C:\<file_name.pst>. Per spostare il file pst in Outlook, seguire questa procedura:

  1. Nel riquadro di spostamento fare clic con il pulsante destro del mouse su Cartelle personali o sul nome della cartella visualizzato per il file pst e quindi scegliere Proprietà per <folder_name>.

    Nota

    Questa cartella sarà sempre una cartella di primo livello nel riquadro di spostamento, in Posta.

  2. Nella scheda Generale fare clic su Avanzate.

  3. Nella casella di testo Nome file prendere nota del percorso completo e del nome file del file pst.

  4. Fare clic su OK due volte per chiudere la <finestra di dialogo Proprietà folder_name>.

  5. Uscire da Outlook.

  6. Usare Microsoft Windows Explorer per spostare il file pst nel nuovo percorso.

    Per impostazione predefinita, il percorso di un file pst è l'unità:\Documents and Settings\<user_name>\Local Settings\Application Data\Microsoft\Outlook. Il percorso predefinito è una cartella nascosta. Per usare Esplora risorse per individuare questa cartella, devi prima attivare la visualizzazione delle cartelle nascoste. A tal fine, attenersi alla seguente procedura:

    1. In Esplora risorse fare clic su Opzioni cartella dal menu Strumenti .

    2. Fare clic sulla scheda Visualizza .

    3. Nella sezione Impostazioni avanzate fare clic su Mostra file e cartelle nascosti in Cartelle e file nascosti.

    4. Se si desidera visualizzare tutte le estensioni di file, fare clic per deselezionare la casella di controllo Nascondi estensioni per i tipi di file noti in File e cartelle.

      Nota

      Le cartelle nascoste vengono visualizzate in grigio per indicare che non sono cartelle tipiche.

    5. Fare clic su OK.

  7. Usare uno dei metodi seguenti per aprire l'elemento di posta in Pannello di controllo:

    • A tale scopo, in un computer basato su Windows XP o in un computer basato su Windows Server 2003, fare clic su Start, fare clic su Pannello di controllo, su Account utente e quindi su Posta elettronica.

      Nota

      Se si usa la visualizzazione classica, fare clic su Start, fare clic su Pannello di controllo e quindi fare doppio clic su Posta.

    • Per eseguire questa operazione in un computer basato su Microsoft Windows 2000, fare clic su Start, scegliere Impostazioni, fare clic su Pannello di controllo e quindi fare doppio clic su Posta.

  8. Fare clic su Mostra profili e quindi sul profilo che contiene il file pst.

  9. Fare clic su Proprietà e quindi su File di dati.

  10. Fare clic sul file di dati pst spostato e quindi fare clic su Impostazioni.

  11. Quando viene richiesto che il file di dati non sia stato trovato nel percorso precedente, fare clic su OK.

  12. Individuare e quindi fare clic sul file con estensione pst nel percorso della nuova cartella e quindi fare clic su Apri.

  13. Fare clic su OK e quindi su Chiudi due volte.

  14. Fare clic su OK.

  15. Chiudere Pannello di controllo.

  16. Riavviare Outlook.

Metodo 5

Deselezionare la casella di controllo solo in questo computer . Se si usa una regola per spostare i messaggi di posta elettronica in un file pst, fare clic per deselezionare la casella di controllo solo in questo computer, a meno che non si stia accedendo alla posta elettronica Exchange Server da computer client diversi. Per eseguire questa operazione in Outlook, seguire questa procedura:

Per Outlook 2010 e versioni successive:

  1. Nella scheda File fare clic su Info.
  2. Fare clic su Gestisci regole e avvisi.
  3. Nella scheda Regole di posta elettronica fare clic sulla regola da rinominare.
  4. Fare clic su Modifica regola e quindi su Modifica impostazioni regola.
  5. Fare clic per deselezionare la casella di controllo Solo in questo computer se la casella di controllo è selezionata.
  6. Completare la Procedura guidata regole. Fare clic su OK per chiudere la finestra di dialogo Regole e avvisi .

Per Outlook 2007 e Outlook 2003:

  1. Scegliere Regole e avvisi dal menu Strumenti.

  2. Nella scheda Regole di posta elettronica fare clic sulla regola da modificare.

  3. Nell'elenco Modifica regola fare clic su Modifica impostazioni regola.

  4. Se selezionata, fare clic per deselezionare la casella di controllo solo in questo computer .

  5. Completare la Procedura guidata regole.

  6. Fare clic su OK per chiudere la finestra di dialogo Regole e avvisi .

    Nota

    Se si usano regole solo client che puntano a file di risorse locali, ad esempio lo spostamento di elementi in una cartella in un file pst e si usano più computer per accedere a Microsoft Outlook, potrebbero verificarsi conflitti di regole. Di conseguenza, alcune regole solo client possono essere disabilitate.