Id. de artículo: 886630 - Última revisión: viernes, 02 de febrero de 2007 - Versión: 2.2

Recibe un mensaje de error cuando instala un programa que usa Windows Installer en Windows XP

Nota acerca de su sistema operativoEste artículo se aplica a un sistema operativo distinto al que usa. El contenido del artículo que puede que no sea importante para usted, se deshabilitará

En esta página

Expandir todo | Contraer todo

Síntomas

Cuando intenta instalar un programa que utiliza Windows Installer en Microsoft Windows XP, el programa no se instala y puede aparecer un mensaje de error similar a uno de los mensajes siguientes:
No se tiene acceso al servicio de Windows Installer. Póngase en contacto con el personal de soporte técnico para comprobar que el servicio de Windows Installer está registrado correctamente.
No puede iniciarse el servicio de Windows Installer. Póngase en contacto con el personal de soporte técnico.
Error interno

Causa

Este problema puede producirse si los archivos de Windows Installer no están presentes o están dañados.

Solución

Para resolver este problema, utilice uno o varios de los métodos siguientes en el orden indicado.

Método 1: vuelva a registrar Windows Installer

  1. Cierre todos los programas de Windows.
  2. Haga clic en Inicio y en Ejecutar, escriba msiexec /unregister en el cuadro Abrir y haga clic en Aceptar.
  3. Haga clic en Inicio y en Ejecutar, escriba msiexec /regserver en el cuadro Abrir y haga clic en Aceptar.
  4. Reinicie el equipo.

Método 2: quite los archivos de Windows Installer

  1. Cierre todos los programas de Windows.
  2. Haga clic en Inicio y en Ejecutar, escriba msiexec /unregister en el cuadro Abrir y haga clic en Aceptar.
  3. En el Explorador de Windows, cambie el nombre de los siguientes archivos en la carpeta %systemroot%\System32:
    • Msi.dll
    • Msihnd.dll
    • Msiexec.exe
    Nota
    Si no puede cambiar el nombre de estos archivos, intente cambiarlos en un símbolo del sistema. Para iniciar un símbolo del sistema, haga clic en Inicio y en Ejecutar, escriba cmd en el cuadro Abrir y haga clic en Aceptar.
  4. Reinicie Windows XP.

Método 3: reinicie Windows XP en el Modo a prueba de errores

Reinicie Windows XP en el modo a prueba de errores, y vuelva a intentar los métodos 1 y 2 en el orden en que se muestran. Para obtener más información acerca de cómo reiniciar Windows XP en modo a prueba de errores, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
316434  (http://support.microsoft.com/kb/316434/ ) Cómo realizar la solución de problemas avanzados de inicio limpio en Windows XP

Más información

Para obtener más información acerca de Windows Installer, visite el siguiente sitio Web de Microsoft:
http://msdn2.microsoft.com/en-us/library/aa372866.aspx (http://msdn2.microsoft.com/en-us/library/aa372866.aspx)

La información de este artículo se refiere a:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Palabras clave: 
kbtshoot kbprb KB886630