文書番号: 886630 - 最終更新日: 2007年1月8日 - リビジョン: 2.1

Windows XP で Windows インストーラを使用するプログラムをインストールしようとするとエラー メッセージが表示される

目次

すべて展開する | すべて折りたたむ

現象

Microsoft Windows XP で Windows インストーラを使用するプログラムをインストールしようとすると、プログラムがインストールされず、以下のいずれかのようなエラー メッセージが表示されることがあります。
Windows インストーラ サービスにアクセスできませんでした。サポート担当者に問い合わせて、Windows インストーラ サービスが正しく登録されているかどうかを確認してください。
Windows インストーラ サービスを起動できませんでした。サポート担当者にお問い合わせください。
内部エラー

原因

この問題は、Windows インストーラのファイルが欠落または破損している場合に発生する可能性があります。

解決方法

この問題を解決するには、以下の 1 つ以上の方法を記載順に実行します。

方法 1 : Windows インストーラを登録する

  1. すべての Windows プログラムを終了します。
  2. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。[名前] ボックスに msiexec /unregister と入力し、[OK] をクリックします。
  3. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。[名前] ボックスに msiexec /regserver と入力し、[OK] をクリックします。
  4. コンピュータを再起動します。

方法 2 : Windows インストーラのファイルを削除する

  1. すべての Windows プログラムを終了します。
  2. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。[名前] ボックスに msiexec /unregister と入力し、[OK] をクリックします。
  3. エクスプローラで、Windows\System32 フォルダにある以下のファイルの名前を変更します。
    • Msi.dll
    • Msihnd.dll
    • Msiexec.exe
    : これらのファイルの名前を変更できない場合は、コマンド プロンプトでファイル名を変更してみてください。コマンド プロンプトを起動するには、[スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックして、[名前] ボックスに cmd と入力し、[OK] をクリックします。
  4. Windows XP を再起動します。

方法 3 : Windows XP をセーフ モードで再起動する

Windows XP をセーフ モードで再起動してから、方法 1 と方法 2 を記載順に再試行します。 Windows XP をセーフ モードで再起動する方法の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
316434? (http://support.microsoft.com/kb/316434/ ) [HOWTO] Windows XP で高度なクリーン ブート トラブルシューティングを実行する

詳細

Windows インストーラの詳細については、次のマイクロソフト Web サイトを参照してください。
http://msdn2.microsoft.com/en-us/library/aa372866.aspx (http://msdn2.microsoft.com/en-us/library/aa372866.aspx)

この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
キーワード:?
kbtshoot kbprb KB886630
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"
 

サポート技術情報の翻訳

 

Related Support Centers