Oprava: Tisk relací Host může přestat reagovat (zablokuje se) při povolena možnost Request závazné odpověď v Host Integration Server

Překlady článku Překlady článku
ID článku: 886666 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Microsoft Host Integration Server hostitelem Tisk relací, které mají povolena možnost Request závazné odpověď může přestat reagovat (zablokuje se). Po výskytu tohoto problému nelze odeslat nový hostitel tiskové úlohy k tisku relaci hostitele.

Příčina

K tomuto problému dochází, protože tiskový server neodešle odpověď na hostitelský systém po dokončení tiskové úlohy, pokud je čas mezi tiskové úlohy je více než časový limit je nakonfigurována možnost po zakončení projektu, zpoždění uzavření tiskárny v relaci tisku. Protože hostitelský systém čeká na odpověď označuje, že tisk dokončení předchozí úlohy, tiskové relaci nelze odeslat další tiskové úlohy. Toto chování způsobí tisku relace přestane reagovat.

Řešení

Host Integration Server 2000

Informace o aktualizaci Service Pack

Tento problém vyřešíte pomocí nejnovější aktualizace service pack pro Microsoft Host Integration Server 2000. Další informace naleznete následujícím článku znalostní databáze Microsoft Knowledge Base:
328152Jak získat nejnovější aktualizaci service pack pro Host Integration Server 2000

Informace o opravě hotfix

Anglická verze této opravy hotfix má následující (nebo pozdější) atributy souborů. Data a časy jednotlivých souborů jsou uvedeny ve formátu UTC (Coordinated Universal Time). Pokud zobrazíte informace o souboru, bude převedena na místní čas. Rozdíl mezi místním ČASEM a najít, použijte kartu časové pásmo v ovládacím panelu Datum a čas.
   Date         Time   Version     Size     File name
   -----------------------------------------------------
   29-Sep-2004  16:34  5.0.0.1002   20,752  Msg5250.dll
   29-Sep-2004  16:34  5.0.0.1002  250,128  Ppd3270.dll
   29-Sep-2004  16:34  5.0.0.1002  139,536  Ppd5250.dll
   29-Sep-2004  16:34  5.0.0.1002   49,424  Prmngext.dll
   29-Sep-2004  16:34  5.0.0.1002  209,168  Snacfg.dll
   29-Sep-2004  16:34  5.0.0.1002   24,848  Snaxlt.dll
   29-Sep-2004  16:34  5.0.0.1002  282,896  Winvprt.dll
   29-Sep-2004  16:34  5.0.0.1002   57,616  Pdfcomp.exe
   29-Sep-2004  16:34  5.0.0.1002   94,480  Snaprint.exe

				
Poznámka: Vzhledem k závislostem souborů může nejnovější oprava obsahující tyto soubory obsahovat také další soubory.

Host Integration Server 2004

K dispozici je podporovaná oprava hotfix od společnosti Microsoft. Tato oprava hotfix je však určena pouze k opravě problému popsanému v tomto článku. Použijte tuto opravu hotfix pouze u systémů, kde dochází k tomuto konkrétnímu problému. Tato oprava hotfix může být dále testována. Pokud Vás tento problém závažně nepostihuje, doporučujeme počkat na další aktualizaci softwaru, která bude tuto opravu hotfix obsahovat.

Pokud je oprava hotfix k dispozici ke stažení, v horní části tohoto článku je sekce "Hotfix stažení k dispozici". Pokud tento oddíl nevidíte, obraťte se na Technickou podpora společnosti Microsoft pro získání opravy hotfix.

Poznámka: Pokud vyskytnout další problémy nebo jakékoli řešení potíží je vyžadován, pravděpodobně budete muset vytvořit zvláštní požadavek na službu. Výdaje na technickou podporu se týkají dalších otázek a problémů, které nelze vyřešit pomocí této opravy konkrétní opravy hotfix. Navštivte následující web společnosti Microsoft pro získání telefonního čísla na Zákaznické centrum, nebo pokud chcete vytvořit samostatnou žádost o podporu:
http://support.microsoft.com/contactus/?ws=support
Poznámka: Zobrazí formulář "Hotfix stažení k dispozici" jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, oprava hotfix není k dispozici pro daný jazyk.

Anglická verze této opravy hotfix má následující (nebo pozdější) atributy souborů. Data a časy jednotlivých souborů jsou uvedeny ve formátu UTC (Coordinated Universal Time). Pokud zobrazíte informace o souboru, bude převedena na místní čas. Rozdíl mezi místním ČASEM a najít, použijte kartu časové pásmo v ovládacím panelu Datum a čas.
   Date         Time   Version     Size     File name
   -----------------------------------------------------
   29-Sep-2004  17:33  6.0.1905.0   29,184  Msg5250.dll
   29-Sep-2004  17:33  6.0.1905.0   39,424  Pdfcomp.exe
   29-Sep-2004  17:33  6.0.1905.0  183,808  Ppd3270.dll
   29-Sep-2004  17:33  6.0.1905.0   93,184  Ppd5250.dll
   29-Sep-2004  17:33  6.0.1905.0   33,280  Prmngext.dll
   29-Sep-2004  17:33  6.0.1905.0  167,936  Snacfg.dll
   29-Sep-2004  17:33  6.0.1905.0   61,440  Snaprint.exe
   29-Sep-2004  17:33  6.0.1905.0   12,288  Snaxlt.dll
   29-Sep-2004  17:33  6.0.1905.0  194,560  Winvprt.dll
				

Poznámka: Vzhledem k závislostem souborů může nejnovější oprava obsahující tyto soubory obsahovat také další soubory.

Jak potíže obejít

Tento problém vyřešit, zakažte jednu nebo obě následující možnosti konfigurace ve vlastnostech tisku relace:
  • Vyžádat odpověď závazné
  • Po úlohy zakončení zpoždění uzavření tiskárny

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části Informace v tomto článku jsou určeny pro produkt.Tento problém byl opraven v Microsoft Host Integration Server 2000 Service Pack 2.

Další informace

Tiskové služby hostitele (Snaprint.exe) v SNA Server 4.0 a dřívějších verzích otevře všechny definované tiskáren, které jsou používány Tisk relací nakonfigurovanému hostiteli spuštění služby. Byla přidána možnost Po úlohy zakončení zpoždění uzavření tiskárny v Host Integration Server 2000 a optimalizovat výkon a systémové prostředky. Pokud tiskárna je vždy k dispozici, jsou spotřebovány systémové prostředky jako například tiskárny úchyty. Však Pokud je tiskárna neustále otevřené a uzavřené s každou tiskovou úlohu, která je odeslána, utrpí výkonu. Nastavením časového limitu možnost po zakončení projektu, zpoždění uzavření tiskárny tiskárny zůstane k dispozici pro tiskové úlohy, které jsou odeslány blízko sebe ke zlepšení výkonu a bude během bez obsazené časy uvolnit prostředky zavřete tiskárny.

Ve výchozím nastavení je povolena možnost po zakončení projektu, zpoždění uzavření tiskárny a nastavte časový limit na 10 sekund na Host Integration Server 2004 a Host Integration Server 2000.

Obě možnosti Request závazné odpověď a po zakončení projektu, zpoždění uzavření tiskárny jsou povoleny na hostitele tisku relace dojde k problém popsaný v části "Příznaky". Pokud více hostitele tiskové úlohy jsou odeslány do hostitele vytisknout relace a zpoždění mezi každé tiskové úlohy je menší než časový limit, která je určena možnost časového limitu po zakončení projektu, zpoždění uzavření tiskárny, vytištěny všechny tiskové úlohy. Navíc hostitel tisková služba odešle odpověď na hostitelský systém označit každou úlohou vytištěny úspěšně. Možnost Request závazné Response poskytuje tuto funkci.

Pokud více hostitele tiskové úlohy jsou odeslány do relace tisku hostitele a zpoždění mezi jeden nebo více tiskových úloh je více než časový limit možnost Po úlohy zakončení zpoždění uzavření tiskárny, tiskové úlohy jsou vytištěny úspěšně. Tiskové služby hostitele neodešle odpověď na hostitelský systém tisková úloha byla odeslána po vypršení časového limitu po zakončení projektu, zpoždění uzavření tiskárny. Toto chování způsobí tisku relace přestane reagovat, protože hostitelský systém neodešle žádné další tiskové úlohy k tisku relaci během čeká na odpověď na předchozí tiskové úlohy.

Vlastnosti

ID článku: 886666 - Poslední aktualizace: 4. prosince 2007 - Revize: 2.6
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Host Integration Server 2000 Standard Edition
  • Microsoft Host Integration Server 2000 Service Pack 1
  • Microsoft Host Integration Server 2004 Standard Edition
Klíčová slova: 
kbmt kbautohotfix kbhotfixserver kbqfe kbhostintegserv2000presp2fix kbfix kbbug KB886666 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:886666

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com